[8.2.3.1] LibreELEC 8.2 for S905/S905X

  • Verdilak - Does the rgb part work, or is it a leftover from previous versions? According to page 1 it's broken, that's why I'm asking.

  • I just saw today that Samba (CIFS) does not work. It was working alright but somewhere between 8.1.7 and 8.1.8 broke and now i cannot see the NAS share. The folder inside Kodi behaves like a normal folder and everything is saved locally.


    I use this:


    [Unit]

    Description=cifs mount script

    Requires=network-online.service

    After=network-online.service

    Before=kodi.service


    [Mount]

    What=//10.0.0.109/Videos/LibreELEC

    Where=/storage/libreelec

    Options=username=******,password= *****,rw

    Type=cifs


    [Install]

    WantedBy=multi-user.target

  • It's my first time that I checked this on 8.1.8 and didn't work for me either.

    Edited once, last by quitroot ().

  • A bit of a n00b question.

    I've just gotten a (proper) 4k HDR tv with an amplifier which also supports these standards.

    I've configured Kodi for 1080p 60 Hz as I read that the upscaling on newer/more expensive tv's are better than these s905x boxes (and I watch almost only 1080p).

    When I watch a 4k HDR movie, the amp displays:

    4k (3840x2160) 50 Hz

    YCbCr420 24 bit


    Is this the best picture I can get? Or could I try 442 or any other optimization/experimentation for a better picture. It's quite good now but I feel the build in YouTube App has better quality

  • I changed it to v3 same result.

    as far as i know there's two places where you can set smb version. In the libreelec settings (min-max) and in kodi service settings (cant check right now but i believe that is correct).


    I set the LE config to min: smbv2, max: smbv3. In Kodi services i set max to smbv3. That works here.


    Also, i think that some nas systems require smbv1 to function

    'You're like a child who wanders into the middle of a movie and wants to know -..' ~ Walter Sobchak (The Big Lebowski)

  • as far as i know there's two places where you can set smb version. In the libreelec settings (min-max) and in kodi service settings (cant check right now but i believe that is correct).


    I set the LE config to min: smbv2, max: smbv3. In Kodi services i set max to smbv3. That works here.


    Also, i think that some nas systems require smbv1 to function

    All set as you mention. Still no change.

    The wird thing is that I can get reached to the folder with kodi file manager.

  • All set as you mention. Still no change.

    The wird thing is that I can get reached to the folder with kodi file manager.

    It seems to me that there is a new "samba.conf.sample" file in the .config folder. Save it as "samba.conf" replacing the old one.

  • I have 8.0.2e (kszaq Version) installed right now, what is the „easiest“ way to update to 8.1.8?

    Copy the .tar file and the dtb into the .update folder and reboot.

    RPI3 1GB, Z4 RK3368 1GB, MINI MX-G 2GB, Mini M8S II (coreelec.org 9.2.1), H96 Pro (coreelec.org 9.2.1), ODORID N2 (coreelec.org 9.2.1), VIM3 PRO (coreelec.org 9.2.1), Beelink GT King (coreelec.org 9.2.1), Denon AVR-X2600H, LG 60SJ810V
    pel.hu

  • All set as you mention. Still no change.

    The wird thing is that I can get reached to the folder with kodi file manager.

    That's strange. I had something similar. See if you can force a higher Samba version on your NAS

  • That's strange. I had something similar. See if you can force a higher Samba version on your NAS

    it's a router (tp-link vr600) connect to usb drive. not a NAS.


    this is what I have done:


    1. create a file name: storage-vr600.mount

    with this text (password and username are hidden for security reasons):

    [Unit]

    Description=cifs mount script

    Requires=network-online.service

    After=network-online.service

    Before=kodi.service


    [Mount]

    What=//192.168.1.1/volume(sda1)/torrents

    Where=/storage/vr600

    Options=username=****,password=****,rw

    Type=cifs


    [Install]

    WantedBy=multi-user.target


    2. put it at my ki pro to this folder :

    /storge/.config/system.d/


    3. send this command through ssh:


    systemctl enable storage-vr600.mount


    4. reset the device.


    5. then I saw the folder buy it's empty.


    uploaded router setting,


  • Okay, I've enabled debug logging and turned my box off for a while. After powering on, it froze at the Libreelec splash screen. I hope there's something useful in them.

  • Yes, you are correct. I will fix this in next build.

  • A little bit off topic,


    I'm using WOL (wake on lan) to wake up my server where my multimedia files.

    It works great.


    It's possible to send some commands to shutting down server at same time i shutdown my Android box?

    - Box Android Mini M8S II (Amlogic S905X, 2GB RAM, 8GB ROM)
    - Ugreen USB Ethernet Adapter Usb 3.0 2.0 [ASIX AX88179 Chipset]
    - LibreELEC 8.2 (Nougat Kernel) builds aimed at devices based on Amlogic S905/S905X SoC.

  • It should be possible by running a shutdown script on your box incl. the commands to ssh and shutdown your server (e.g. poweroff command).