[8.2.2.3] LibreELEC 8.2 for S912

  • A big thanks to you all !! I was a newbe regarding libreelec and kodi. But the Beelink GT1 Ultimate did not work on android (7.1) with Kodi, audio passtrough did not work (no DTS).


    But using a fast micro usb SD card, and using the LE USB Creator, I installed the LibreELEC-S912.arm-8.2-8.2.2.3


    Then I searched for the right device tree, which I thought would be the 3/32G variant. But with that the Beelink did not boot.

    The I added the gxm_q200_2g.dtb and renamed it to dtb.img and added it on the micro usb.



    And finally tried to boot the Beelink again, with some searching for the reset switch. Which is located at the bottom, and only reachable with a paperclip!

    forum.libreelec.tv/core/attachment/3489/


    And yes, LE and Kodi where live. on 1080p/60Hz

    With audio/DTS passtrough via pcm and full functionality (ethernet interface, remote control, wifi, usb).


    For me this is currently fine, and i am not sending the Beelink GT1 Ultimate back to GearBest.



    I did not try H265 and higher display resolution yet. Also did not try downscaling from 2/4K to 1080p yet.

  • Does 4k playback work on this build properly? I have a h96 pro tv dongle and 4k playback is stuttering.

  • amazing the new build with the subtitle fix, i was waiting for that (i was using hw accelleration off until now), works perfectly on my Tanix TX8 Max, thank you soo much :D

  • Guys please help me out, i have a U9-H with 8.2.2.4 overclock, everything works perfect but still no DTS-HD MA Passthrough?


    its a 55OLEDB7V


    if i plug a usb with the DTS test file it works and i get infomation that DTS is on,


    but kodi i just get no sound whatsoever, the only way i can get it to work is to turn off DTS/DTS HD-MA passthrough?


    any ideas why, its really bugging me its the only thing thats failing on this whole setup


    -----------


    Have tried:


    Different HDMI cables - nope

    PCM / HDMI mode - nope

    flicked every swtich in the system/audio section - nothing


    Edited 3 times, last by ersenos ().

  • Hi


    You can not passthrough DTS HD-MA to your 55OLEDB7V because TV can not read this type of lossless audio stream. HDMI handchake information from your TV to the U9-H i saying " no I can not do this " and therefore no sound.


    When you use the USB test drive. The TV is decoding the core DTS file inside the container and you got DTS sound. But this is not lossless DTS-HD MA. It is corse DTS. This is for backwards compatibility.

  • Hi


    You can not passthrough DTS HD-MA to your 55OLEDB7V because TV can not read this type of lossless audio stream. HDMI handchake information from your TV to the U9-H i saying " no I can not do this " and therefore no sound.


    When you use the USB test drive. The TV is decoding the core DTS file inside the container and you got DTS sound. But this is not lossless DTS-HD MA. It is corse DTS. This is for backwards compatibility.

    oh wow, thanks for saving me alot of time, guess everything it working as it should


    thankyou very much for taking the time mate

  • Hello everyone!


    My device is Beelink GT1 2GB/16GB with LibreELEC 8.2.2.3. I always use it with custom remote (rii 25a), and it worked like a charm, but now my custom remote is broken and I've noticed that stock remote does not work at all. It can turn box on, but in LibreELEC nothing works. Can anyone give me an advice what can it be and what to do?:)

  • oh wow, thanks for saving me alot of time, guess everything it working as it should


    thankyou very much for taking the time mate

    note that you have sounds on the "Dolby Atmos" second film.

    But it doesn't work on the TrueHD track, it works because the second film have a E-AC-3 (DD+) encoded track.

    Minix U9-H LibreElec 8.2 - Yamaha RX-V681 - LG 55C7V

  • I have an LG Oled55C6V I think it is almost the same as 55OLEDB7V.

    I am using 8.2.4 Subtitles-ff

    I read very much on this topic that other people have DTS pass through working

    I have a H96 Pro+ but I can 't get it working.

    The info on TV always shows "pcm"

    I think the problem is not in the TV because with my old Raspberry Pi with OpenElec DTS passthrough was working fine.

    You can simply check this by putting the cursor on the hdmi logo

  • johnberg


    The B6 is not really the same.

    The B7 (except B7A) supports passthrough for many formats, maybe even for them all, the B6 doesn't.

    But either way, if you still get sound with passthrough but it says PCM, then it's not working at all.

    Make sure that you don't have synchronize audio to display (or something of that sort) enabled in the Video settings.

  • Make sure that you don't have synchronize audio to display (or something of that sort) enabled in the Video settings.

    Sorry but I really can't find this setting in settings>system>video


    My settings are the same as you can see on page 56 post 1003 of this topic.

    This is exact the same as in my Raspberry Pi.

    But no DTS or Dolby 5.1 passthrough on my H96 Pro+


    Very strange because there are people who have this working.


    Any idea why??:cry:

  • johnberg


    Settings --> Player --> Videos -> Sync playback to display.

    Make sure that this is UNCHECKED.

    GREATFULL thanks the Coolest!! :thumbup::)I was looking so long for this and never would have found that this important audio-setting was located in the video-settings.

    I always thougt that sync playback to display was a crucial setting for the frameratesync, but now I see that this is only "Adjust display refresh rate" on start/stop.

    I found that in my case it is also important to disable DTS HD and True HD capable (in Audio settings) otherwise you don't have any sound at all (when playing DTS HD or True HD).

    DTS HD MA is converted to common DTS I think and True HD is converted to PCM stereo, the last is a little bit a pity, but never mind sometimes there are more soundtracks.

    I have a Logitec Z5500 connected with optical Toslink to my LG TV, still sounds fine for me

    Edited 2 times, last by johnberg ().

  • In 8.1.7 you can enable suspend/sleep mode manually:

    1. Go to \\Configfiles\sleep.conf.d (in Windows) or /storage/.config/sleep.conf.d (over SSH).
    2. Rename sleep.conf.sample to sleep.conf
    3. Open sleep.conf and remove this line: SuspendMode=false
    4. Reboot, enjoy.

    using 8.2.5 i can't find a sleep.conf.sample in any folder of my x86 version. is there another way to enable hibernate mode?


    edit: oh looks like the wrong thread for this question