[] LibreELEC 8.2 for S912

  • Mine is set at 50Hz for 25fps TV viewing.

    This is the current img.gz I'm using:


    I used the .tar to update to 8.2-chroma-422.

    Just tried to use the image file, but my Minix U9 doesn't boot with it. Tried it with the device tree I used for the and with the version for 8.90.5 but both didn't work. What am I doing wrong?

    Edited 3 times, last by mule ().

  • wrxtasy

    Now install went flawless, but the issue with 720p TV channels has not been solved: unwatchable because of massive frame drops although the player info states HW acceleration is being used.

    Any further ideas?
    It is so frustrating: With your 8.x version 4K/HDR is working perfectly, but 720p channels not. With the original the TV channels work perfectly, but 4k/HDR not.

    Edited once, last by mule ().

  • wrxtasy ive tried your 4:4.4 build and 4:2:2 with the added kodi menu for 10bit and with both of them I’ve tried all the dtbs included in the builds and I’ve tried kszaqs and the Leia build dtb but I always get a black screen after the libre elec splash screen.. I’m suspecting my hdmi cable isn’t up to scratch although it was sold as hdmi 2.0b it’s not premium certified, before I order a new hdmi cable is there anything else I could be doing wrong or do you know of any inferior batches of mecool m8s pro that simply can’t output 4:4:4

    I know my tv can handle it and my le box is connected directly to the tv and not through a amp

    I have no problems installing and using the normal build

    I’d love to be able to use my tv to it’s full potential when playing 4k with 10bit hdr

    Tv is panasonic 65dx902b

    Thanks again for your help!

  • I assume you still have android working, does that work with the Hdmi cable?

  • mule

    I think Kszaq's build has it built in, but on his old LE7 builds I had to run the following command to fix some live channels. (I have it in autostart.sh on that box).

    echo 4 > /sys/module/amvdec_h264/parameters/dec_control
  • I assume you still have android working, does that work with the Hdmi cable?

    no I don’t have android installed anymore, I installed kszaqs to internal and I updated to the 4:4:4 wrxtasy build but I have the black screen problem so I’m now back to running kszaqs build from sd card until I can figure out what’s causing the black screen

  • Another test release.

    This one fixes the Audio silence problem with the new Linux Kernel when you go from PCM Audio to Passthrough, back to PCM which then used to result in a total loss of audio output.

    Also reverted a small new Kernel change for h264 video decoding.

    As well as adding an option to turn off - AMLogic deinterlacing picture post processing completely.

    mule try doing a .tar update and see if there are any H264 improvements out of the box.

    If not go into Settings > Display > Disable AMLogic hardware deinterlacing and try again, you may have to reboot.

    All my h264 TV viewing is 1080i streamed in a .mkv container.

    Sometimes a .mkv container from TvHeadend is more compatible with various media players.



    Wizzi07 just be aware, if you are running a Kodi user interface at 2160p50 or 60Hz at a Chroma and bit depth of 444,10bit you will have issues as that combo is Not supported by HDMI 2.0 standards. See the table in THIS link.

    If 4:4:4 is used then you must run the Kodi user interface at a 1080p resolution and let LE Kodi auto switch to 2160p when watching 4K 24p movies.

    Yes it sounds like you need a high speed or premium certified HDMI 2.0a cable.

    The "Amazon Basics" and Monoprice ones work and are good value.

  • wrxtasy thanks again.. kodi ui was set to 2160p 24p before I tried to update.. I will order a new cable and let you know how I get on - I’m pretty sure it is due to the hdmi cable because the box is booting and on the libreelec screen I see your build version in the top left corner and even when the screen goes black after the boot screen I can still ssh and drag and drop files to the box using windows explorer so it must be on

  • There is simply no need to run the Kodi GUI at 2160p anything, all it does it heat up the Chipset necessarily. Plus your 4K TV will have better quality user interface 1080p > 4K picture upscaling vs pretty much any media player. Then to also really annoy you it causes black screen and HDMI issues.

    Set the Kodi GUI to 1080p60Hz or 50Hz and also set:

    in Kodi settings > Player > Video > Adjust display refresh rate > Start/stop

    Sync Playback to Display > Off

    If you play 2160p material AML LE Kodi will auto refresh AND 1080p <<<--->>> 2160p auto Resolution switch.

    Set and forget. ;)

    All 4K AML LE or OSMC Kodi Krypton media players operate the same.

  • is it correct to say that all 1080p video will never be upscaled to 2160p using a 4k tv. It will be passtrough to the TV to upscale.

    The setting in Kodi: " .Enable HQ scalers for scaling above 20% " will be overrided.''

  • Those CPU Software upscalers will never usually be activated with AMLogic LE Kodi.

    You need decent Intel Iron to use Software upscaling.

    If you set a resolution of 2160p, AML hardware does the 1080p > 4K upscaling. But in my experience the picture on my 4K TV then appears a bit soft and dull. Leave the GUI at 1080p and let the 4K TV use it's superior upscaling hardware.

  • I have tested this new version, but I don't get audio!

    In Settings -> System Settings -> Audio the "Audio output device" is fixed to "Default, Bluetooth Audio (PULSAUDIO)" and this is not changeable!

    How can I set an other Audio output device, e.g. ALSA PCM?