[8.2.2.3] LibreELEC 8.2 for S912

  • kszaq wrote: No, not essential. You can also do this yourself in every previous version, e.g. to scale GPU down to 500MHz:
    Code
    1. echo 2 > /sys/class/mpgpu/cur_freq

    Kszaq is this code like:

    or just the code you posted... and is this the only thing i have to do, ones?

    And is there a way to scale down CPU? for betther temp/ overheat?

    Code

    1. echo 2 > /sys/class/mpgpu/cur_freq=500?
  • I'm afraid there is no developer who would be able to get through AML audio driver mess and/or rewrite the driver.


    You can turn off HDMI audio by echo audio_off > /sys/class/amhdmitx/amhdmitx0/config

    Thanks.

    What will be the consequences of switching off HDMI audio - will the SPIDF remain active and decoupled from TV behaviour ?


    Shoog

    Edit: Having just tried this, it seems that SPIDF dies with a diasbled HDMI.


    Edit: I just discovered that I was listening to the analogue output from my TV through my amp rather than the SPIDF off the box, I can now confirm that SPIDF in fact stays alive when the TV is off. Sorry for the confusion.

    Edited 2 times, last by Shoog ().

  • kszaq wrote: No, not essential. You can also do this yourself in every previous version, e.g. to scale GPU down to 500MHz:
    Code
    1. echo 2 > /sys/class/mpgpu/cur_freq

    Kszaq is this code like:

    or just the code you posted... and is this the only thing i have to do, ones?

    And is there a way to scale down CPU? for betther temp/ overheat?

    Code

    1. echo 2 > /sys/class/mpgpu/cur_freq=500?

    I don't understand the question. You don't have to do anything, box should work with OK temps with the latest build.

  • I didn't know that MCH = multichannel - if that's the case then my question is answered, thank you!


    Getting my Minix U9-H in tomorrow, hopefully all goes well. I will report my own findings back running on my old Onkyo TX-SR606.

    For anyone Google'ing in the future - LibreELEC on a MINUX U9-H supports multichannel PCM over HDMI without problems.


    Thanks everyone for their help.

  • Hello, a month ago I switched from RPi3 to Vorke Z6 with S912 when I use the Samsung UE55MU6172 TV. From the beginning I deal with film problems and I also try to install LE (different versions, SD card, internal memory)


    I do not have 100% so far and tried parts of the films but so far it looks like:


    Active full HW acceleration:

    - movies work in 4k

    - movies 1080p 23,976fps - lets watch the movie but is not smooth (does not break)

    - movies 1080p 25fps - what a new animation Coco tried for a while, I felt the movie was fine (I did not see the whole movie like this)



    Inactive full HW acceleration:

    - 4k movies do not work

    - movies 1080p 23,976fps - smooth movie watching, cool

    - movies 1080p 25fps - lets watch the film but it is not smooth (animation Coco, I've seen it all), if not 30fps I can watch but it's a horror


    Some ideas? :)


    Thanks

    Vorke Z6 - LibreElec 8.2.2.3 - KODI 17.6 - skin AeonNox Silvo

    Xbox One X - KODI 18 Leia

  • Strange, S912 should do w/o issues 1080p flawlessly. What Android do you have, stock of flashed something? Did you tried FTMC (Jarvis - Kodi 16) under Android or Kodi 17 straight out of the market? Should be pretty much flawless with LibreELEC. But then have in mind that not all of the S912 come equal, some use crappy slow eMMC (internal storage), shitty RAM, or other crap components...


    Take a look here, about some proper 7.1.2 Android custom firmware.

  • After purchasing the Vorke Z6 I did not use Android at all, so there was a default version. I immediately used LE, first on the SD card and then installed into internal memory. I do not know, I do not really understand these issues, which still depend on HW acceleration on / off in KODI settings. I use an add-on to watch movie movies where there are more or less good streams. I have bit stream filtering based on the download speed (68Mbps), so I have no problem tracking 4k movies.

    Vorke Z6 - LibreElec 8.2.2.3 - KODI 17.6 - skin AeonNox Silvo

    Xbox One X - KODI 18 Leia

  • I use an add-on to watch movie movies ...

    I don´t use an addon on my S912 vorke.

    Playing videos from NAS - HW acceleration works.

  • So you use LE 8.2.2.3 and for what TV? Or maybe you can try some movie at 23,976fps and 25fps? The problem is not in the add-in, I just found a problem with different fps. And what is your resolution and player setting in KODI?


    edit: TV I see, sorry. You have a super TV than me :) Maybe the TV can handle it or just download a good rip


    edit2: I just do not understand that movies are playing differently with HW acceleration on/off, which would make the TV´s technical considerations bad. The 4k movie will play, but hw acceleration must be turned on. The 1080p (h264) movie in the "correct" 23,976fps format must already be hw off to make it all right...

    Vorke Z6 - LibreElec 8.2.2.3 - KODI 17.6 - skin AeonNox Silvo

    Xbox One X - KODI 18 Leia

    Edited 3 times, last by vosay ().

  • So you use LE 8.2.2.3 and for what TV? Or maybe you can try some movie at 23,976fps and 25fps? The problem is not in the add-in, I just found a problem with different fps.

    Most of my video files(movies) are 23.9 or 25.

    If You got problems with differents fps -> [READ FIRST] Reporting bugs


    BTW:

    I You expect perfect playback of any Video file type - :thumbdown:

    There are to much files encoded with special szene encoders

  • I understand that all the movies will not be all right. I used Rpi3 before Vorke (I had another TV) and anything I released in 1080p or worse quality, so it was good. I did not deal with fps because I did not download the movies. Log I can try, but I'm out of my gear now.

    Vorke Z6 - LibreElec 8.2.2.3 - KODI 17.6 - skin AeonNox Silvo

    Xbox One X - KODI 18 Leia

  • Most video files will be good, but not all.

    I also used raspi in the past.

    Now I own 4k TV and bought amlogic S905X & S912 and can´t confirm worse quality playing most of my movies(720p, 1080p and UHD)


    To improve picture quality You can check this

    Code
    1. echo 1 > /sys/module/di/parameters/bypass_all
  • And where can I find this, or possible action? Does the Inputstream Adaptive addon play any role? Thanks :)

    Vorke Z6 - LibreElec 8.2.2.3 - KODI 17.6 - skin AeonNox Silvo

    Xbox One X - KODI 18 Leia

  • Hi Kszaq, thanks for all your work. Everything I need on my box (h96 pro +) works great. I have one small problem when playing multiple videos in the youtube addon. When I pick a video and select play from here, the first 2,3 videos playing normally but the next video is playing without sound. When I stop the video and select the video manually the video is playing with sound. Can someone help me out with this. Not a big problem, but I use the youtube addon a lot for my kids.

  • Hi Kszaq, is it possible to scale down the CPU freq to 1GHz by using SSH? its now 1.536 GHz

    The H96 Pro plus is running 70+ C. and will freeze after 4 hours

    The cooling is not that good on this box...

  • echo "echo 3 > /sys/class/mpgpu/scale_mode" > /storage/.config/autostart.sh


    Work this code with 8.2.2.3? Or only with the deleted version 8.2.3.1?