[8.2.2.3] LibreELEC 8.2 for S912

  • @wrextasy How can I check if my GPU speed is being overclocked? I put the correct device tree too.

    Also when I did update over 8.2.2.3, my remote control is still working...

    Edited once, last by mirbg ().

  • This new S912 Krypton version in the following folder should fix the ppmgr_3d_mode


    S912-Krypton-v8.2.4-AML folder

    just updated to this build and enabled overclocked gpu and 10bit and it’s by far the best build I’ve used! Everything is working perfectly and ui is snappy thankyou!!

    One question I have is what sort of gpu temp should I be worried about hitting? At the moment after some general library browsing and setting changes it’s at 63•c

    Mecool m8s pro S912 3/16gb 8.2.2.4oc installed to internal

  • Current GPU clock Frequency:

    cat /sys/class/mpgpu/cur_freq


    I would only be worried if a S912 sits on sustained temps of 90+ Degrees C

    That would indicated really poor SoC cooling and thermal design.


    63 is pretty normal for a AML SoC. :D

  • ok thanks.. and thanks again for taking the time to improve and share these builds it really is appreciated! I hope you keep up the good work because without you and the other libreelec/kodi/amilogic devs these Chinease boxes would be mostly junk but with your guys work they can be a very capable device 👍😁

    Mecool m8s pro S912 3/16gb 8.2.2.4oc installed to internal

  • I've owned my TV since 2015 and to my astonishment it supports up to HDR10bit 4:4:4 and plays Dobly Vision(12bit?!) content.


    My LG TV EDID reports:


    420,10bit

    420,8bit

    444,10bit

    444,8bit

    422,10bit

    422,8bit

    rgb,10bit

    rgb,8bit

    I enabled the HDR setting in Kodi and rebooted, all works just fine.


    Does that mean if the TV plays a file encoded with HDR content, that I have these supports? Or is there another way of checking? I must say the quality is incredible(could be a placebo), but weirdly when I reinstalled my system yesterday using my crappy Samsung work monitor from 2010(max res 1080P), it also played the 4K HDR files?! dafuq

    Edited once, last by shablamy ().

  • shablamy


    Your TV doesn't support HDR10 nor DV.

    So the best bet is the SoC is doing some generic tone mapping of HDR to SDR for HDR10.

    For DV, the DV part is an extra layer. If DV is not supported, and it is not supported by neither your box, your TV nor LE, you're just going to get the SDR version of the video.

  • shablamy


    Your TV doesn't support HDR10 nor DV.

    So the best bet is the SoC is doing some generic tone mapping of HDR to SDR for HDR10.

    For DV, the DV part is an extra layer. If DV is not supported, and it is not supported by neither your box, your TV nor LE, you're just going to get the SDR version of the video.

    Thanks! I got excited when I saw the supported bits via the EDID.

  • wrxtasy both LibreELEC-S912.arm-8.2.4-Chroma.444 and LibreELEC-S912.arm-8.2.4-Oclock-GPU cause crashes when trying to play livetv. As soon as you try start a channel the box just reboots. This never happens on any other release

    Crashlog

    Debuglog

  • I am confused...it shows 500Mhz, what am I doing wrong? I put 8.2.4_OCGPU on the SD with Win32DiskImager and then replace the default dtb.img with the correct one for my box (100Mbit_3GB, Mecool M8S Pro 3/16) after renaming it to dtb.img...

    What am I missing?


    EDIT: OK. I found it, had to activate the option in settings:)

    Now I have 792MHz GPU, but my CPU is always at 1000MHz, no matter if I am watching 4K or 720p...


    EDIT 1: with the test file 160-mbps-4k-uhd-hevc-10bit.mkv my CPU works at 1512 and both CPU and GPU temps are operating at max 38C.

    I have modified my M8S Pro with 40x40x10 Fan on 5V:


    EDIT 2: with 4:4:4,10bit option activated I have a lot of red on my 1080p content, this happens when I use 4K GUI in Lebreelec. What resolution for GUI should I use? 1080p 60fps?

  • Current GPU clock Frequency:

    cat /sys/class/mpgpu/cur_freq

    Did some testing on my X92 box, and here are results:


    Running v8.90.4 (500MHz)

    image1


    Running v8.2.4 (400MHz)

    image2


    Turning overclock ON

    image3


    Results with (666MHz)

    image4


    Your version displays correct CPU freq on my X92 box

    image5


    Is there a way to get 792MHz on my box?


    Your version works OK playing all sorts of video files from local USB disk, no hiccups what so ever...

    ODROID N2_S922 4G - 1GB Ethernet, X92_S912_q201 3/32G - 1GB Ethernet Box_Android 7.1.2, Mocool KM8_S905X 2/16 0.1GB Ethernet Box_Android 8.0, X96Mini_S905W 2/16G 0.1GB Ethernet Box_Android 7.1.2

    Edited 4 times, last by Sholander ().

  • So my M96X Pro locked up over night so i was forced to power cycle it. I went to look at /var/log/syslog to see what happened but of course its not there in Libreelec! I am aware of debugging mode in Kodi but as this issue seems to be random I'm loathed to leave it running in that mode for a few days to see if I can get it to 'on tape'. Is there any other way to view the dmesg content before current boot?

  • Did you say the remote works out of the box after upgrading to v8.2.4?

    I can confirm, just update my Minix u9-h with 8.2.4 and the IR remote work well.

    Libreelec : Odroid C1+ ; Odroid C2 ; Raspberry Pi 1, 2, 3 ; M8S-S812 ; A95X-S905X ; GT1-S912

    Divers : Xiaomi mi box ; Rock 64 ; RockPro64 ; Minix U9-H (x2); Orange pi pc ; Orange pi pc+ ; Orange pi one

  • Standard way to run any 4K LE AMLogic box:


    If you watch a lot of 25i OTA TV use a 1080 50Hz setup to prevent un-necessary refresh switching.

    I watch a lot of 25i live TV with S912 MINIX U9 - LE v8.2.4 = no crashes.


    Otherwise use a 1080p 60Hz Kodi GUI and let your 4K TV upscale everything with it superior 1080p > 4K upscaling Hardware. This will result in superior picture outputs.


    AML LE Kodi Krypton will Auto Resolution Switch to 4K when actually watching 4K content anyway.


    The CPU speed has (mostly) nothing to do with hardware video decoding or drawing the Kodi user interface, it's just idling most of the time. In that context consider whatever speed it is running at irrelevant.


    Cheap AML hardware with cheap internal components and without proper thermal cooling and heat sinks - when Overclocked will very likely crash or show other strange picture output behaviors.

    Time to open up and mod your device then like mirbg 's cool setup pictured above.:thumbup:


    And yes there are extra Kodi settings in my releases found in System and also Audio settings. Hint set LFE to 100% for 2.1 subwoofer audio setups. ;)

  • Ok thanks for the tips. Yes I'm running the Kodi GUI at 1080p 60Hz. I am however running a bunch of other services via docker so I could see how that would lead to overheating. I haven't done anything to overclock, I'm just running stock 8.2.2.3.


    Well aware of the cheapo cooling, have a few spare tubes of artic silver so was going to mod the cooling stack anyway! I just wanted to have a look at /var/log/syslog to rule out a driver issue before cracking her open. I guess a bit of modification is due.


    Just a professional Q wrxtasy , I'm a software developer myself yet wouldn't know the first thing about modifying the kernel and the various other bits and bobs that you do. How did you pick that up? Professional background, curiosity? I've always looked upon the guys dealing closer to the hardware as the real guru's yet I dont see how I myself can go from a regular software guy to a on the bare metal dev like yourself.


    Also, "Hi" from a fellow Aussie (Brisbane).

  • Anyone having box losing addon settings? From time to time the KIII Pro loses all addon settings and no addon its capable to start. Only solution is restore a backup.

    Edited once, last by RPSouto ().