[8.2.2.3] LibreELEC 8.2 for S912

  • wrxtasy


    Hi, could you please reply to my previous post?

    wrxtasy


    I'm having a hard time figuring out which kernel your build uses. Is it based on kszaq's builds?

    The automatic REC.709 and BT.2020 switching, does it normally run in 422,8bit and only switch to 422,10bit when HDR content is started?

    That would be perfect, because my TV switches into BT.2020 SDR mode when I run it at 444,10bit, which oversaturates everything.

    Also, can we expect a S905X build?

  • If you use:

    echo "echo '422,10bit' > /sys/class/amhdmitx/amhdmitx0/attr" >> /storage/.config/autostart.sh


    You will get green screen video output with kszaq 's LE 8.2.x S9xx AML builds because that uses the old AML Linux Kernel that has a bug in it.

    Those sort of terminal commands are only needed if you are watching 4K HDR 10bit video anyway.

    With the old kszaq Kernel you actually use this command for proper 4K HDR Chroma and 10bit output:


    echo "echo '444,10bit' > /sys/class/amhdmitx/amhdmitx0/attr" >> /storage/.config/autostart.sh


    A high speed or premium certified HDMI 2.0a cable is then needed because you will be transmitting a lot more 4K HDR display data over HDMI.


    Some people (like hdmkv ) have 4K HDR projectors that only support 422,10 or 12bit input - so this was the reason I plugged in the newer AML Linux Kernel in the first place - to fix the 422,10bit green screen issue.

  • Thank you wrxtasy for this information.

    Is the command line in autostart.sh going to be there permanently even after I have turned off the

    U9-h ?

  • ok thanks! I’ll give it a try

    Mecool m8s pro S912 3/16gb 8.2.2.4oc installed to internal

  • Thank you wrxtasy for this information.

    Is the command line in autostart.sh going to be there permanently even after I have turned off the

    U9-h ?

    Thatswhy people call it „autostart“

  • wrxtasy .. I created a new bootable sd first using kzsaqs build and dtb and it booted so I placed your 10bit version into the update folder rebooted and it updated and got passed the mecool boot screen and onto the Libre elec screen with your build name in the top left corner, the image then goes small and into the top left then the screen goes black and the tv detects no input.

    The tv is definitely 10 bit capable it’s a panasonic 65dx902b

    Any idea what I could be doing wrong?

    Thanks

    Mecool m8s pro S912 3/16gb 8.2.2.4oc installed to internal

  • Hello


    I cannot access the 512mb partition after burning the image to usb drive

    ive used rufus and libreelec writer.

    Im using windows 10


    What can i do to solve this?

  • I use LE-8.2.2.3 with my Alphawise H96pro+ (S912) and for me works all things fine.

    I have tested the new LE-8.90.5 but without success to play videos or LiveTV with 3840/50p. And so I use these "older" LE-8.2.2.3 version.


    With the LE-8.90.5 I have to use "ir-keytable" for my remote control and this is really great, because I can use my Universal Remot control after create a "keytable". And this works perfect!


    And for this reason I would like the same with LE-8.2.2.3, so I can use my Universal remote control in place of the original remote control, but it doesn't work. What have I made:

    • In the Libreelec-addon I have deactivatet "lirc"
    • I put my, under LE-8.90.5 created, "rc_maps.cfg" to .storage/config and also my createtd "keytable" to .storage/config/rc_maps


    After a reboot I found out that my Universal remote control doesn't work.

    • If I logged in the console and put in "ir-keytable" I get only an error message: "/sys/class/rc/: No such file or directory"


    And so I have a question: Is there a possibility to use ir-keytable with LE-8.2.2.3 or can I only use "lircd" with this LE version?

    If YES, can you say what I have to do.


    Paul

    PS: Sorry for my english, but this is not my native language. ;)

    Alfawise H96pro+ with S912 and 2/16GB

  • the earlier versions, used a different way for the remote.


    Create remote.conf from scratch


    remote.conf repository


    you basically create a remote.conf & put it in the config folder


    I have a logitech 350 & 650, if you look through the posts, there are some instructions there, to use the Pivos profile from the logitech database

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro (Coreelec), Fire TV 4K Stick (Bedroom)

    Synology DS414 Plex Pass

    :)

  • I assume you just want to put the correct dtb file in the 512 partition, I use windows 10, & once rufus has finished, the partition opens, so I can copy the dtb over

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro (Coreelec), Fire TV 4K Stick (Bedroom)

    Synology DS414 Plex Pass

    :)

  • the earlier versions, used a different way for the remote.


    Create remote.conf from scratch

    remote.conf repository


    you basically create a remote.conf & put it in the config folder

    Yes, that is also a way to use my Universal remote control with LE-8.2.2.3


    So I have to create a new "remote.conf" for LE-8.2.2.3 and can't use my "keytable" from LE-8.90.5.

    If there is no other solution I will do that at weekend! :)


    Paul

    PS: Sorry for my english, but this is not my native language. ;)

    Alfawise H96pro+ with S912 and 2/16GB

  • I'm afraid I don't know if you can use your key table


    No need to apologise for English not being your native language.

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro (Coreelec), Fire TV 4K Stick (Bedroom)

    Synology DS414 Plex Pass

    :)

  • I assume you just want to put the correct dtb file in the 512 partition, I use windows 10, & once rufus has finished, the partition opens, so I can copy the dtb over

    wont work on windows, i had to install opensuse to access the partition

    i copied the file but looks like my box is not compatible, i just ordered a compatible one

    lets see how it works :)


    Thank you bro.

  • LibreELEC-S912.arm-8.2-Chroma-422.10bit.tar


    Notes:

    - there may be some Audio issues with this release after using audio passthrough. Straight 2.0 PCM audio is fine.

    - the previously jerky video playback when watching H264 OTA TV seems to have disappeared as well.

    Sorry to say, but the jerky video playback of 720p-TV channels (H264) has not been solved. Any ideas? Otherwise this is the best version for 4k HDR yet. Many thanks for your efforts!

    Edited 2 times, last by mule ().

  • With LibreELEC-S912.arm-8.2-Chroma-422.10bit.tar i have many skip frames (500) with x264 videos, back to 8.2.2.3 and its ok...


    Also i have small problems with 444 on 8.2.2.3 (black screen with 1080p videos once per movie for 1 second), no signal on 420 and green screen on 422.

    On RGB 10bit its looks good but is rgb better or worse then 422?

    Edited 2 times, last by Pinki ().

  • Green screens when using 422 have been verified fixed by a few of use now when using the new Kernel. I cannot help with @kszaq's LE 8.2.2.3 version, but black screens when using 4:4:4 are usually a sign of a HDMI cable unable to transmit up to 18Gbps of data.

    Sorry to say, but the jerky video playback of 720p-TV channels (H264) has not been solved. Any ideas? Otherwise this has been the best version for 4k HDR until now. Many thanks for your efforts!

    Have you set a fallback framerate in Kodi > PVR & TV > Playback settings ?

    Mine is set at 50Hz for 25fps TV viewing.


    This is the current img.gz I'm using:


    LibreELEC-S912.arm-8.2-Chroma-422.img.gz

  • hi I'm running the 8.90.5 rom on a beelink gt1. I got some occasional reboot. From what I've read it's related to temp sensor.

    In the 8.90.5 thread, op says in my case we should use 8.2 temp-sensor-disable from ksaq. Where can i find the temp sensor disable rom?