LibreELEC Krypton/Leia/Agile build for Odroid C2, Rock64, WeTek Hub, WeTek Play2

  • Hi To all friends here ..


    GDPR-1 ..

    I have a odroid-c2 with an hifi shield 2 audio dac..

    i do have sound coming from this dac ( analog as i have only a 2 channel amp ) but it seems your build has not the proper drivers for this dac..

    it seems it needs some extra module's but i can't get then in.. the modules needed to get this dad working properly it needs the following modules.

    1 : Module ==> snd-soc-pcm5102

    2 : Module ==> snd-soc-odroid-dac

    when i do a : modprobe snd-soc-pcm5102 the awnser is ==>

    modprobe: FATAL: Module snd-soc-pcm5102 not found in directory /lib/modules/3.14.29

    now i found these module in a libreelec version for raspberry.. i pulled them out.. but no way for me to write them in de Odroid system.. read only.

    so my question could you compile these modules in your next build..??

    I also checked out this page.. Odroid C2 + HiFi Shield+ but that did not help me much loll..

    best regards Ozzy...

    Running
    Original M8.. Demetris LE
    Hybrid MXIII (S812).. Balbes150 LE
    Raspbery PI3 B2.. LE Millhouse..

    Odroid-C2+Hifi Shield2- Volumio2+Kodi.

    Edited once, last by Mr Ozzy ().

  • Hi,


    Yesterday I bought the Wetek Play 2 and after updating the box I installed the Original Libreelec image. (LibreELEC-WeTek_Play_2.aarch64-8.2.3) onto Nand. After that I upgraded the installation with "LibreELEC-WeTek_Play_2.arm-rb-leia23.tar"


    No problems so far. I set the resolution to 4K (24Hz) and installed the TVHeadend client. After connecting to the TVHeadend server I noticed that the audio ran out of Sync when a channel was playing. The audio runs faster than the video. When I set the resolution back to 1080P (60Hz) everything runs smooth (audio in sync).


    When on 4K the audio runs progressivly out of sync when streaming a channel from my TVHeadend server..


    Am I missing something? (I must admit that i havent read the whole forum thread)

    Kind Regards,


    RR69

    --------------------------

    Frontends:

    - Wetek Play 2 - LibreElec Leia build 23 / RPI3 - LibreElec Leia / HiMedia Q10 Pro - Kodi 17.6

    Backend:

    - HDHomeRun Expand - DVB-C (HDHR3-4DC)

    - Openmediavault 3.98 running Virtualbox 5.1.14 Host

    - TVHeadend 4.2.5-49 / OSCam 1.20-unstable on Ubuntu 16.04 (virtualbox guest)

    Edited once, last by rr69 ().

  • Pleased to report that during my quick tests, it seems the live tv stuttering through tvheadend has disappeared! Thankyou Raybuntu :D

  • Yes. Your monitor probably support for 4k only 30Hz and when you play 1080p, pictures are upscaled to 4K and played at max supported fps (30).

    You don't need set resolution to 4k. Playback is always set to best matching higher resolution supported by your monitor, trying to eliminate downscaling.

  • Set the Kodi GUI to 1080p60Hz if you live in the USA and have an ATSC TV tuner. Otherwise set it at 1080p50Hz.


    In Kodi settings > Player > Videos then set:

    - Adjust display refresh rate > Start/Stop

    Sync Playback to display > Off


    Leave the user interface at 1080p. LE will auto refresh switch and auto resolution switch to 4K when you watch 4K content. If your Display supports the required resolutions properly.


    Let LE Kodi do the hard work auto refresh switching to sync properly varied video content. Doing it yourself and guessing produces poor results.


    Kodi Leia may have playback fluidity problems when watching H264 HD TV because of a brand new Linux Kernel and using An early Alpha Version of Kodi. See how you go.

  • Mr Ozzy those modules are not necessary and supported in LibreELEC. Those are only available with Hardkernel's Kernel. We use a more recent AML Kernel but it lacks individual fixes from HK. Hifi Shield should just work with simultaneous HDMI audio output.


    TheCosmicSlug was is tested with my new leia24 release?

  • Mr Ozzy those modules are not necessary and supported in LibreELEC. Those are only available with Hardkernel's Kernel. We use a more recent AML Kernel but it lacks individual fixes from HK. Hifi Shield should just work with simultaneous HDMI audio output.


    TheCosmicSlug was is tested with my new leia24 release?


    Yes tested with the leia24, ive been having issues ever since leia21 but it seems to have finally gone :D


    If it helps anyone still experiencing them, try this:


    In Kodi settings > Player > Videos then set:

    - Adjust display refresh rate > Start/Stop

    Sync Playback to display > Off

  • Live TV is working fine now with rb-leia24

    Finally no more stuttering.

    GDPR-1

    Btw i noticed that connect with CEC took ages with your new build.

    Has something change with cec?

    Thank you for new build this one runs really great on my ODROID C2!


    Thanks!

    Edited once, last by Marciano ().

  • Quote

    Live TV is working fine now with rb-leia24

    Finally no more stuttering.

    Seems to be gone indeed. However I've seen some issues with 4k content on 19.2 (Astra, and SES demos)

    However, when the picture runs in a windows, the framedrops are still present, and video has low framerate. I

  • DVB-T2 Stick - lsusb:

    ID 0572:c688 Conexant Systems (Rockwell), Inc. Geniatech T230 DVB-T2 TV Stick


    This stick seems to be unsupported in your built (LibreELEC-Odroid_C2.arm-rb-leia24.img.gz), right?

    Then it would not be worth to search for a solution.


    EDIT: Just found out that DVB drivers are available as installable modules. Just selected (in my case) "crazycat" drivers in the addon "LibreELEC Module Drivers".

    Edited once, last by jochen02: found solution ().

  • Anybody else still noticing issues with sound completely gone sometimes after AC3 playback with passthrough is started, especially with Live tv stream. ? (It's what I've observed, might be present also with different formats, like DTS.)

  • @trex_daemon

    I had seen where 4K media would not play sound out via HDMI to TV, and the TV redirected it to my sound bar over the 3.5mm jack. But as soon as I switched back to 1080p I had no issues (that was v21 however).


    @GDPR-1

    I am trying to upgrade from 21 to 24 on my Rock64. I put the tar I downloaded into the Update folder, rebooted.

    The system stayed at 21, and the tar file was deleted. No upgrade. :(


    I should be able to go from 21 to 24 without the intermediary upgrades, correct?

    I have not started digging into it, but I figured this would be a good thing to double check first.

    -Written by a team of angry monkeys.

  • I experienced similar problem when upgrade to rb-leia24. It was due to architectural change, hence update was cancelled and tar file was deleted. I finished my upgrade by first made a Kodi backup, fresh installed rb-leia24, and Kodi restore the backup.


    There's been a huge improvement in rb-leia24, especially on video player. It worth the extra work.