LibreELEC Krypton/Leia/Agile build for Odroid C2, Rock64, WeTek Hub, WeTek Play2

  • Here is my community build. Kernel is build as 64bit with 32bit Userspace. It means you can use 32bit armhf packages.
    I'm putting it here too. You can also get support here:
    Wetekforums for WH
    Wetekforums for WP2
    Odroid Forum for C2

    Pine64 Forum for RocPine64 Forum for Rock64k64
    Kodinerds for WH, WP2, C2 German Support


    DISCLAIMER: It's a community build of LibreELEC. USE AT YOUR OWN RISK! Report Bug only to me.


    Tar upgrade from aarch64 might work use the following steps:

    Code
    1. touch /storage/.update/.nocompat


    Then copy the tar into /storage/.update/ and reboot
    After everthing is updated you need to remove all the binary addons and reinstall those from the repo.
    Beware that kodi caches zips in /storage/.kodi/addons/packages. Those have to be removed too.

    Code
    1. rm /storage/.kodi/addons/packages



    If you are updating from one of my previous builds you just need to put the tar in /storage/.update/


    Download: Github Download Page
    images      <--- Do not use that anymore!


    LibRetro, DRM with inputstream work.


    It is bleeding edge. I'm following LibreELEC release cycle.


    Source Code: GitHub - Raybuntu/LibreELEC.tv: Just enough OS for KODI


    Backup Downloads:
    Addons: repository.rbrepo

    If you like my build and you want to buy me a beer or whatever.
    Bitcoin: 12zLUYC7JzwM7a8cQKekAvZr9kWxjzTfxm

    Edited once, last by GDPR-1 ().

  • The difference between Raybuntu's and my builds is that Raybuntu's work out-of-the-box on devices they are designed for. This means no need to pick/replace device tree, remote control configuration etc. Raybuntu also follows official LE more closely, I push a bit more experimental changes in my builds.

  • But it you want more features you have to stick with kszaq :). My builds are limited to WH, WP2 and C2. WH and WP2 support probably works very good in kszaq 's build!


  • But it you want more features you have to stick with kszaq :). My builds are limited to WH, WP2 and C2. WH and WP2 support probably works very good in kszaq 's build!


    I'm thinking of adding some "features" to RB's build, now he has done all the Hard Yakka on getting 32bit LE up and working ! :P


    You may want to add specific instructions for deleting the 64bit backup Addon packages:

    Code
    1. rm /storage/.kodi/addons/packages

    Edited once, last by wrxtasy ().

  • I'm thinking of adding some "features" to RB's build, now he has done all the Hard Yakka on getting 32bit LE up and working ! :P


    You may want to add specific instructions for deleting the 64bit backup Addon packages:

    Code
    1. rm /storage/.kodi/addons/packages


    Done. Be my guest wrxtasy . Glad to see you back!

  • kszaq , your build is good as well but there in no internal dvb tuner support for play2 . Only this is missing for me in your great builds .I am using GDPR-1 builds from some time and I am very happy . Only tvh 4.2 is broken for me and sometimes audio/video stop on some channels after switch on them. Tvh 4.0 is working good but has no hevc h265 support :-( would be nice to test kszaq build with internal dvb tuner for play2 :-)

    Edited once, last by zbigzbig20 ().


  • @ zbigzbig20 I believe this is a known issue with TvHeadend 4.2


    Over in afl1's KI Plus / KII Pro thread, guys seem to be having success with service.tvheadend42-8.1.108.zip and Kodi Krypton. :)


    I think the issue is different here. I'm not using media_build and I've bumped tvh 4.2 server too. The issue is rather in peak3d's patch. It's like the rewind/ffwd/skipping problem. Sometimes picture freezes.

  • I'm giving this a go. So far it seems to work fine, except the Wetek Hub remote doesn't work. CEC works fine.

    Edited once, last by mafijozo ().


  • Do you have a custom lircd.conf. Remote is working for me.


    I don't have any custom / advanced configs, I just burned your image on an SD card and booted of it. No tinkering, no custom builds or similar.


    EDIT: the remote does work. I am using a harmony remote to control all my devices. After I increased the command repeat it suddenly started working. Meaning for some reason the IR receiver is less sensitive with this LE build. Once the repeat value was increased, it started working without a hitch. I didn't test with the stock remote.

    Edited once, last by mafijozo ().

  • Ahhh ok I thought you were talking about the original Hub remote. It uses lirc (like official LE) which is not very responsive for NEC protocal. @kszag uses amremote which works better.

  • I'm good :) This is literally the only Kodi build I've tried which doesn't crash on my Hub (I've tried LE 7.1.0, WePlayer, Kodi 16.1 and 17 RC4 on Android etc.)


    So thank you a lot for your work!

  • Some guys programmed their remote as MCEUSB (power button as NEC). It works better.
    Yeah the memleak is solved with 32bit. Enjoy.

  • Hi,


    as first time odroid-c2 user i want thank you (at first) and to share some of my experiences with your build:


    i can`t locate the problem better, but it seems the network traffic stalls sometime: i am not able to browse the repositories, i am not able to browse the RB Backup Add-ons Repo (installed from zip file, get always a timout) and access to the internal class c subnet is very laggy.


    I realized, that a reboot is not as goot as a full hw-reset (power off via power supply or via rocker switch). I got at least access to the preinstalled repos after a full reset... a normal reboot leads mostly in timeouts to all of the repos.


    The addon and radio and tv view and more from the main view doesnt update (endless rotating icons)... (movies and music works... maybe because of the mysql connect ?)


    I use centralized Icons, shared via nfs, stored on my ubuntu server.


    I get an tv guide with channels but without epg data.


    My setup:
    1Gbit Zyxel switch, vdr, nfs, samba and mysql db on ubuntu 14.04 lts headless server (core i5 with 16GB) for video an music db, and - of course - odroid-c2, but with SDcard for now.


    I am using a wetek play, raspberry pi 1+2 and cubox 4 i pro, too. All on actual libreelec 8x. beta.


    Sascha

  • Sorry for that but now that the LE repo is up again please use that. It's build by me and hosted on the LE community server. I've refactored the backup repo today. Please install the new zip. Sorry for the inconvenience.


    repository.rbrepo-8.1.1_Odroid_C2.zip


    But again you don't need it. It was a failsafe for the server outage. LE repo features all addons. Just check for updates.

    Edited once, last by GDPR-1 ().

  • Hi Raybuntu,


    i guess it has nothing to do with your backup repo problem... it seems that odroid`s http / samba network requests stuck ...


    it is a strange behaviour....