[7.0.3.012l] LibreELEC 7.0 for S905/S905X

  • Run these and post results:
    dmesg | paste
    udevadm info /sys/bus/sdio/devices/sdio* | paste
    lsusb -vvv | paste


    Thanks kszaq. Actually lsmod reports that the bluetooth module is loaded. SSHed to the wrong box before, but LibreELEC is reporting that no bluetooth adapter is found. Here are the lsmod results if interested:


    BbVS


    And the other results as requested:


    TLJT
    fVih
    XZfS

    Edited once, last by SEIKT ().

  • Just remove the microsd card

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro, X96+, Fire TV 4K Stick (Bedroom)

    Synology DS414 Plex Pass

    :)

  • My T95M boots into LE by default (on SD card), from there I can reboot it into Android. If I reboot from Android, it just boots back up into LE.

  • SEIKT You have AP6212a chip. Unfortunately there is no BT firmware for that chip in Amlogic sources yet. The other issue is that I don't know how to differentiate AP6212 from AP6212a in systemd.

  • pesh I'm using the latest publicly available NAND driver in my builds. You have to hope that Amlogic releases NAND driver update that will fix your issue.

  • Where can I find this universal uboot 0.6 version? Thanks!


    Probably a total noob question, but what the hell: is it possible to use this universal 0.6 version to update Nexbox A95X (1G/8G) since it cannot be powered up via remote due to a problem with uboot?


  • SEIKT You have AP6212a chip. Unfortunately there is no BT firmware for that chip in Amlogic sources yet. The other issue is that I don't know how to differentiate AP6212 from AP6212a in systemd.



    Bummer. Hopefully one appears soon.

  • Hi everyone,


    excellent job kszaq.


    I have installed LibreElec on OTT TV BOX (Amlogic S905X) and everything works fine, except from one thing.
    lirc is not working. What I am trying to do is to try and map the remote that it came with. So I am using irrecord in order to record the remote buttons. But it cannot find the ir receiver. (i.e. the is no dev/lirc0).
    Is this a problem of the build or of LibreElec in general? Or have I done something wrong?


    Has anyone solved this problem before?


    Thanks for your help

  • Lirc is not used for internal IR receiver. I use amremote in my builds in order to be able to use remote.conf files from Android. Lirc can't do this.

  • Hi everyone


    first of all, Thanks again kszaq for your great builds!
    I have a weird issue:


    1.My box is Beelink S905 2G/16G Mini MX III
    2. installed version 7.0.2.007 - worked great.
    3. I wanted to upgrade to current version, because of the DVBT drivers update.
    4.installed new version - 7.0.3.12c to USB, working fine.
    5. I cant reach the USB installation through SSH.....so i cant copy the newest version to NAND,,.
    when i tried update through update folder, libreelect crashed and its not working since.....(stuck on beeling splash logo)
    now the only working version is through USB, but as noted, i cant install to internal because i dont have SSH access as i used to for some reason....


    is there any way to reach recovery and wipe everything, or reach USB installation through SSH?
    any suggestions...?


    Thanx......


  • @ bubblegum57 - first thanks for your reply. I managed to run LE on the box from MicroSD, without any problems. kszaq - thanks for your work!!!


    Additional 2 question :
    a) Beelink MINI MXIII II is connected to 8 years old Full HD Sony LCD. Adjust display refresh rate is enable by default and I have problems with 1080i/1080p/4K material. My Tv doesn't show the whole picture if Adjust display refresh rate is enable, see attachment. Is this normal ?


    b) i want to know if my beelink is capable of playing 4:2:2 files. From Samples - Official Kodi Wiki (see MPEG2 4:2:[email protected] 1080i/29.970 35Mbps ) there is an example file and picture is green pixellated mess. Is there a way to play it properly ? Sound is ok.


  • Additional 2 question :
    a) Beelink MINI MXIII II is connected to 8 years old Full HD Sony LCD. Adjust display refresh rate is enable by default and I have problems with 1080i/1080p/4K material. My Tv doesn't show the whole picture if Adjust display refresh rate is enable, see attachment. Is this normal ?


    Please set resolution in Android to 1080p 60Hz or 50Hz and try again. Is it OK now?


    b) i want to know if my beelink is capable of playing 4:2:2 files. From Samples - Official Kodi Wiki (see MPEG2 4:2:[email protected] 1080i/29.970 35Mbps ) there is an example file and picture is green pixellated mess. Is there a way to play it properly ? Sound is ok.


    Amlogic can't HW decode MPEG2 4:2:2. Only software decoding is available.

  • Run these and post results:
    dmesg | paste
    udevadm info /sys/bus/sdio/devices/sdio* | paste
    lsusb -vvv | paste


    LibreELEC (community) Version: 7.0.3.012c-temp_sensor_disabled
    LibreELEC:~ # dmesg | paste
    eXQO
    LibreELEC:~ # udevadm info /sys/bus/sdio/devices/sdio* | paste
    -sh: udevadm info: not found
    TVIC
    LibreELEC:~ # lsusb -vvv | paste
    can't get debug descriptor: Resource temporarily unavailable
    can't get device qualifier: Resource temporarily unavailable
    can't get debug descriptor: Resource temporarily unavailable
    can't get device qualifier: Resource temporarily unavailable
    can't get debug descriptor: Resource temporarily unavailable
    can't get device qualifier: Resource temporarily unavailable
    can't get debug descriptor: Resource temporarily unavailable
    aZQA


    Again this is for a S905 A95X Nexbox 16gb/2gb

  • I'm trying to test a basic patch to support color space conversion for my bt2020 videos so they're watchable (not hdr but hdr tv unfortunately), and haven't been able to boot even current kszaq libreelec-7.0 HEAD builds on my s905x device from sdcard. Kszaq's builds boot flawlessly.


    I don't know what's different between how I'm building for sdcard, and how kszaq does:


    PROJECT=S905 ARCH=arm make amlpkg


    I then dd the image, copy dtb (gxl_p212_1g.dtb), and try booting. However, on booting the sdcard it is unable to mount LABEL=DISK (unlike kszaq's builds).


    How can I build for sdcard? I do working non-media_build/backports builds for my s805 mxq, but do tar internal updates on it.

    Edited once, last by blinkmxq ().


  • However, on booting the sdcard it is unable to mount LABEL=DISK (unlike kszaq's builds).


    I believe the partition labels should be LIBREELEC (boot) & LIBREELEC_DISK (storage) ;)
    (Or, perhaps it hasn't changed for the 7.0.3.x builds :s )

    Edited once, last by Poida ().

  • I believe the partition labels should be LIBREELEC (boot) & LIBREELEC_DISK (storage) ;)
    (Or, perhaps it hasn't changed for the 7.0.3.x builds :s )


    It differs between libreelec 8 and 7: LibreELEC.tv/platform_init at libreelec-8.0-sX05 · kszaq/LibreELEC.tv · GitHub and LibreELEC.tv/platform_init at libreelec-7.0 · kszaq/LibreELEC.tv · GitHub


    Edit: I just tested a libreelec-8.0 build from kszaq's repo, and got: Error in mount_storage: mount_common: Could not mount LABEL=LIBREELEC_DISK


    However, kszaq's last libreelec-8.0 build dd'd to a micro sdcard the same way works. So I'm definitely missing something in the build process for micro sd or s905x.


    Update: partition layout from amlpkg .img isn't correct, and the second partition doesn't mount. Using the same structure and just updating the build seems to work.

    Edited once, last by blinkmxq ().