[7.0.3.012l] LibreELEC 7.0 for S905/S905X


  • See this post:


  • Thanks kszaq for the new 7.0.3.012b build.


    Just tried this on Nexbox A95X (amlogic S905X 2/16 gb)
    - now tvheadend server with my dvb-t2 usb (mygica t230) working flawlessly
    - will test more later, especially docker :)


    Docker doesn't work in 7.0.3.012b. I will upload 7.0.3.012c today with the only difference being fixed Docker support.
    [hr]


    If it's not too much to ask could you please compile your next build for 'installtointernal' directly as well. I need to update several friends MiniMX-G boxes that are using Alex's old 7.0.2.005 build and I would prefer to do so directly via recovery. Sorry if I'm out of line by asking, I appreciate all your hard-work greatly


    I can upload the build but with no support. You are aware that installing in recovery wipes user data? You can also try a direct update - put img.gz in Update folder along with a device tree. This should work because as far as I'm aware Alex's builds are based on my sources.
    [hr]
    @all OP updated with 7.0.3.012c build. The only difference from 7.0.3.012b is fixed Docker support. A build with disabled temperature sensor is also available.

    Edited once, last by kszaq ().

  • What are the risks for running with the temp sensor disabled? I don't care if the box burns up, its just i leave it on 24/7 and hoping the box will die before it catches fire. If it ever comes to that.


    Does anyone know if these boxes come with hardware temp sensors or it stickly software?

  • FAQ
    [hr]
    Q: My remote control does not work, what can I do?
    A: Grab remote.conf file from Android firmware (it's available in /system/etc) and copy it to Configuration folder: /storage/.config over SSH or \\your_box_IP\Configuration using Windows shares. You can also put that file to main folder of your SD card. You may need to remap some buttons.


    Can someone help me to get my remote working. I have a Tronsmart S95x. Ive copied the remote.conf file from android over to LE in the .config folder. As well as putting a copy in the root of the sd card, reboot, and still no working remote. What am I missing? I see that I may need to remap some buttons but there is absolutely no response at all from anything I try. I also have a Tronsmart S95 Pro which works really well, so something do do with this 905x chip and the default remote I guess.


    The remote works to power the box on but nothing else.


    Also, my remote from my Tronsmart MXIII Plus can control the S95x perfectly if I put a custom remote.conf file on the box, yet the S95x remote does nothing. It works in android, just not LE Kodi. Im loosing my mind over here.


    So I guess what I need to do is find a custom remote.conf for my specific remote. That file doesnt exist on the S95 pro so I have nothing to copy over to the S95x.


    This is my remote:


    Anyone got any ideas?
    Thanks.

    Edited once, last by Charbs ().

  • You might have tried to find 30 seconds of your time to read the Changelog and known issues which would answer the KNOWN issues you asked about.
    It would have taken you less time than writing all the observations you just wrote.


    Yes, you're right and it's my bad.
    But except the known issue of dark menus until first video playback, the general statement that HDR is still buggy, which is understandable, I thought that maybe my results could help.


  • Yes to both questions. Remember that you will be switching from 64-bit to 32-bit build, please read read addon notes from the first post carefully.

  • Is there any working solution for


    Cannot get MTD information for /dev/nand_env
    Error: environment not initialized


    after installononternal?

  • Hi all,


    no way to start libreelec from SD on my OTT MXQ PRO 4K (leelbox) with this version (with or without temp mod, version A, B or C)


    With prev version work fine.


    With this version i get always this error and i have tried ALL DTV file into directory of this build.




    WHAT CAN I DO? Thanks in advance


  • no way to start libreelec from SD on my OTT MXQ PRO 4K (leelbox) with this version (with or without temp mod, version A, B or C)


    With prev version work fine.


    Please confirm your specifications are as below.
    What is the previous version that worked ?
    Specifications
    Chipset: Amlogic S905 Quad-Core [email protected]
    GPU: Penta-Core [email protected]+
    FLASH: 8GB NAND FLASH
    SDRAM: 1GB DDR
    LAN Ethernet: 10/100M

  • Hello...


    Installed 7.0.3.012c and i cannot sync Kodi library with Trakt nor TVShow Time...


    Does anyone else has this issue?


    Best regards...

  • How do I flash back to android after installing LE on internal?


    I cant get my remote working with LE im gonna try starting over from scratch on Android and grab the remote.conf file again to see if that helps.


    Thanks.




  • I used libreelec 7.0.2.007 from SD and Libreelec 7.0.3.11 Arch64 booting from SD and flashing into nand with installtointernal 2 times and rebooting with rebootfromnand.


    I have exactly this specifications:
    Chipset: Amlogic S905 Quad-Core [email protected]
    CPU: AArch64 Processor rev 4 (aarch64)
    Revision: 020c
    GPU: Mali-450 MP
    FLASH: 8GB NAND FLASH
    SDRAM: 1GB DDR
    LAN Ethernet: 100M


    I have used V7 image with P200, also if my board it's blue p201 MXQ-S905-D16 V1. Work fine only with this Android IMG burned with burning tool.


    Help me plz

  • I have T95m (old one with s905 on board) tvbox with RTL8723BS and I still get "No Bluetooth adapter found" after enabling BT in LibreELEC settings (i do use latest version of LibreELEC with BT fix) but after typing "modprobe 8723bs" in SSH session my BT finally appears and works as it should, so I have a question if there is any problem with proper module initialisation or its just my tvbox acting weird?


  • You don't mention the Device Tree you used to update ?
    gxbb_p201.dtb from s905/7.0.3.012/device_trees/ ????
    Or did you skip that part.
    Is that your Board you are mentioning.

    Edited once, last by kostaman ().


  • Is there any working solution for


    Cannot get MTD information for /dev/nand_env
    Error: environment not initialized


    after installononternal?


    You shouldn't worry about that error if installing goes fine.
    [hr]


    I have T95m (old one with s905 on board) tvbox with RTL8723BS and I still get "No Bluetooth adapter found" after enabling BT in LibreELEC settings (i do use latest version of LibreELEC with BT fix) but after typing "modprobe 8723bs" in SSH session my BT finally appears and works as it should, so I have a question if there is any problem with proper module initialisation or its just my tvbox acting weird?


    Please post logs. LibreELEC

    Edited once, last by kszaq ().