Create remote.conf from scratch

  • @Jeffers  you first need to get the first change to the template is to insert your correct factory code

    2) Set Factory Code

    From the PuTTy output you posted, the generated error appears to be 0xb24d4040, so you would change line 33 of the template to factory_code = 0x40400001

    Edited once, last by Poida ().

  • Sorry, what I mean is:

    When you type '/storage/.config' what are you trying to do? That's just the folder remote.conf should be in - looking at the first post the OP is just giving you an address, a place to stick the file, not an instruction to type. I can see how it's not clear if you're unfamiliar with putty / ssh.

    Do you have a remote.conf that you want to stick in /storage/.config?

    This is my remote.conf file for wetek play 2, if that could help someone ...

  • Quote

    Jeffers (in another thread):

    Question:- How do I edit the remote.conf when box is booted to LibreELEC, I did it by editing file on USB stick on my laptop and recopied into LibreELEC

    There are several ways, what I find easiest (from a windows pc) is:

    Open an explorer (not internet explorer!) window.

    1. In the address bar type "\\192.168.x.x" - no quote marks, and replace the number with the real IP of your libreelec box.
    2. Hit 'return' and you should see a list of folders (actually shares) in your explorer window. Go into the one called 'Configfiles' - that's actually pointing at /storage/.config
    3. Open remote.conf with a text editor (I use notepad++), make your changes, save (make sure you don't save as remote.conf.txt)
  • Last Friday my new S905X box arrived, and over the weekend I've been tinkering with the remote.conf. Thanks to the excellent instructions in this thread I've set it up almost perfectly to my taste, but there's one issue remaining.

    I noticed that all my keys were working correctly, except one key that I've mapped to the TAB key (to switch to/from fullscreen). That key always got registered as ESCAPE. I was sure my remote.conf was correct however, because if I did another remotecfg .config/remote.conf, the TAB key worked correctly.

    It turns out that at each boot, the .config/remote.conf file isn't read directly, but it is first copied to /tmp/remote.conf while having certain codes stripped out. In my remote.conf I had


    0xe1 15 ; KEY_TAB


    But in /tmp/remote.conf, that was replaced by


    0xe1 1

    You can see what codes are being stripped out (replaced) in /usr/lib/libreelec/remote-config. This is the relevant part:

    Code 15 (KEY_TAB) is being replaced by code 1 (KEY_ESCAPE), code 63 (KEY_F5) by code 90 (KEY_KATAKANA), etc.

    Does anyone know why this is being done? Since this file is in the read-only filesystem, the user can't easily fix it himself. Right now my workaround is to put another remotecfg in the, but I'd like to know why this is being done in the first place.

  • Thanks to the patience of Poida helping me to understand how ro work out my remote's factory code see post Create remote.conf from scratch, I now have the basics on my remote working.

    Can anyone point me to a table/list of a full set of the key action codes with an explanation of what the codes mean (what action Kodi will take when the key is pressed), that can be used in the remote.conf? If I end up with spare keys on my remote I could use them to allocate options I would like to do in Kodi.

    For example the obvious ones are 166 for power, 105 for left, 106 for Right........

    If I map and activate my colour keys, what do the key action codes 398, 399, 400 and 401 do:-

    # 0x53 398 #RED
    # 0x5b 399 #GREEN
    # 0x57 400 #YELLOW
    # 0x54 401 #BLUE

    Whatever the action codes do, I may want to allocate different action codes not used in the template.

    I would also appreciate being pointed to some explanation of what some of the options in the template I used from the OP mean and how to use them. For example:-

    # fn_key_scancode = 0x44 #MOUSE
    # left_key_scancode = 0x25 #LEFT
    # right_key_scancode = 0x27 #RIGHT
    # up_key_scancode = 0x26 #UP
    # down_key_scancode = 0x28 #DOWN
    # ok_key_scancode = 0x0d #OK
    # 0 0x25 #LEFT
    # 1 0x27 #RIGHT
    # 2 0x26 #UP
    # 3 0x28 #DOWN

    I haven't got my mouse working yet, any help would be appreciated

  • Hi

    Does anyone know which is the code for KEY_TITLE?

    Actually I have another question: the original remote config files under /etc/lirc for xbox remote, xbox360 remote etc... are a kind of different

    The use mnemonic key identificator (KEY_0, KEY_TITLE, etc...) instead of numeric code. And they don't even use the factory_code setting....

    Is anyone expert of this lirc configuration?


  • The problem is that I have tried to set it, but I don't get the action assigned to TITLE happening, i.e. Process Info (codecs, etc...) while watching movies...

  • I have just been having a play with my remote.conf

    I can't explain what these things mean.

    Have you enabled mouse in kodi, settings system, input, devices

    Regarding the coloured buttons, I just used the same procedure to find out the codes,

    My Red, setup button is not configurable, the others, App to stop, volume + FF volume - REW

    #v- mute v+

    0x10 19

    0x41 113

    0x18 33

    The mouse button I set to Play/pause

    #app mouse

    0x0f 166

    0x00 164

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro, X96+, Fire TV 4K Stick (Bedroom)

    Synology DS414 Plex Pass


  • H96 PRO PLUS Remote



    if you want virtual mouse support on the remote

    Edited once, last by Shonk ().

  • Im confused.

    I went info file manager in Kodi (le8) searched and found STORAGE folder, opened added .config.

    Would not save the (.) bit.

    Went into (ip of box)

    Found Configfiles folder. Opened and tried to add .config folder. Wouldnt let me with the (.).

    Added STORAGE folder.

    Put remote.conf there,

    Also tried it in storage/config/remote.config

    still cant make IR remotes work...grr help :(

    pi3 and Beelink Android both with LibreELEC

    Odroid C2 and H96 Max 905X2 with CoreElec

  • Opened and tried to add .config folder. Wouldnt let me with the (.).

    Added STORAGE folder.

    Put remote.conf there,

    still cant make IR remotes work...grr help :(

    Connect via SSH -> /storage/.config


    Connect via \\<IP> from windows PC and use folder 'Configfiles'

  • Connect via \\<IP> from windows PC and use folder 'Configfiles'

    I can get there

    Do I just drop the remote.config file there in the configfiles folder when click on the folder?? Thanks

    edit: did that but still nothing. Made a folder in there called storage/congig/ and tried in there ...still no good

    IR remote (MiniMX) worked fine in LE7. Just wont work in LE8

    pi3 and Beelink Android both with LibreELEC

    Odroid C2 and H96 Max 905X2 with CoreElec

    Edited once, last by bazzle ().

  • Do I just drop the remote.config file there in the configfiles folder when click on the folder??


    Don´t create a folder /storage/config -> will not work

    Plan B:

    SSH to box

    1. mount -n -o remount,rw /flash
    2. cp /storage/.config/remote.conf /flash
    3. reboot
  • Many thanks. My remote is now working. Is it possible somehow to copy the remote.conf file to the /etc/amremote folder instead?

  • Hi,

    remote.conf from android does not work on libreelec. Where is the error? Please help....