S802/S812-Libreelec images for 7/8/9

  • Hi All,

    Hello i own a mxiii 4k 2gb android TV box. Could someone tell me the exact image file to download for this install.

    Thanks in advance.


  • LibreELEC-S8X2.arm-8.2.3-S82.img.gz is what I run on my MX-III 2GB device S802 CPU AP6330 Wifi+BT

  • Hello everyone, I have a minix x8-Hp box and am having some issues getting the Libreelec to run. I have read a large amount of the 88 pages of posts and I thought I had it down but I am a newbie with libreelec . I have 2 of these boxes one rooted to 5.1.1 but would like to try this solution on the other booting from SD card with android still accessible.

    I flashed my box with the Remix115k4.zip

    android started let updates happen.

    Unplugged Box and removed SD card with Remix on it

    put LibreELEC-S8X2.arm-8.2.2-X8H-PLUS.img.gz to SD card using libreelecSD creator (on OS X)

    added Nocompat.zip to SD

    inserted SD card , plugged in box, held power button down for 6secs.

    Blue light flashed on and off nothing on screen.

    Did I do something wrong?

    also tried toothpick boot same results.

    thank you for the work to keep these boxes working .

  • I have a Matricom Q2 2GB and everything I read seems I should be looking for an S812 arm which could be the M8S or MIII or MIII Plus.....to no luck I cannot get this on an SD CARD and have it update to LibreELEC.

    I have tried so many img files and I don't want to brick this thing.

    I did not have this much trouble a few years ago with my MX2.

    Any help you can provide. I'm completely lost now on where to start.

  • @ Demitris

    2 questions Dimitris, regarding an "old" S802 1GB box.

    Fully works with your MXIII-1G rom variant, but:


    I have always ONLY been able to update with the tar file (on a fresh install, i must first flash an old openelec build through recovery, and then update with the tar).

    Since your first release, if i boot with the img burnt on an SD card, gives me "corrupted file system detected" and if i let it do the repair, says "system is beyond repair bla-bla-bla". I even flashed the Remix-115k4.zip, android works, but your img will not get past the repair.


    I have been trying to boot armbian on it, but Balbes150's images probably do not support this box. Tried sd, usb, newer and older dtb's for this box, nothing, black screen for hours.

    Any pointers? Thanks.

  • Hi All,

    This is the exact description of the box i own.

    MXIII-G S812 2GB/16GB Android 5.1 1000M LAN Quad Core 4K x 2K H.265 Decoding 2.4G/5G WiFi Bluetooth 4.0 Kodi XBMC TV Box Android Mini PC

    Please suggest the best image.



  • Hi gujal,

    Installed the suggested img in SD card.

    I used the libreelec-usb-cd creator tool.

    After that toothpick method.

    I am getting this error and long boot and no progress ...

    "libreelec a start job is running for load kernel modules"

    Please suggest

  • no WiFi working for me with LibreELEC-S8X2.arm-8.2.3-MXIII-1G.tar , i tried to upgrade to LibreELEC-S8X2.arm-8.2.3-S82.tar but to freezes, doesnt go beyond pulse audio etc etc...

    any way to revert it ?

    edit: reset button does not work anymore

    edit 2: got remix to boot, now how do i re-install this releases ?

    Edited 2 times, last by kxrls ().

  • Remix does not let me access recovery boot :/

    anyway to get around this ?

    edit: used TWRP (downloaded from playstore) and flashed zip with that app.... (rebooted / autoflashed )

    i have a mygica atv 582

    Edited once, last by kxrls ().

  • I'm with you i have no clue what software to use, I have been using the First Gen Q box for years running the M8 Software with NO problems at all, i have bricked 2 of the Q2 Boxes so far, I have LibreELEC-Amlogic.arm-M8SPlus-8.2.5-update installed in it now BUT found the remote will not work and the Network Cat5 settings are all wrong (Gives a 169.xxx.xxx.xxx Ip address) Wifi does work, I fixed the Remote problem