S802/S812-Libreelec images for 7/8/9

  • hi all, I'm hoping someone can please help me - I have an old Beelink M8 box - one of the first round black and red coloured media players and I've tried the following images on SD card, but nothing boots.. I just have the grey boot screen (which flickers a few seconds after initial boot.. then nothing).


    LibreELEC-S8X2.arm-8.2.3-M8.img

    LibreELEC-S8X2.arm-8.2.3-M8S-PLUS.img

    LibreELEC-S8X2.arm-8.2.3-S82.img


    I have used win32diskimager to write them to the known working SD card but none of them appear to work.


    is there another boot image I should be using? is my box bound for the rubbish? any comments / help much appreciated. thank you.


    EDIT: also I want to check my expectations - the unpacked IMG on the SD card should be booted to, just like my newer mini M8S box does right? I don't need to update the firmware on the Beelink and it's internally booting from that correct?


    EDIT 2: Friday - no comments? I'm asking about booting as early libreelec needed to install to NAND from memory, it didn't boot from SD card. Should I try booting from USB?


    EDIT 3: I've now tried LibreELEC-S802.M8.arm-8.0.RC4.img written to SD card using win32diskimager and I press the toothpick in the AV port and feel the button click, hold it in for count of 5 then let go.. but still no booting from the SD card. what am I doing wrong please? thank you.


    EDIT 4: Sunday.. wow no comments or assistance, slightly surprising considering how active this thread has been recently. Ok so looks like the S802 cannot boot direct from an SD card unless you install a modified bootloader? I'm reading up how to do that for my Beelink M8 S802 round box, but would still appreciate any assistance / comments on booting libreelec + Kodi on this system. Thank you.

    Edited 4 times, last by gizmomelb ().

  • hi all, I'm hoping someone can please help me - I have an old Beelink M8 box - one of the first round black and red coloured media players and I've tried the following images on SD card, but nothing boots.. I just have the grey boot screen (which flickers a few seconds after initial boot.. then nothing).


    LibreELEC-S8X2.arm-8.2.3-M8.img

    LibreELEC-S8X2.arm-8.2.3-M8S-PLUS.img

    LibreELEC-S8X2.arm-8.2.3-S82.img

    You likely haven't read enough of the forum posts. There is a ton of good information available in the posts.

    You can try this from post 1048 - this allows the box to boot from the SD card slot. Once done that try installing one of the M8 roms.

    1- Download "Enable SD card dual boot" zip file, copy file to sdcard/thumb drive (I used sdcard) - OpenELEC-MX3G.arm-DualBootSD.zip

    2. "Toothpick" boot your device into (original) recovery mode (took~30 seconds), select install ZIP from EXT & select "OpenELEC-MX3G.arm-DualBootSD.zip" Note that there was an error on the bottom line of the zip screen - E:/misc - I didn't write it down. It had no effect on the process.

    After the zip ran I formatted the sdcard with SDformatter v 5.0. Then burned the ROM image to the sdcard and toothpick booted into LE.

    5 seconds often isn't enough to get LE started, might take 30 or more seconds.

    If the newer roms don't work try reading through the full 1048 post and the posts from #1 up to that point..


    MXIII-G, M8 and Beeklink MXIII Plus LE 8.2.2 - Demetris, Mecool M8S Pro+/Abox A1, Abox A1 Max Coreelec 9.0.2. Thanks to all.

  • thanks doggyofone - I saw your post but it was for a different model.


    I have progressed.. I still had the ''original'' 102K4 firmware on the M8, so I looked for newer and couldn't find an official firmware - but I did much reading and installed the ReMiX 115K4 firmware - which works well and also allows me to boot from SD card.


    EDIT: link to ReMiX here - [ROM] RemiX 115k4 >>>s802 - FreakTab.com



    I literally just tried rebooting the media player with libreelec on SD card and it boots, does some checking and gives me a lot of error messages but the main error message seems to be with thinking the SD card is read only.


    repairing filesystem...


    ?? invalid argument

    Read-only file system


    .ext4: Read-only file system while trying to open /dev/mmcblk0p1

    write-protected; use the -n option to do a read-only


    fsck failed. Yout system is broken beyond repair

    please re-install LibreELEC



    so this is on a known working SD card that I can boot to libreELEC on my s905 media box.


    more reading.


    EDIT: I cannot format my SD card now so probably bad - I don't have another one to test. Will have ot buy on on Thursday (payday).

    Edited once, last by gizmomelb ().



  • so this is on a known working SD card that I can boot to libreELEC on my s905 media box.


    more reading.


    EDIT: I cannot format my SD card now so probably bad - I don't have another one to test. Will have ot buy on on Thursday (payday).

    I've used lots of different cards and never had problems with any. Right now I'm using Lexar 633X and 300X no problem. Also Sandisk cards. I look on Amazon for the faster speeds which you can compare here - Fastest MicroSD Card Speed Tests | Updated March 2018

    I think your box has an SD slot, so Samsung, Lexar and Sandisk are good choices and pretty good prices.

    MXIII-G, M8 and Beeklink MXIII Plus LE 8.2.2 - Demetris, Mecool M8S Pro+/Abox A1, Abox A1 Max Coreelec 9.0.2. Thanks to all.

  • Thanks for the feedback. This info is now in OP

    Regards

    Also fyi these images are for amlogic S802/S812 stop trying to boot them on rk3229, @Jeffers& @ochentay4

  • Thanks for the feedback. This info is now in OP

    Regards

    Also fyi these images are for amlogic S802/S812 stop trying to boot them on rk3229, @Jeffers& @ochentay4

    I know, some guy asked and I answered, but Im trying to make it work on my Tronsmart MXIII 2G. So far I coulndt manage yet to do it. I just managed to install this: Android 5.1.1 (Lollipop) working on S89 (s802) - FreakTab.com and will try to boot LibreElec S82 from SD/Pendrive again to see if it works.

  • Im sorry but I already tried RemiX 115K4 on my Tronsmart MXIII 2GB RAM / 8GB ROM and I never managed to boot from SD/Pendrive. This is strange as hell.

  • I have an M8S. Looking for this image: LibreELEC-S8X2.arm-8.0.2-MXIII-PLUS which I expect to upgrade my box to Krypton 17.. Currently I am using LibreELEC-MX3G.arm-7.0.1.4.img which is working perfectly with Kodi 16. Dual booting only.


    I am a beginner and have problem trying to get to this image from Page 1. Any help would be appreciated

  • I have an M8S. Looking for this image: LibreELEC-S8X2.arm-8.0.2-MXIII-PLUS which I expect to upgrade my box to Krypton 17.. Currently I am using LibreELEC-MX3G.arm-7.0.1.4.img which is working perfectly with Kodi 16. Dual booting only.


    I am a beginner and have problem trying to get to this image from Page 1. Any help would be appreciated

    Googled what you were looking for and got this:- S802/S812-Libreelec images for 7/8/x

  • Hello,


    I am running the 8.2.2 image on an MX3-G and are mostly happy. The newest 8.2.3 version sadly does not work at all. During starting the libreelec logo is not centered, instead it is in the left upper corner. When the logo disappears nothing happens. Normally the kodi logo shows up and starts. I use a 4k TV if that matters.


    Kodi in libreelec runs a lot faster compared with the Android version, the movies don't shudder as they do a little bit in android (I don't know why this happens but it annoys me, libreelec is fine). But I have an issue which is not there in the android version. The box crashed if i try to display a 3d movie in 2d. Playing in 3d is fine but as soon as I switch to show as 2d the box goes black. Android works well, no issues.


    Anyone an idea how to solve my issues? Thanks!

  • I have the same problem too!! I have the mxiii-g and I had to go back to 8.2.2. I have mentioned it in previous post but no one care. I just waiting the 8.2.4 version with the hope that it will fixing this.

    Edited once, last by gthebest ().

  • good morning Demetris

    well i didnt give up on trying to flash an S812 bootloader to the old M8C variant lol.

    as of right now the box is actually running android 5.1.1, i used usb burning tools to flash MXIII-G_108L1_Tronsmart.img then used TWRP to flash matricom's boot.img.

    android is running ok, wifi is not working but im not bothered about that as its hard wired any ways BUT it does NOT adjust refresh rate at all.

    now this is where things get interesting....

    as i previously reported any of your S8X2 builds "stop/lockup" 2 cores on my box, the last one to work flawlessly was LibreELEC-S802.M8.arm-8.0.RC4.img

    now the box is running Tronsmart android this ALSO "stop/lockup" 2 cores!!!! to fix this i rooted then installed no-frills cpu and set the governor to ondemand and the I/O scheduler to noop and rebooted box. now the cores all working as they should!

    the box does now boot from sd card and i have tried booting the following


    LibreELEC-S8X2.arm-8.2.3-MXIII-PLUS.img results in libreelec logo in top left corner, then starts loading kernel modules then loads with no wifi and 2 cores locked up


    LibreELEC-S8X2.arm-8.2.2-MXIII-PLUS.img loads the libreelec logo fine but then loads kernel modules before finally booting with no wifi and 2 cores locked up


    LibreELEC-S8X2.arm-8.2.3-M8.img fails to boot with "detected file corruption"


    could the 2 cores being "stopped/lockedup" have anything to do with libreelec's I/O scheduler and/or governor? is there a way i can change it and if so how?


    is there any more info i can send you to help?


    as always thank you for taking the time away from your loved ones to provide me and mine with some truly awesome stuff!!!!


    many thanks and all the best


    paul

    Edited once, last by chunk1982 ().

  • Hey Guys..

    I've read through every page on this thread and could not find an answer... I have a Minix X8H-P and trying to get these libreelec builds to boot off an SD card.. I currently have a dual boot setup running libreelec 8.2RC from datrh from the minix forum via an SD card.. I've tried copying the TAR file to the update folder and rebooting. It installs fine but then after the reboot I get the android boot screen for a few seconds then a black screen followed by no signal to the TV... I've tried writing the image to an SD with the libreelec tool and boot the box without the toothpick... Same results.... tried with the toothpick..... same results... I've tried the boot.scr in the boot folder on the SD card, and multiple SD card with no luck.. Has anyone got these builds to boot from an SD card for the X8H-P minix box successfully? And if so, how?

    Thanks

    Shawn

  • Hi,



    I'm using this on my Sandroid M9 (M8S) and it works well (no WiFi or Bluetooth - it's an AP6330 WiFi+Bluetooth chip. It's there a version I should use rather then the M8S-Plus version?



    Also, anyone have any luck upgrading InputStream Adaptive? Mine won't update so I can't use Eurosport!!



    Thank you for reading!!

  • It installs fine but then after the reboot I get the android boot screen for a few seconds then a black screen followed by no signal to the TVShawn

    Seems to be a common problem with the latest version. Try 8.2.2.

  • Demetris - A huge thank you for your development work. I am posting this to help any other ATV 1800 users that happen on this thread


    I have been trying for months to get my MyGica ATV 1800 usable again. Came across this thread and some info from Lparker, after reading the all 82 pages loaded "LibreELEC-S8X2.arm-8.2.3-M8.tar" onto the box and everything seems to work great.


    Tested so Far:

    Lan - OK

    WiFi - OK

    HDMI Passthru - OK (Highest my receiver supports is DTS 5.1)

    Bluetooth - Disabled (I don't think my box ever had bluetooth) Bluetooth Works - enabled it in services it saw my phone, don't have anything to connect to it.


    Still to test is the remote, the ir on this box died a year ago and the rf remote was always flakey so I typically use Kore on my phone, I will dig out the remote and see if it works now.


    Playback is smoother then it ever was when the box was running android.


    Procedure:


    Update to the OpenElec found on the MyGica website. ATV 1800E UNOFFICIAL OPENELEC KODI 15.2 - 02/18/16 - Downloads - MyGica Support Forum

    Put the LibreELEC-S8X2.arm-8.2.3-M8.tar into the .update folder and reboot.


    hope this helps someone


    Edit - 2: IR remote does not work, but as stated the IR stopped working a year ago when still on android suspect it is hardware related. RF remote works fine.

    Edited 2 times, last by pillswoj: Bluetooth works ().

  • Seems to be a common problem with the latest version. Try 8.2.2.

    Do I just need to write the image to the SD card and reboot? or do I need the 805 auto script or boot.scr?


    EDIT:

    Tried every which way to get this version to work also, same issue... Tried the boot file in the boot directory, tried the 805 script, tried updating with the TAR file, tried booting from SD with and without a toothpick... Looks like Datrh is working on a LEIA build, I'll just wait for that..

    Edited once, last by ProWinDeX ().

  • Where can I find 8.2.2 image for MX3-G please?