[8.0.2e] LibreELEC 8.0 for S905/S905X

  • Wow just wow, I was so close to buying a Minix cause I thought my box was doomed to be laggy and buggy.


    Installed to USB and it runs like a dream! Copied over the correct remote.conf and bang all good, to my amazement too my Wi-Fi speed has exploded, so much faster!


    Big thanks to the Dev, amazing work!


    I've been reading and to my understanding I can't suspend my box because I'm running off USB? Can anyone please confirm?


  • alexeiyo Once again I'm sorry to say that your WiFi chip is not supported. I've sent multiple requests to the manufacturer for driver source code only to be ignored.


    Thanks for the reply.
    Hopefully, my relative wouldn't need the WiFi in the near future.
    So my box's model is definitely a good candidate for a blacklist.


  • First line in the OP: suspend is not reliable and thus disabled completely.


    I see no reason to use suspend anyway, given the fact that a shutdown and then a power on takes like 10 seconds in total to complete (running with an UHS-I / Class 10 SD card)

  • SSH Into box and you will see all Directories. Apparently Remote works using my instructions. #2,609
    Hope you got it sorted.


    Like I said before, there's no directory ('folder' for windows people) in the entire file system named configfiles. I'll just wait for the next release, maybe it'll be fixed then. Thanks for your help.


  • type crontab -e, paste 50 23 * * * poweroff, save and exit nano; box should now power down at ten to midnight - just tested and it's working fine.




    Like I said before, there's no directory ('folder' for windows people) in the entire file system named configfiles. I'll just wait for the next release, maybe it'll be fixed then. Thanks for your help.


    /storage/.config/ is the configfiles dir (mounted with SMB as configfiles).

    Edited once, last by her ().




  • /storage/.config/ is the configfiles dir (mounted with SMB as configfiles).


    There's the answer I was looking for. Thanks, I'll copy the remote.conf file there & reboot, see if it works.


  • For everyone who had problems with audio sync in Krypton builds. This advancedsettings works:


    Download advancedsettings.xml for Krypton


    How can I test/check whether I need this or not? So far I haven't noticed audio issues, but I would like to make sure.


  • Thanks a lot, I did as you said, install 8.0.0g via usb, then put the remote.config in the configfiles folder via ssh, and the key now turns off and turns on the box.


    Ciao dibotto,
    if you want the "suspend" feature on minimx here's the link to custom version: is kszaq 8.0.1h but with suspend enabled


    MEGA


    saluti

    Edited once, last by stormrev ().

  • type crontab -e, paste 50 23 * * * poweroff, save and exit nano; box should now power down at ten to midnight - just tested and it's working fine.


    Alright, I did it with 30 3 * * * shutdown and that worked, too. Thank you. :)


    Now, I have another slight issue. After a reboot all PVR channels are ALWAYS gone. So, I go into addons and check for an update of Simple IP TV (although there is none) and BANG ... all channels are back without looking/searching for them.


    Anyone else having this?




  • Hi, version 8.0.1h:
    I still have problem with jerky (stutter) playback and massive frame skips on some videos. And next, all files with Dolby THD still are without audio playback (DTS HDMA works properly).
    Test files are described above. Records from camera of TV screen from playing from test files and with enabled Ctrl-Shift-O info, you can fiind here:
    Peter_Gabriel_CAMSCR.mp4, Italy_CAMSCR.mp4, Jelly_Fish_CAMSCR.mp4


    Kodi log here: log-2017-04-28-20.14.01.zip

    Sunvell T95Z Max (S912) 2G/16G 1Gbit LAN, MXV+ (S905) 1G/8B 1Gbit LAN , NAS D-Link 320L, TV LG 65UK6500MLA, Receiver Yamaha RX-V475

    Edited once, last by Whitesak ().

  • I posted the other day with no response :(


    Thanks for your hard work this boots perfect off usb. Been using builds for more months


    My issue is I cannot boot from nand. Black screen. Nothing happens. I must be missing something


    I used the atb nand file booted up, ssh into it. Installtointernal went through the process fine.


    The non nand atb gave me an error.


    As instructions say if it doesn't boot flash again. I did . Same result black screen.


    Am I missing a step. This is driving me crazy.


    Abox 1 plus 2gb is my box. Everything is 100% functional off usb. It works fantastic.


    Thanks guys


  • Try to update to my version LibreELEC-S905.arm-8.0-8.0.1i-I.tar (Copy it to /storage/.upgrade and reboot box.)
    I have no issue to play jellyfish-140-mbps-4k-uhd-hevc-10bit.mkv smoothly with TrueHD passthrough. No drops, no skips.


  • Did you try install to internal from microSD card or just from USB?
    It's worth a try.

    TX5 PRO S905X

  • It was from usb. I will try from a microSD tonight. Any other ideas? Nothing has to be done in recovery or anything that I'm missing right?



    Thanks for your reply.



    Did you try install to internal from microSD card or just from USB?
    It's worth a try.


    [hr]

    Edited once, last by blinksta3 ().

  • There's the answer I was looking for. Thanks, I'll copy the remote.conf file there & reboot, see if it works.


    That did it, remote.conf was not in /storage/.config. Looks like the installtointernal script needs to be updated.


    Thanks to everyone for your help, especially kszaq for maintaining this build.


  • CEC to shutdown the box instead going to sleep or disable this function at all.


    Thanks for your response.
    Setting CEC to shutdown doesn't accomplish anything on my MXQ. Regardless if the box goes to standby or power off, there is no way to turn it back on again without pulling the power supply.


    So is the only option to go to version "8.0.0f"?

  • Quote


    Just tried to installtointernal via microSD, same result. black screen no boot. like box was dead.


    during install everything looked good, and went as planned.


    im out of ideas.


    My box came with rooted Android so I installed TWRP on it. Without it the toothpick method did not work for me. I don't think it has something to do with installing to internal but I know that some new Android firmware are blocking booting from USB and microSD.
    I know it's not the case but maybe there is an older firmware for your box (or newer, check both) that make some changes?
    And try installing TWRP on your box.
    There's an app in Play store that installs TWRP but not every box will work with it.
    Still there are methods to install it manually.

    TX5 PRO S905X

    Edited once, last by yatoya ().

  • Try to update to my version LibreELEC-S905.arm-8.0-8.0.1i-I.tar (Copy it to /storage/.upgrade and reboot box.)
    I have no issue to play jellyfish-140-mbps-4k-uhd-hevc-10bit.mkv smoothly with TrueHD passthrough. No drops, no skips.


    Hi, thank you.
    Jellyfish plays smoothly without drops and skips, but I have no sound - Dolby THD Passthrough is not working.
    Peter Gabriel and Italy demo plays still very jerky with lot of frame skips.

    Sunvell T95Z Max (S912) 2G/16G 1Gbit LAN, MXV+ (S905) 1G/8B 1Gbit LAN , NAS D-Link 320L, TV LG 65UK6500MLA, Receiver Yamaha RX-V475