Posts by her

    I've now had a chance to try John Wick Chapter 2 (Overall bit rate : 83.5 Mb/s), relevant mediainfo attached further down.


    The movie played absolutely fine over a 100mbit link, even when the bitrate briefly peaked at greater than 100mbit.


    I kept PlayerProcessInfo on screen throughout and the cache stayed between 425-500MB for the majority of the movie, dropping down to 375MB during a single scene--so I could have safely reduced cache size by 75% (although the RAM is otherwise being wasted, so I may as well use it as a cache).



    Below is my advancedsettings.xml cache:

    Code
    1. <cache>
    2. <memorysize>1405000000</memorysize>
    3. <readfactor>10</readfactor>
    4. <buffermode>1</buffermode>
    5. </cache>


    Default setting is 20MB, iirc, which is barely even 2 seconds of video and totally insufficient for 4k playback

    No, it was tested and reported in this forum - 100MBit is not enough(most cases)

    I've tested it myself, with Goodfellas - the largest movie I've remuxed (75mbit video, 5mbit audio) and advancedsettings.xml cache <memorysize> set to 1405000000 (same as I set on all my 2gb ram devices), via a NFS mounted share on a MiniM8SII 100mbit NIC box and watched the entire movie without problems.


    Mediainfo of that file attached:


    100mbit is fine, for now. I expect that to change in the coming years, but I'll cross that bridge when I come to it.

    I think this behavior is normal. By default the priority has LAN. As long it's connected the WiFi will be disabled.

    I'm aware that it's default behaviour, but it's not my desired behaviour.


    I've sorted it anyway, for anyone that may read in future:


    cp /etc/connman/main.conf /storage/.config/connman_main.conf


    append: AlwaysConnectedTechnologies = wifi,ethernet to connman_main.conf


    Jobs a good 'un! :)

    Just installed 8.2.0.1and wondering if anyone knows how to enable both wifi and ethernet at boot.


    I need to use local LAN for media, and wifi to connect to scrapers & timeserver. I can enable both and everything works but when I reboot the wifi doesn't automatically reconnect (auto connect is enabled), so I have to manually connect every boot. I tend to leave the box on so it isn't a huge deal, but it would be nice to have them both enabled automatically - anyone know of a way to do that?

    7.0.3.012k on MiniM8SII (s905x, 2/16gb) fails to display kodi, log shows error:

    Code
    1. 13:43:09 T:4119245376 ERROR: AML: no rw on /sys/class/ppmgr/ppmgr_3d_mode13:43:09 T:4119245376 NOTICE: InitWindowSystem: Using EGL Implementation: amlogic
    2. 13:43:09 T:4119245376 ERROR: EGL error in InitDisplay: 3003
    3. 13:43:09 T:4119245376 ERROR: InitWindowSystem: Could not create display
    4. 13:43:09 T:4119245376 FATAL: CApplication::Create: Unable to init windowing system


    log:
    ZPfM


    type crontab -e, paste 50 23 * * * poweroff, save and exit nano; box should now power down at ten to midnight - just tested and it's working fine.




    Like I said before, there's no directory ('folder' for windows people) in the entire file system named configfiles. I'll just wait for the next release, maybe it'll be fixed then. Thanks for your help.


    /storage/.config/ is the configfiles dir (mounted with SMB as configfiles).


    It's not working at all in my case. Even the splash screen is still visible.
    What is the location of your advancedsetting.xml?


    I ssh in and edit it with nano, so the location is /storage/.kodi/userdata/ - if using smb then follow the previous advice. Make sure to use a text editor that uses linux style line endings.


    I think when I disabled splash screen it still displayed until I cleared the cache, after that it no longer displayed.


    Following is my advancedsettings.xml video section, which works fine to delay the audio by 175ms for 23.976/24fps content.


    I know they're completely different but Raspberry Pi's have the "HDMI_IGNORE_CEC_INIT" setting in their config.txt file, I guess we need something similar for Amlogic boxes so we can still use our TV remotes to control the box but don't control the box's powerstate with it. Is something like that already available perhaps? Are there HDMI-CEC config files somewhere that we can tinker with?


    You can change that from the GUI, in Kodi 16 it's in Settings > System > Input Devices > Peripherals > CEC Adapter then choose if and when the device powers on and off, if the device pauses or not when switching sources, etc etc. I assume the setting is still in Kodi 17.


    .


    @ kszaq may i suggest you add following patch to kodi based on work by  juramusger thread-4068.html to avoid dark screen on bootup...


    That isn't a patch, that is playing a video at startup to workaround the dark screen, and is something I think many of us would be opposed to. It's easy enough for someone to set a startup video if it bothers them that much.


    Personally I'd be much more bothered by the extra time taken to start the box because of an intro video playing after boot - the slightly darker menus don't affect usability at all.