[8.0.2e] LibreELEC 8.0 for S905/S905X


  • Updating from "a, b, c" to d or e you need to copy the dtb file too in the update folder because the newest builds is with Nougat kernel or try other dtb.


    It's not "full" Nougat kernel, only some parts ported. No dtb update needed.


    Test build to try before I leave: 8.0-devel

  • Just pop the .tar file in your update folder and reboot

    [hr]


    Initial testing with the dev build and TVHeadend appears to be working again :)

    Devices: Mecool KI Pro S905D & Beelink MiniMX III 2G/16G S905.

    Edited once, last by Hans Gruber ().

  • I have a TicTid M8S+ board that is marked M8S_pro_s905X Rev 1.0 2016/09/23. Wifi chip is Realtek 8189ETV 1GB LAN.


    Is the gxl_p212_2g.dtb the correct dtb?


    Thank you.


  • Hi kszaq, I noticed that in your builds, when one goes to the addons/install from repository section and browses through the addons, the info section actually displays the "news" and the news section is blank. There is no way to see the addon info.


    However when one goes to the addons/my addons section and browses addons, both the info and news sections are displayed properly.


    I checked the chromebox running LE 8.0.1 generic, and on there the install from repository section displays the info correctly.


    kszaq I just wanted to make sure that you saw this


    Thanks


  • Just pop the .tar file in your update folder and reboot


    Easy there, I don't want to update my almost perfectly running build with a test build. For testing I want to install it on an USB Stick and run it from there.


  • Hi,


    You can set the resolution on boot and GUI via SSH by typing this command:

    Code
    1. fw_setenv hdmimode 1080p24hz
    2. fw_setenv outputmode 1080p24hz


    Or using alternative resolution with refresh rate you want.


    Thanks for the reply Rootz, but wouldn't this be forcing Libreelec to run at 24Hz even in the GUI? I thought the "Adjust Refresh Rate" option was so Libre/Kodi could intelligently switch between refresh rates depending on what you're doing.


    This particular setting has never caused an issue before.


  • Easy there, I don't want to update my almost perfectly running build with a test build. For testing I want to install it on an USB Stick and run it from there.


    Install any LE 8 image version on your empty stick/card, then update to the latest and greatest...

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test

  • Hello everybody


    I have played several 5.1 sound test files on Youtube but seems that my Home theatre is not playing along with LibreElec


    Tried with

    • ALSA AML-M8AUDIO: HDMI
    • ALSA AML-M8AUDIO: PCM


    No stereo upmix
    With and Without Passthrough
    "Adjust display refresh rate" disabled


    * HomeTheatre Sony DAV-DZ310 (connected to TV via HDMI) (Sony DAV-DZ310 Specs - CNET)
    * TV Sony Bravia (connected to TV Box and HomeTheatre)
    * TV Box: Beelink M18 (Amlogic S905, 2Gb RAM) ([REVIEW] TV Box Beelink M18 - Amlogic s905 - El hermano mayo : Smart TV y Monitores)
    * Librelec 8.01e


    Logfile: UWFK


    Suggestions?


    Thanks in advance

  • Thanks for the reply Rootz, but wouldn't this be forcing Libreelec to run at 24Hz even in the GUI? I thought the "Adjust Refresh Rate" option was so Libre/Kodi could intelligently switch between refresh rates depending on what you're doing.


    This particular setting has never caused an issue before.


    Yes, ill force GUI at 24Hz but why you want more Hz in GUI?
    I set to 24Hz because most of media i see is 23,976 frames so the TV don't need to change rate always it only change if see a content different like TV (50Hz) or something else.
    My settings on the pics above:


  • YouTube is not 5.1 capable.


    Tapatalkkal küldve az én SM-J320FN eszközömről


  • YouTube is not 5.1 capable.


    Tapatalkkal küldve az én SM-J320FN eszközömről


    Thanks


    Tested with a 5.1 TV Show and:


    If Kodi is configured 5.1 I barely can hear the voice of the characters of the TV show.. Just when I set it 4.1 works (But I'm sure there is one channel missing)


    Also tested the Home Theatre just by itself (libreelec not running) with the sound test and all the speakers/channels are working.


    What might be wrong?


  • 8.0.1e available to download.


    I have to take at least 10 days break. I won't be updating my builds and won't be writing on forum. Please enjoy the builds responsibly and help each other like you always do. See you later. :angel:


    Enjoy break. When you read this, consider setting a 8.0.1e tag in git for reference.

    player : Mini MX-G p200_2G & Inphic Spot i7 PRO p212 & Khadas VIM2 q200
    monitor : iiyama ProLite E2283HS
    speaker : UE Boom 2
    dvb-t : PCTV microStick (79e)
    firmware : android | LE 64bit | balbes 3in1 | gentoo


  • Yes, ill force GUI at 24Hz but why you want more Hz in GUI?
    I set to 24Hz because most of media i see is 23,976 frames so the TV don't need to change rate always it only change if see a content different like TV (50Hz) or something else.
    My settings on the pics above:


    Thanks again for the reply Rootz. I thought I read in the past that the GUI can feel a bit more sluggish at 24Hz but I've never actually tried it myself.


    While I'd say about 90% of my content is probably 23.976fps I know there is still some TV content I get that's 60fps. I'd like the refresh rate change to work as intended, not have to force it to always be one thing, if possible. I'm assuming it's not a setting thing at this point.


    As I said before, I set up a couple S905 Beelink's (with Libreelec 7) and didn't have this issue. Is this is known issue with the S905X? Is it something with Kodi 17 or Libreelec 8? Anyone else having the issue?

  • Hi, I have strange TV.
    When resolution is [email protected] colors like HDR, when [email protected] - normal.


    In version 8.0.1e and devel before starting kodi, TV changes colors like HDR or Libreelec do something??? but TV shows resolution is [email protected]
    All Libreelec versions before works fine!


    New feature "new approach to fractional frame rates" can do this?


    Rolled back to 8.0.1d.

    Edited once, last by fermalin ().

  • If Kodi is configured 5.1 I barely can hear the voice of the characters of the TV show.. Just when I set it 4.1 works (But I'm sure there is one channel missing)


    Also tested the Home Theatre just by itself (libreelec not running) with the sound test and all the speakers/channels are working.


    What might be wrong?


    Your connection between your box and your "home theater" is via the tv, which uses HDMI ARC to transfer audio. ARC can support 5.1 audio, but only DTS, AC3 and PCM, no "HD" audio, and also many tvs limit the type of audio transferred from other sources via ARC to 2-channel stereo (while they will happily pass 5.1 audio from the internal media player or cable/sat/terrestrial receiver).


    You can try to setup kodi to 2-channel output, but allow DTS and AC3 passthrough and see what happens when you play a file with DTS or AC3 5.1 audio. It might just work.

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test

    Edited once, last by mmpp ().