[8.0.2e] LibreELEC 8.0 for S905/S905X

  • Edited once, last by crajax ().


  • I can't find the option to boost the central audio channel. Where is it?


    Removed in Krypton.

    Tomato X96 s905x 2G/16G - 8.0.1i
    OTT MXQ s805 1G/8G - HD18Q.arm-7.0.3.2
    MythTV Backend w/HDhomerun PRIME


  • I'm quoting myself just in case some people are facing the same issue as I did.


    I found a workaround to get my TX95 box booting into LibreElec (must have been something like a broken recovery into original rom): Just install a custom firmware like this one using USB_Burning_Tool, it will then give you the ability to boot into LibreElec using usual toothpick method.

    Edited once, last by flipflop ().

  • Silly question, if I'm on 7.0.3.012g do i need to upgrade the device tree? I recall reading 8.0 still uses the old 7.0.3.012 device tree

  • I have a few bluetooth controllers. I pair in LibreElec, I go into Jokerzbox retroarch port and I can not even get the controller to register, Does anyone have any ideas on what I could be missing or doing wrong? I have no issues with connecting them on PC, Android, OSX etc. Any ideas would be great. Thank you all very much
    [hr]
    Same with Mini USB keyboards, plug usb in, mouse will work but keyboard will not. Thanks again for the awesome work. I should state I am using the latest Krypton 8.0.0c I think it was no sensors

    Edited once, last by dataghost ().


  • How is everyone's GUI smoothness in 8.0.0c? Better or no change than in previous builds?


    I believe to feel c is smoother in GUI than a. But I have not much practice to come to statistical thruth. But feeling also counts.
    [hr]


    Silly question, if I'm on 7.0.3.012g do i need to upgrade the device tree? I recall reading 8.0 still uses the old 7.0.3.012 device tree


    I successfully use old device 7.0.3 trees. In fact I am not sure there are newer ones (for my devices).
    [hr]




    Try replacing addons URL to something like this: options#L129 and use WP2.


    Thanks for the hint! I had not spotted this options ADDON_SERVER_URL key.
    [hr]


    deRedactie.be developer provided workaround fix for his add-on (to be found in github).
    I'll switch from 7.0.3 to 8.0.0 !

    player : Mini MX-G p200_2G & Inphic Spot i7 PRO p212 & Khadas VIM2 q200
    monitor : iiyama ProLite E2283HS
    speaker : UE Boom 2
    dvb-t : PCTV microStick (79e)
    firmware : android | LE 64bit | balbes 3in1 | gentoo

    Edited once, last by Nofan Tasi ().


  • Yes, yes and yes. And yes.
    If you're jumping from 7 to 8 I'd run a backup first, otherwise you can't easily revert - but that's your call.
    I'd also switch to confluence - if you're not already using it - before updating.


    Thanks for the info, I already use Confluence and like it. When updating within the Update folder, is that for my SD card or internal NAND? I run LE from my SD card...


    Thanks again :)




  • Try replacing addons URL to something like this: options#L129 and use WP2.


    I may be missing something but if I define

    Code
    1. ADDON_PATH="$ADDON_VERSION/WeTek_Play_2/$TARGET_ARCH"
    2. ADDON_URL="$ADDON_SERVER_URL/$ADDON_PATH"


    I still end up in kszaq.libreelec.tv since

    Code
    1. ADDON_SERVER_URL="http://kszaq.libreelec.tv/addons"


    Unfortunately I do not find an alternative Addon server URL ...

    Code
    1. $ pwd
    2. kszaq/LibreELEC.tv
    3. $ find projects/ -type f | xargs grep ADDON_SERVER_URL
    4. projects/S905/options:    ADDON_SERVER_URL="http://kszaq.libreelec.tv/addons"
    5. projects/S905/options:    ADDON_URL="$ADDON_SERVER_URL/$ADDON_PATH"
    6. projects/S805/options:    ADDON_SERVER_URL="http://kszaq.libreelec.tv/addons"
    7. projects/S805/options:    ADDON_URL="$ADDON_SERVER_URL/$ADDON_PATH"
    8. projects/Virtual/options:    ADDON_URL="$ADDON_SERVER_URL/$ADDON_PATH"

    player : Mini MX-G p200_2G & Inphic Spot i7 PRO p212 & Khadas VIM2 q200
    monitor : iiyama ProLite E2283HS
    speaker : UE Boom 2
    dvb-t : PCTV microStick (79e)
    firmware : android | LE 64bit | balbes 3in1 | gentoo

  • After upgrading from 7.03.012x to 8.0.0c * it just hung at the libreElec screen after the reboot


    *This was running on an SD card and simply put the img.gz file in the update folder and reboot
    No need to even include a device tree for this update.


    I suspected the problem was similar to when I updated my Linux system from 16.1 to 17 and employed the same fix as indicated here
    [ubuntu] Kodi fails to start


    So a heads-up for anyone who finds the same situation, follow instruction in that link above
    (just ssh into box and delete that file - I actually use cyberduck which is an awesome utility with very simple 'explorer' type navigation - I highly recommend it)

  • I just finished upgrading to Krypton and all my DTS files now show Dolby Digital on my TV and AVR, on Jarvis it would show DTS instead. Also the number of channels has to be set to 2.0 for it to show Dolby Digital, if i set it to 5.1 (which is what I have) i only get PCM 2.0 audio.


    Yes passthrough is enabled and so are the formats my AVR supports.


    EDIT: Turns out you can no longer have "Sync to Display" enabled for passthrough.

    Edited once, last by JonSnow ().


  • I just finished upgrading to Krypton and all my DTS files now show Dolby Digital on my TV and AVR, on Jarvis it would show DTS instead. Also the number of channels has to be set to 2.0 for it to show Dolby Digital, if i set it to 5.1 (which is what I have) i only get PCM 2.0 audio.


    Yes passthrough is enabled and so are the formats my AVR supports.


    Sorry to say I have a different experience. Yes, 'Number of Channels' is always set to 2.0, this was it since Kodi running under Android and I didn't bother to change it.


    I just pulled couple of disk drives and tested several videos with different audio format. For DTS, it shows DTS on my AVR; for DTS MA (or DTS HD), it shows DTS HD and for TrueHD, it shows DD (Dolby Digital) HD on my AVR. Therefore I believe there's no problem with audio passthrough.


    BTW, I'm testing with M18 (S905, 2G/16G), Pioneer VSX-321 AVR using HDMI connection.

  • Update to 8.0.0c worked nicely as all updates before. Only thing is, the MAC of my ethernet controller changed!?


    Thx for a great piece of software for that tiny little box :-)

    * s905x, 2/8GB, Coreelec 9.2.1
    * RPi3, LE 9.2.0, GPIO IR
    * Server, kodi-headless, MySQL, VDR, NFS-Server (& much more)


  • How is everyone's GUI smoothness in 8.0.0c? Better or no change than in previous builds?


    For me 8.0.0.c it's smoother then "a" or "b". Keep experimenting on this layer, pls. Still slower then GUI on Jarvis, but definitely an visible improvement on the last iteration.
    On topic: is it only me or could be a known issue - the colours are a little bit darker compare to Jarvis (same box, same tv)?

    Bqeel M9C Max [S905X/2G/16G]: LibreELEC always the latest community version