[8.0.2e] LibreELEC 8.0 for S905/S905X

  • It's not working at all in my case. Even the splash screen is still visible.
    What is the location of your advancedsetting.xml?

    I ssh in and edit it with nano, so the location is /storage/.kodi/userdata/ - if using smb then follow the previous advice. Make sure to use a text editor that uses linux style line endings.

    I think when I disabled splash screen it still displayed until I cleared the cache, after that it no longer displayed.

  • Quote

    It's advancedsettings.xml no advancedsetting.xml and goes in \\IPADDRESS\Userdata

    Make sure its called just advancedsettings.xml and Windows hasn't given it a hidden extension such as .txt.

    Yep, it was the missing letter 's' in advancedsettings.xml :)
    Thank you for your help! :)

    TX5 PRO S905X

  • Nevermind this report. Just realized 3 LE boxes all had a segfault at the same time. Only one is amlogic. I'm investigating it.

  • My issue with the box shutting down was indeed related to cec. I used to have it turned off but apparently it got reenabled by the new Kodi. I turned it off but it still shut down my box. After a reboot it finally turned off cec though, and it's working happily now.

  • Is there any reason why after a couple of days I stop being able to record with tvheadend I just get constant continuity errors. I have the same feed hooked up to my TV and there is nothing wrong with it.

  • Hello,

    I am new to this forum, I have read most of this topic and successfully installed the latest version on my Nexbox A95X with 2G/16GB.

    It is working fine, I have the impression of more smoothness and fluidity in the menus. Thank you Kszaq for your hard work ! :angel:

    I have still one question left to improve more : how to have a bluetooth (from Esynic) keyboard recognised in AZERTY instead of QWERTY ?

    With Android System, there is optional APK that you can install, but I do not know how to manage this with Libreelec....



    I hope I posted in right topic.... :blush:

    Edited once, last by Marcge ().

  • I think to try this new beta. I had mysql database on my nas with kodi 16.1 (7.0.3 le)
    It worked, but when i switch to krypton i tried make advancedsettings.xml that worked in 16.1, (and worked with k1 plus build le 8 beta of afl1), i cannot make it.
    Always forget what is the settings for media (content type, etc)
    When i use it without advancedsettings mysql setting, the work the identification, but some reason not work when enable it.

    Has anyone some solution or tipp?

  • Have you considered or heard about Emby for managing your media it has great metadata management plus other wonderful features, in addition, there is an addon called emby for Kodi, which interface emby server with Kodi, with right setup everything should be working flawlessly, and save you alot of efforts managing your media throug MsSq, the group have supports teams.

    You can read more about emby from this link
    Support apps and platforms
    Download Emby - Emby
    Emby Blog
    Community support
    Emby Community

    Hope you find it useful

    Edited once, last by e123enitan ().

  • I am not sure if these apply to Bluetooth keyboards, but have you tried going to Settings > LibreELEC and changing the settings under Keyboard in the System tab?

  • Hello Kzsaq,

    Do you think it is possible to change the default action (power off) of the power off remote control button ?

    Usually, when I switched on my TV, the first picture I had on the screen was the start menu of Kodi. This is the case with your 7.12 version.
    With the Beta 6, I have a blank screen. If i try to ping my kodi device, it fails. Reason : Kodi has swith off.

    I think that, when I switch off my TV with the remote control, Kodi turns off too...

    So I would like to test if it is possible to change the default action of the remote control to NOT turn off kodi when I shut my TV off ??

    I use the TV remote control (CEC).
    I didn't have any keymaps.xml file.

    Thanks for your answer.


  • Have you tried CEC in peripherals under settings-->System-->Input
    there you can change the settings not to switch off Kodi when powering off TV

  • kszaq - I'm experiencing erratic commercial skipping on recordings from a mythtv backend. Seems to be the same issue discussed HERE.

    Could you look into the possibility of backporting this patch into your 8.0 builds? -> VideoPlayer: fix edl skipping by FernetMenta · Pull Request #11646 · xbmc/xbmc · GitHub

    Apparently Millhouse has it working in his RPI build?

    Tomato X96 s905x 2G/16G - 8.0.1i
    OTT MXQ s805 1G/8G - HD18Q.arm-
    MythTV Backend w/HDhomerun PRIME

  • In Kodi v17, the following tags are removed from


    and placed under a new


    tag. Also,


    is renamed to




    is renamed to


    .See also: [font]HOW-TO:Modify the cache[/font]<cache>
      <memorysize>0</memorysize>  [font]<!-- number of bytes used for buffering streams in memory [/font]
    [font] When set to 0 the cache will be written to disk instead of RAM -->[/font]
      <buffermode>0</buffermode>  [font]<!-- Choose what to buffer:[/font]
    [font] 0) Buffer all internet filesystems (like "2" but additionally also ftp, webdav, etc.) (default)[/font]
    [font] 1) Buffer all filesystems (including local)[/font]
    [font] 2) Only buffer true internet filesystems (streams) (http, etc.)[/font]
    [font] 3) No buffer -->[/font]
      <readfactor>4.0</readfactor> [font]<!-- this factor determines the max readrate in terms of readbufferfactor * avg bitrate of a video file. [/font]
    [font]This can help on bad connections to keep the cache filled. It will also greatly speed up buffering. Default value 4.0. -->[/font]

    I had to edit my xml when I moved to Kodi.. in the Wiki, it breaks it all down (new changes and all)

  • I install on syno nas, but I don't know how can I use with libreelec as client?
    I tried client with libreelec too, but want me money to unlock features, so thank, no.

    any other way to make work mysql database on LE8?

    i control the database on my synology nas.
    I have MyVideos99 MyMusic56 database for Jarvis and MyVideos107 and MyMusic60 for Krypton.
    Both version filled with data's.
    the Krypton version maked by K1Plus with Afl's dvb LE8Beta6 build, and with that I can use it.
    I don't know kszaq's build why can't connect it.
    I use same advancedsetting.xml.
    When advancedsetting.xml there, then no media and the source for media is change automatic to nothing.

    Edited once, last by envagyok ().

  • The PR is for Kodi 18, not 17.

    That's why I specified "backporting" :D

    Tomato X96 s905x 2G/16G - 8.0.1i
    OTT MXQ s805 1G/8G - HD18Q.arm-
    MythTV Backend w/HDhomerun PRIME

  • That's why I specified "backporting" :D

    The fix is huge in terms of modified code and I know very little about how VideoPlayer works. We should leave it to professionals, I'll ask in the PR for backport.

  • I have 3 boxes running LE builds from kszaq, using a mysql database running on a windows PC. Recently I upgraded from LE7 to LE8 without any problem with mysql. I remember having network problems with some boxes that resulted in empty databases. You can check this post thread-1349-post-9962.html#pid9962.