[8.0.2e] LibreELEC 8.0 for S905/S905X


  • Hi afl1 , wich device tree should we use? I'm trying with device_trees without succes.
    regards, Jefken.

    Raspberry Pi2 LibreELEC Milhouse nightly builds

    Q-Box 2G/8G and Q-Box 2G/16G LibreELEC 8.2 kszaq 's
    NexBox A95x balbes150 Armbian_5.32_S9xxx_Debian_jessie_3.14.29_server_20170907 with tvheadend and OScam.
    Digibit R1 Sat>IP server. (80 cm. dish with disecq 4/2 (28.2E, 23.5E, 13.0E, 19.2E) and fixed 90 cm. dish at 30.0W)

    4 x TP-LINK TL-PA411

  • Hi, I still have problems with audio pass through. On live TV (PAL 50Hz) it is always on PCM. Video-files working as expected. "Sync playback to display" is switched off. This problem only occure with 7.95, with 7.0.3.012 everything is fine. My Box is a NEXBOX A95X (S905x) 2GB/16GB. Does anybody have similar problems?


    Thank you in advance.

  • There is no passthrough available for live TV in kodi Krypton. Multichannel audio will be decoded to pcm.

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test

  • thanks for the manual-workaround. I took a look inside the saved tar image (which is made by beta5 version and found everything is in it. So the backup function works in beta5 but the restore function doesn't work in beta5b.
    Tonight I will resinstal beta5b and try again the restore function and the manual-workaround too.


    Paolo, thank you, worked well, everything is OK with the migrated settings.

  • You should ask: does this build support. ;)


    Someone here said it worked for him with S905/S905X device. AFAIK there are some issues on S805.


  • Hi, I still have problems with audio pass through. On live TV (PAL 50Hz) it is always on PCM. Video-files working as expected. "Sync playback to display" is switched off. This problem only occure with 7.95, with 7.0.3.012 everything is fine. My Box is a NEXBOX A95X (S905x) 2GB/16GB. Does anybody have similar problems?


    Thank you in advance.


    Do you hear crackling now and then? i hear it on my rears, fairly low, but audible. Like i got when PCM was used for movie playback except that was very loud, haven't had that since passthrough started working.

  • Quote

    fractional frame rates are not fully working (frame jumps)


    Thanks for your great built :)
    Could you patch this in the future? :s

  • Do you hear crackling now and then? i hear it on my rears, fairly low, but audible. Like i got when PCM was used for movie playback except that was very loud, haven't had that since passthrough started working.


    Yes, same here. It only happens sometimes with multichannel audio. Stereo seems to be fine.

  • At first, thank you for all your hard work & "open ears" for the community problems kszaq :D and thanks to the hole community for all the help... Im new in that arm based Kodi scene and read the threads with a lot of attention. My first Kodi version (love at first sight) was an alpha version on the xbox with nothing more that one Gui Screen and a list of Videos you can choose - thats it :rolleyes:


    But i dont wanna spam this thread...


    Problem:
    I have a T95x (2g/8gb) and configured it yesterday (with beta5). Like all the known bugs i have one more bug, that i dont read here:


    => When playing HDR video, the colors are wrong (TV recognize HDR). *dirty workaround* But when i start a video and press back (video still playing) and press a second time on the Video, the video restarts with correct colors (TV recognize HDR again). I ordered a second S905x device to see, if its related to the TV or my TV Box (this time a bought a Leelbox MXQ Pro). I will report!


    => By the way, is there any fix for the 3d bug at the horizon? Im mean the bug, where the left eye got both splitted Frames and the right eye is blind.... luxury-problems, i know ^^


    Thank you again for your hard work :D


    UPDATE (10.02.17):
    I installed the Android Version again (stock firmware) and the HDR bug is gone. HDR is starting directly with right colors. It seems to me, it is a LE bug.
    Now i will install LE 7.0.3 *cross fingers*
    UPDATE 2:
    LE 7.0.3 & LE 7.9.5 have the HDR Bug, in Android is all fine. My TV is an LG ef9509.... but im still swear loyality to LibreElec & kszaq ^^ my new favorite 5 letters :blush: ;)

    Edited once, last by dimitrij2k ().

  • I also have a T95X 1g/8g running libreelec 8.0-7.95beta5.
    An audio problem occurs randomly with all video files with multichannel aac.


    Sometimes when playback starts or resumes from a pause, a static high pitched noise is heard which continues until playback is stopped. And then restarted and the noise is gone. Is appears random.


    I have my t95x plugged into my Yamaha receiver then into my tv.


    Issue only seems to occur with AAC audio. Dolby digital DTS and all other HD audio tracks are flawless.


    At the moment, I have set the audio setting to fixed, and reduced the setting to below 96khz (I thinks it's 88.xxhz). Issue is fixed , but this then turns off passthrough audio which I require. I normally have it set to best match.


    Has anyone had similar problems playing AAC audio movies, with the S905x box plugged into a Yamaha amp?


    I have another S905x box plugged directly into tv (no amp) and no issues there at all.




    Sent from my HTC 2PS6200 using Tapatalk

  • Hello...


    I have a Tanix TX5 Pro box with S905X and i installed the latest version of LibreELEC (7.95.beta5)...


    I have connected the box with TV with HDMI and all audio goes from box to amplifier through this HDMI...


    I have enabled all passthrough options in Kodi, except TrueHD and DTS-HD which are not supported by my setup...


    I watched a movie with DTS and it is working fine...


    I watched 2 episodes with Dolby Digital AC3 and when the episode starts everything is alright at the start for about 5 minutes...


    After that i have small random audio interruptions... These interruptions are signal interruptions because i see in the amplifier a notification that audio signal has lost and then came back...


    I did not have this issue with previous Jarvis version of LibreELEC...


    Do you have any idea why this is happening?


    Best regards...

  • Hi kszaq,


    just a general interest question:
    Am I right in assuming, that the "premium" S905 devices (like Odroid C2, WeTek Hub, WeTek Play2) currently have the same issues with the video player / hardware decoding in Krypton, as all the others do?
    For instance the frame skips...


    If this is a hardware decoder issue, all devices behave equally, right?

    Mini M8S II 2G/16G (S905X)


  • Hi logicheart


    I dont have this issue. I'm no expert so sorry if my answer is obvious, but it sounds like maybe your sync to display settings are kicking in. Have those settings been turned on?


    Have u tried disabling this?


    Sent from my HTC 2PS6200 using Tapatalk


  • Am I right in assuming, that the "premium" S905 devices (like Odroid C2, WeTek Hub, WeTek Play2) currently have the same issues with the video player / hardware decoding in Krypton, as all the others do? For instance the frame skips...


    If this is a hardware decoder issue, all devices behave equally, right?


    There are a few differences:


    The wetek devices contain the neccessary keys to allow for HDCP encryption, the odroid-c2 and all the no-name chinese boxes do not.
    The wetek and odroid hardware specifications do not change, so you can always be sure what you will get when you buy the box (esp. with wlan and bluetooth chipset).


    But all boxes with S905 SoC should behave in the same way regarding video processing and output.


    There is currently no box from wetek or odroid using the S905X SoC, so you will be limited to no-name boxes here. While the advantage would be the hardware decoding of HDR and VP9 content, some of the feedback by S905X users makes me think that this chipset might behave differently when decoding h264/h265 video. I do not own a S905X device, so I cannot compare.

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test

    Edited once, last by mmpp ().