LibreELEC (Leia) 9.2 Beta 2

  • Source: LibreELEC (Leia) 9.2 Beta 2 – LibreELEC

  • Tried it for about 2 hours of usage (RPI4 1GB).


    Everything i am using seems to work just fine.


    2 issues still persist from earlier builds.


    1.Occasional tearing on KODI GUI (seems less frequent then previous builds)

    2.Pictures viewer causes total system freeze (only power unplug releases it) from time to time.


    viewing same pictures from file manager works just fine.


    Also after restoring my backup from previous libreelec (RPI 3B+) i had same occasional system freezes until all thumbnail data was kinda refreshed.


    So my guess there is some issue with picture loading/analyzing , tried to find something on debug logs , found nothing.


    I assume i am not the only one with this problem since i can easily reproduce it with almost every jpg i try.


    Keep up the good work.:thumbup:

  • So my guess there is some issue with picture loading/analyzing

    I assume i am not the only one with this problem since i can easily reproduce it with almost every jpg i try.

    Thumbnail creation may still be the culprit there. Create a new topic/thread with a log file and some sample jpg's that are freezing things up for you.

  • Sorry, just to clarify, when Linux 5.2 is the base for Libreelec, that's likely when the os will fully support 4k and HDR with the Pi4?


    I'm curious so that I know for future reference. (I may consider a Pi4 then)

  • Hi,

    How do I know if I have the latest firmware on Pi4?

    The menu appears like this, "Bootloader EEPROM (up to date:2019-09-10)"

    Thanks for the work...

    Raspberry Pi4 2GB LibreELEC

  • The same here with pictures. If my scraper tries to fetch an image, then all the other movie images are going black (even the backgrounds). They appear after a few seconds, tough.
    Can I do a role back? The old Beta version didn't had this problem at all. So I can wait for a fix.

    Thanks a lot!

    Cheers!

    Dive Mask Strap :cool:

  • Sorry, just to clarify, when Linux 5.2 is the base for Libreelec, that's likely when the os will fully support 4k and HDR with the Pi4?


    I'm curious so that I know for future reference. (I may consider a Pi4 then)

    LE master branch is already on 5.3 and will bump to 5.4 soon .. but not for RPi4 which needs to remain on 4.19 until more V4L2 plumbing has been completed. Kodi is slowly inching towards HDR support. It's already possible to hack something up that works for some SoCs (not RPi4 yet) but we'd rather do it properly at a more measured pace. I'm not expecting to see "proper" HDR support for some time yet.

  • Hi,

    How do I know if I have the latest firmware on Pi4?

    The menu appears like this, "Bootloader EEPROM (up to date:2019-09-10)"

    Thanks for the work...

    ^ what's not clear about "up to date" ??

  • WLAN still does not work properly.
    2.4 GHz connects and is very slow.
    5 GHz connects sporidically and is even slower.
    Libreelec Cofigurator Tool brings the system to crash and reboot more often. (In connection with wlan)

  • Well, updated ok. But strange, right after the update, the firetv remote didn't work. Went to Bluetooth and it was there, but not connected. I tried to connect it, no luck, said auth error. Disconnected it and was able to connect but it won't control the menu anymore. Anybody else have issues?

  • That was fast. Thanks very much for x502!

    - Video judder and stutter seems nearly gone. I'm not completely sure, still have to test with subtitles, but the audio/passthrough related dropouts are reduced to a very few, which I'm not sure could have other reasons. In any case: video is much smoother with HW and multichannel audio.

    - CPU temperature in average is now about 5°C lower (with or without HW-acceleration). How is this possible, but maybe I'm wrong and I changed something...

    - Can't detect the GUI-tearing in 1080 at the moment - has improved very much.

    Thanks very much and Greetings!

  • Well, updated ok. But strange, right after the update, the firetv remote didn't work. Went to Bluetooth and it was there, but not connected. I tried to connect it, no luck, said auth error. Disconnected it and was able to connect but it won't control the menu anymore. Anybody else have issues?

    Same with my Harmony Companion remote on RPi4. Gone. No input at all. Couldn't reconnect so far but I'll keep trying.

  • Hi,

    I haven't tested it yet, but big thumb up for no tearing GUI, if it's true.


    Did someone tested if HBR audio is fully supported (DTS HD MA and Dolby Atmos)?. That's what I want so bad on my RPi4. My home theatre just crying.

  • Hi,

    I haven't tested it yet, but big thumb up for no tearing GUI, if it's true.


    Did someone tested if HBR audio is fully supported (DTS HD MA and Dolby Atmos)?. That's what I want so bad on my RPi4. My home theatre just crying.

    DTS HD Master Audio is losslessly decoded to PCM 5.1/7.1 (and the Pi4B supports 192k/24bit at 5.1/7.1 and isn't limited to 4.0 at 192k as previous models are, I believe) - so it's only Atmos that your Home Theatre is crying for? (Or is stream metadata vital for your use case??)