LibreELEC 9.0.1 builds for S905 (semi official)

  • got the same issue as here regarding stereo audio. This is the first time I have used Leia after a fresh install from 8.2.3.1. It is passing multichannel ok to my amp but I get no sound from stereo sources unless I check upmix stereo which sounds awful over 5.1 speakers. If I change the output to analogue it works but this kills bitstreaming.


    Device is a Mecool KI Pro

  • Hello,


    it is neccesary to move the correct device-tree file from the device-tree directory to the root directory and to rename it after the image is writen to the sd card?

  • I am missing the 'Boot from internal' option when shutting down Kodi. How can it be activated?

  • Hello,


    it is neccesary to move the correct device-tree file from the device-tree directory to the root directory and to rename it after the image is writen to the sd card?

    Yes as always.

  • Hello,


    where can I download the appropriate device-tree for my Minix Neo U1 Player? My remote control does not work after installation with the image "LibreELEC-S905.arm-9.0.1.img.gz".


    Many Thanks.

  • I have a siano dvb-t stick that isn't recognized by the default LE drivers, this is the log

    I tried switching to the "DVB drivers from the latest kernel", those do recognize the dvb-t stick but do not recognize the internal tuner of my mecool ki pro, log here

  • Has anyone been able to have wifi working on the MXQ Pro box? I did a dmesg | paste



    http://ix.io/1fhc

  • I've downloaded latest img.gz and burned with etcher to sd card. However, my device boots to Android. What's correct way?

  • Hi!

    I have a WiFi problem with LibreElec. I get low speed and high ping and I dont know why. My device is Tanix TX3 Mini - H, 2GB RAM 16GB mem with SSV6051 WiFi chip inside. Dtb is glx_p281_2g and it boots nice and fast. Signal strength is 75%, it connects to WiFi with no problem but I cant get more than 9Mb/s. I have 20Mb/s ADSL. Android on this same device goes up to 18Mb/s, this version of LibreElec goes to 9Mb/s, LibreElec 8.2 goes up to 12Mb/s and CoreElec 9.0.1 goes only to 4Mb/s. With higher speed ping gets smaller. Can't figure out the problem, it's strange how different versions behave differently with wifi. Is there something I can do to fix this behavior cause I would really like to use LibreElec on my box, Kodi works so much better than on Android...

  • I have a siano dvb-t stick that isn't recognized by the default LE drivers, this is the log

    I tried switching to the "DVB drivers from the latest kernel", those do recognize the dvb-t stick but do not recognize the internal tuner of my mecool ki pro, log here


    I tried Coreelec 9.0.1. With the default drivers it does the same as libreelec, but with the drivers from the latest kernel both adapters work.

  • Hi!

    I have a WiFi problem with LibreElec. I get low speed and high ping and I dont know why. My device is Tanix TX3 Mini - H, 2GB RAM 16GB mem with SSV6051 WiFi chip inside. Dtb is glx_p281_2g and it boots nice and fast. Signal strength is 75%, it connects to WiFi with no problem but I cant get more than 9Mb/s. I have 20Mb/s ADSL. Android on this same device goes up to 18Mb/s, this version of LibreElec goes to 9Mb/s, LibreElec 8.2 goes up to 12Mb/s and CoreElec 9.0.1 goes only to 4Mb/s. With higher speed ping gets smaller. Can't figure out the problem, it's strange how different versions behave differently with wifi. Is there something I can do to fix this behavior cause I would really like to use LibreElec on my box, Kodi works so much better than on Android...

    Get an Ethernet bridge and you'll get proper wifi speeds .. and you'll avoid the future issue that SSV6051 will not be supported on mainline kernel images due to the driver being dreadful crap that we couldn't port (we tried, but, eww.. it's sucky code). It's no surprise that SSV went bust in 2016 :)

  • Thanks for the reply! I hooked it up with LAN cable and performance is much, much better (full speed, low ping)! One more question... My LibreElec is burned on sd card. As long as sd card is inserted into the box I cant boot back to Android. There is a "reboot to internal" option in Kodi shut down menu but it reboots back into LibreElec. Only way to boot Android is to turn off device and eject sd card. Is there something I can do about that? It's super inconvinient to use it this way.

  • I hope that someone will come up with the solution cause Kodi works perfectly on this little box with LibreElec or CoreElec but I would still like to use Android for Youtube and some browsing. Thank you for your help once more, man! I appreciate it.

  • I flashed this LibreELEC 9 version - LibreELEC-S905.arm-9.0.0.img.gz - on my A95X Pro S905W 2GB RAM box. The device tree I used was gxl_p281_2g.dtb.


    Everything seems to work fine. The only difference compared to LibreELEC 8 is that when playing a Blu-Ray Disc, all I get when I reach the main menu with all the options, all I see is text/menu options and there's black screen behind it. I don't see the image or video playing in the background of the menu. And if I'm not quick enough with my selection, the menu will freeze and the only thing I can do is unplug and replug the box to have it work again.


    LibreELEC 8 (Kodi 17.6) doesn't have that problem. Well, the problem since Kodi 17 is the fact that BD menus don't use hardware acceleration so they're kind of slow to navigate through, but at least it doesn't freeze up the system. :)


    I also get the same issue on both CoreELEC and AlexELEC.

    Can this issue be fixed?

  • Hi all, I flashed almost 2 months ago with LibreELEC-S905.arm-9.0.1 (on my old Mini M8S II Amlogic S905X) and it works GREAT! Thank you all for your work!