@balbes150 LE images with Kodi-19 for S9xxx

  • I have, already, installed 9.0.1 version... Is it last version for KI Plus? No newer version?

    Still in development!

    As you can see this topic is for testing the images in development. I hope a little more follow the topic.

    It is useless knowledge if not shared the world.

  • tks for the respond

    the file i used : LibreELEC-ARM-ALL.arm-9.80-devel-20200222095139-569f834-amlgx.img

    the problem is :

    1. no action for install to eMMC

    (ssh to the box in /flash directory i found format file name 8:3)


    2. when i turn off with menu power off, my movie library not load (i used advancedsettings.xml) for movie location

    but when i turn off with power button, my movie library load well

  • I'll re-add the GT-King device-tree to my working tree in a couple of days, then it will magically reappear in Oleg's images. I need to do more testing but the general idea is to send it upstream so it's included in Linux 5.7.

  • I tested the most recent one: LibreELEC-ARM-ALL.arm-9.80-devel-20200304124329-569f834-amlgx

    Do not boot, KI Pro

    I tested an earlier version: LibreELEC-ARM-ALL.aarch64-9.80-devel-20200303122037-569f834-amlgx

    Don't boot, KI Pro.


    balbes150 The bootable version that works on the KI pro, and only from the day 20200217 is the only one that the boot is working.

    It is useless knowledge if not shared the world.

    Edited once, last by erbas ().

  • Hy x96s905x3 max plus libreelec kodi 19


    test there are a version or something possibly?


    please download link.


    I know there is coreelec but it is smoking very much. Previous boxokon I tested it and the libreelecnél is not getting warm at all the box. Concerned loyal ia I am left over.

  • Have you implemented the latest changes for panfrost for the s912? Experimental Panfrost GLES 3.0 support has landed in Mesa

    Unlikely in Oleg's images because LE master is using Mesa v20.x and the changes have gone into Mesa master for v21.x. The GLES 3.0 changes are not particularly relevant for Kodi support as Kodi runs under GLES 2.0. If you're enquiring about overall Panfrost support ..it runs great on S912 now (has been passing all dEQP tests for some time) and there are some Khadas VIM2 boards installed in the Mesa CI lab now so that all Midgard changes are run against T820.


    NB: In the last week I organised a bunch of Bifrost using board samples for the Panfrost devs and Bifrost work has now kicked off! It will be a while before there's usable code, but once that happens, a single LE image that supports GXBB thru SM1 hardware is within our sights :)

  • balbes150

    I installed the latest Armbian just to update the universal multi-boot. (unsuccessfully the same as an update error)

    Armbian_20.02.0-rc1.037_Aml-s9xxx_bionic_current_5.5.0-rc6_20200205.

    I tried the image published today: LibreELEC-ARM-ALL.arm-9.80-devel-20200307231201-569f834-amlgx.

    To my surprise boot worked, it worked. We have an error in the boot screen and restart.

    I tried all driver to detect the mecool KI Pro tuner, TBS5520SE. (without tuner)


    chewitt it is possible to give mecool KI Pro tuner drivers a try.

    Drivers for TBS5520SE in images of the balbes150 or Index of /  milhouse

    Please we want to watch live TV even in HD or SD.

    It is useless knowledge if not shared the world.

  • I tried the image published today: LibreELEC-ARM-ALL.arm-9.80-devel-20200307231201-569f834-amlgx.

    To my surprise boot worked, it worked. We have an error in the boot screen and restart.

    Is a video 4k and sound working?

  • I'm usually working in a kernel that's +1 release ahead of all the media_tree DVB drivers so they never compile and there's not much point in including them until that changes. Oleg's images might be different.

  • I'm usually working in a kernel that's +1 release ahead of all the media_tree DVB drivers so they never compile and there's not much point in including them until that changes. Oleg's images might be different.

    Well if I understood correctly what I said, will the launch of the K19 alpha1 already be possible to use the media_tree DVB drivers?

    If so, do we have a forecast for the K19 alpha launch?

    It is useless knowledge if not shared the world.

  • K19 alpha/beta/launch has nothing to do with it .. DVB support is all about kernel (and out-of-tree driver) versions.

  • Hello,


    I made a quick and dirty test with the latest test-build from test.libreelec.tv from 8th of March (kernel version 5.6-rc4) on Odroid-C2.

    • out of the box it does not support the TP-Link WN822 does not work (works with amlogics 3.14 kernel)
    • CEC doesn't seem to work at all
    • restart and shutdown takes around 30 seconds or longer

    Connected to external TVHeadend server:

    • 720p H264 stream (Das Erste) works with small clock issues (jitter), but without blocking and with relatively low CPU usage (hw acceleration seems to work) - system remains pretty responsive
    • switching hanged the system, but the OS seemed to be there still, because the HTTP server was still reachable via Kore, but you can't do anything
    • MPEG2 streams start either with nothing or green and don't play back

    It's actually way more than I expected for this relatively new kernel. Pretty impressive work so far.

  • If the TP-Link requires some firmware to work let me know (it will be reported in dmesg as a failure to load something) and I'll add the firnware to the image. If it requires an out-of-tree driver, sorry but I don't have time or interest to chase down patches for realtek drivers that break with every kernel bump so all of them are disabled (and no current plans to change that).


    Restart and shutdown now wait for Kodi to gracefully shutdown instead of killing the process after 5 seconds if it hasn't existed (it never does). This avoids frequently reported issues with Kodi trashing configs which are saved at shutdown, but does drag out the shutdown process compared to older LE releases. It's known and is a general Kodi problem not anything specific to Amlogic or these images. There is a long-term plan to refactor/rework some bit of Kodi which should improve timings .. but don't hold breath.


    Hardware decode is still only partially working. H264/VP9 are now reworked and merged for Linux 5.7 and HEVC (not hardware supported on C2) will be next, but ffmpeg stateful API support and the Kodi side still need reworking. Most of the effort on that is currently focussed around Raspberry Pi but since Amlogic shares the same code paths that's not a bad thing.


    No ideas about CEC as I don't use it. I do have a patch in the codebase to disable dmesg log-spamming when CEC is not supported (as I disable it in my AVR) but this is only //commenting out the message and it doesn't/shouldn't prevent actual functionality. Check Kodi settings?