@balbes150 LE images with Kodi-19 for S9xxx

  • I have the hardware X96 max with the S905x² in 4GB/32GB variant, LAN wired. Which file is running and which dtb?


    Thank you very much!

    CT

    X96 max S905X2 (4/32), X96 S905X (2/16) :)

  • Another test with s905x2 this time with a Tanix T5 Max


    I leave images of the motherboard: MEGA


    Wifi:
    RTL8822


    DTB: meson-g12a-x96-max.dtb

    Wifi KO

    Wired OK manual but don´t work

    Sound OK

    Remote KO


    DTB: meson-g12a-x96-max-rmii.dtb

    Wifi KO

    Wired KO

    Sound OK

    Remote KO


    DTB: meson-g12b-odroid-n2.dtb

    Wifi KO

    Wired KO

    Sound KO

    Remote KO


    DTB: meson-g12a-u200.dtb don´t boot

    Wifi

    Wired

    Sound

    Remote


    DTB: meson-g12a-sei510.dtb

    Wifi KO

    Wired KO

    Sound KO

    Remote KO

  • I wish posters would include information that would be useful to others such as


    image used

    dtb used

    ram/rom

    NIC speed


    In that way some comparison might be possible for others such as myself trying to figure out what might or might not work on my hardware.


    Thanks.

  • Works in tanix tx6?


    REVIEW: Tanix TX6 with Allwinner H6 SoC and 4GB of RAM | AndroidPCtv

  • У меня х96макс 4/32. Последняя сборка от 05.24 не началась. Запущен с заменой dtb от 05.12. Звук есть, но только 2.0. AV-ресивер DTS 5.1 долго не может определить, но после определения звук очень плохой. Если дорога до DD 5.1 отправляется транзитом через ресивер к телевизору - есть звук. На ресивере - звука DD 5.1 нет. Во всех этих случаях звук прерывается на короткое время, доли секунды, с интервалом 5-10 секунд. Видео имеет проблемы с перемоткой. А также кодек h265 убивает систему. Vp9 на 1080p работает хорошо, но 4k замедляется. Перезагрузка не работает, только обесточивания устройства делает перезагрузку.

  • У меня х96макс 4/32. Последняя сборка от 05.24 не началась. Запущен с заменой dtb от 05.12. Звук есть, но только 2.0. AV-ресивер DTS 5.1 долго не может определить, но после определения звук очень плохой. Если дорога до DD 5.1 отправляется транзитом через ресивер к телевизору - есть звук. На ресивере - звука DD 5.1 нет. Во всех этих случаях звук прерывается на короткое время, доли секунды, с интервалом 5-10 секунд. Видео имеет проблемы с перемоткой. А также кодек h265 убивает систему. Vp9 на 1080p работает хорошо, но 4k замедляется. Перезагрузка не работает, только обесточивания устройства делает перезагрузку.

    Звук пока работает только в 2.0. Транзит по идее работать не должен вообще. Видео в H.265 часто 10-битное, и это тоже не поддерживается. Сборки в этой теме только для тестов, для ежедневного использования они не подходят. В следующий раз, пожалуйста, пишите на английском. Можно переводить с помощью deepl.com.

  • Registered just because i could relate...


    Hoping to contribute to a more extensive overview, here are my test results:


    - Vontar X96 Max

    - S905X2/u211 SOC

    - G12A chipset

    - 10/100mbit NIC

    - No bluetooth module

    - 2gb/16gb version

    - 2,4ghz wifi b/g


    (aka: the dirt cheap version)


    Image: LibreELEC-AMLG12.arm-9.1-devel-20190521095752-a41fdf1-box.img.gz

    DTB: meson-g12a-x96-max-rmii.dtb (the more recent one posted by balbes150 which now resides at the root of the "kernel_5.x" folder of the yandex disk)


    Results:

    Boots just fine

    Ethernet working, gets IP through DHCP just fine

    Audio only shows bluetooth pulse, no audio over HDMI

    No WiFi

    No remote

    Edited once, last by TheNoor ().

  • Hello,


    I didn't expect these builds to be prime time and nobody said they are. This is true, however they run really smooth and most things are working actually at least somehow. So kudos for these builds, looks really promising.


    Setup:

    • Odroid C2
    • currently C2-build from May 26th for arm (kernel: 5.1.0)
    • copied .kodi and .config from 3.14-stable build (however I also tested most things without this, IR being the exception)
    • from SD card

    Observations:

    • no hdmi output when cold booted; turning the TV off and on fixes this problem
    • HDMI audio works
    • CEC often doesn't work (currently doesn't at all)
    • IR produces double presses or often also queued (second) presses, meaning they are executed once a new button is pressed leading to unexpected behavior :D
    • aspect ratio for 720x576(16:9) PVR content is wrong (pixel ratio wrong)
    • software decoding for MPEG-2 and Xvid doesn't work (AVC does)