[8.2.4.1] LibreELEC Kodi Krypton - S905 & S912 devices

  • ... a download of 151 Mbps, which is in line with my ISP 150 Mb fibre package ( we often get slightly more speed than we pay for here which is nice)...

    Here in Australia, I am getting 4~7Mbps from Telstra ADSL2+ with a package of $99/month (Unlimited Data)... There is no NBN, fibre, etc... available. Could not register with other providers as there is no infrastructure. Where I live is about 10 minutes to the central business district (CBD) in Sydney. So SAD for Australia internet users.


    Oh yes and still wondering if anyone knows about switching off the front panel display which permanently shows "boot" when running LE ?? Not that important but would be nice to fix this. Anybody ??

    Suggest you have a look at this post: LED (VFD) Displays in LibreELEC. Customize it with your own liking.

    X96 S905X 1G/8G WiFi 8189es 100M LAN - LE 8 @ 1.512GHz on SDCard.

  • Hi RayW,


    You write long posts :)


    Glad to see you worked out your ethernet problems.


    I have a Vorke Z6 Plus, which I think is closely related to your box too. I can report that I had similar problem with this version Libreelec 8.2.4.1, whereby I had freezing while browsing the GUI, but NOT while watching videos.


    I never really found the source of the problem, but I think the freezes were worse if I: 1) switched on the weather add-on, 2) enabled some of the pretty screen savers, and 3) switched skins from estuary.


    I think the freezing was caused by overheating which is common in our boxes: I was thinking about adding cooling fans or changing the heatsink, but I was afraid.


    In the end, I never fully solved the problem, so I switched to CoreElec 8.90.4. Since then I don't have freezing problems. BUT I think that Libreelec 8.2.4.1 was actually a smoother user experience than Corelec, I mean navigating through menus, scrolling the GUI, etc was smoother in Libreelec (except for when it crashed of course!)

  • So I still need some help with the freezes using 8.2.4.1 with the TX9 Pro box which happens mainly when scrolling through lists in the GUI, but I have still got to find time today hopefully to try that Advance xml file DirtyRegions setting that wrxtasy suggested to see if that helps. Now I know what DirtyRegions is from the link he gave me, but just did not know of this probablty relatively recent terminolgy for such a system. Many years ago now I was aware of such a basic system of only updating small data changes with most new video frames and this continued for so many consecutive similar frames until sending a new full frame resfresh after no more than every x frames, and whenever big frame changes were detected like an entire change of scene for example or fast moving grahics.


    Oh yes and still wondering if anyone knows about switching off the front panel display which permanently shows "boot" when running LE ?? Not that important but would be nice to fix this. Anybody ??


    Setting "DirtyRegions" in advancedsetting.xml to 0 makes sense only to avoid known "Subtitle Stutter" on S912 boxes.


    For help on seting Front Display ask in this thread.

    ODROID N2_S922 4G - 1GB Ethernet, X92_S912_q201 3/32G - 1GB Ethernet Box_Android 7.1.2, Mocool KM8_S905X 2/16 0.1GB Ethernet Box_Android 8.0, X96Mini_S905W 2/16G 0.1GB Ethernet Box_Android 7.1.2

  • In the end, I never fully solved the problem, so I switched to CoreElec 8.90.4. Since then I don't have freezing problems. BUT I think that Libreelec 8.2.4.1 was actually a smoother user experience than Corelec, I mean navigating through menus, scrolling the GUI, etc was smoother in Libreelec (except for when it crashed of course!)


    To have a smooth scrolling GUI on these boxes it is usually necessary to overclock GPU. It is easily done via autostart.sh for any LE/CE version. It does raise CPU temp for 3-5°C so cooling should be observed - not to go over 80°C to avoid crashes...

    ODROID N2_S922 4G - 1GB Ethernet, X92_S912_q201 3/32G - 1GB Ethernet Box_Android 7.1.2, Mocool KM8_S905X 2/16 0.1GB Ethernet Box_Android 8.0, X96Mini_S905W 2/16G 0.1GB Ethernet Box_Android 7.1.2

  • Thanks Sholander for the advice, I'll keep in mind, although currently even though gui is less smooth, it doesn't bother me that much, i prefer not risk higher temp (i'm keeping the box in an enclosed cabinet).


    I note however that when I was using Libreelec 8.2.4.1, I didn't enable the overclock gpu option, but still the gui was smoother than now with CE.

  • Kodi Krypton is quite different from Kodi Leia_Alpha, so should not be surprised with that ;)

    ODROID N2_S922 4G - 1GB Ethernet, X92_S912_q201 3/32G - 1GB Ethernet Box_Android 7.1.2, Mocool KM8_S905X 2/16 0.1GB Ethernet Box_Android 8.0, X96Mini_S905W 2/16G 0.1GB Ethernet Box_Android 7.1.2

  • Set scanning library on start in Kodi settings and put

    cleanonupdate command in advancedsettings.

    This will clean your library on every boot. Works flawless every time.

    XML
    1. <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    2. <advancedsettings>
    3. <videolibrary>
    4. <cleanonupdate>true</cleanonupdate>
    5. </videolibrary>
    6. </advancedsettings>

    But my problem is that my TV boxes are on 24/7, I rarely reboot them...

  • wrxtasy , i don't understand why your autoswitch modification for HDR/10bits is not implemented in libreelec master branch.


    Is no possible to port to kodi leia 18? I'm want to test leia 18, but the lack of 10bits autoswitch support is a problema.


    Thanks.

  • wrxtasy The LibreELEC-S905.arm-8.2.4.2-S905Test-1529136339.img.gz (or .tar) do not light the LED on my MiniMX (S905) 2G/16G boxes. Is there a later one that does? The LED lights as the box boots up, but goes out once LE begins to boot

    Any fix for this yet?

  • Quote

    In the end, I never fully solved the problem, so I switched to CoreElec 8.90.4. Since then I don't have freezing problems. BUT I think that Libreelec 8.2.4.1 was actually a smoother user experience than Corelec, I mean navigating through menus, scrolling the GUI, etc was smoother in Libreelec (except for when it crashed of course!)





    For some reason the wave visualization causes freezes on both the Krypton and Leia builds on my Rasp Pi and my Vim2. In fact the default visualization seems be be the only one which dosn't cause freezes.


    Shoog

  • Could you please clarify your recommendation?

    I got also this error message:

    Code
    1. ERROR: LibreELEC-S905.arm-8.2.4.2-S905Test-1529136339.tar is not compatible with S905.arm hardware - update cancelled.
    2. Current system: S905.arm
    3. Update system: S912.arm

    The box is X96 (S905X). What do you mean on "bad version"? Shall I really try with the v8.2.4.2-Test2-wetekdvb build on this box?

    Hard to believe that nobody can tell me which image to be installed my S905X box.

    Now I downloaded the LibreELEC-S905.arm-8.2.4.2-S905Test-1529136339.img.gz file and it contains the LibreELEC-S912.arm-8.2.4.2-S905Test-1529136339.img.

  • Now I downloaded the LibreELEC-S905.arm-8.2.4.2-S905Test-1529136339.img.gz file and it contains the LibreELEC-S912.arm-8.2.4.2-S905Test-1529136339.img.

    Hmm Maybe that's why the LED doesn't work correctly on my S905 boxes :rolleyes:

  • Setting "DirtyRegions" in advancedsetting.xml to 0 makes sense only to avoid known "Subtitle Stutter" on S912 boxes.


    For help on seting Front Display ask in this thread.


    Okay good news is I have cured the freezing problem with 8.2.4.1 by changing device tree. Took some finding but the one I used in the end for my Tanix TX9 Pro S912 box was not as expected the new generic gxm_q201_3g_1gbit.dtb which would not even boot. However the gxm_q200_k3_pro.dtb one I used and bingo everything checks out with it. USB ports, WiFi, BT and Audio all good too. Do not know what the k3-Pro box is but it works with the TX9 Pro box so sounds like a copy of the Tanix maybe. The only other 1 GBit DTB that seems to be for 3G RAM too is the gxm_kvim2.dtb and although this booted okay and seemed to work I quickly found that the top USB port on the box was not working, did not check furhter for things like BT etc.


    So for those with the Tanix TX92 box I assume they must be using this same gxm_q200_k3_pro.dtb withthe 8.2.4.1 build as the specs for the TX92 are the same as for the TX9 Pro except the better ventilated less good looking case with a power button on top. So I see no point in paying what I see as a large 20 to 30% more for the TX92 than the I believe newer TX9 Pro ????


    All the 3G 1 Gbit Kszaq device trees for S912 either would not boot at all or would work with freezes though one was good except for no WiFi. But for the Kszaq 8.2.2.3 S912 build then I found a good working DTB in his device tree collection that did work very well with the TX9 Pro.


    Thanks for all the help guys. Yep I decide not to bother with the DirtyRegions settings as I don't get any subtitle stutters and anyway as you see above I have now fixed my freezes problem :-)) Hope the above will be of some help to others with these Tanix S912 boxes.

    Cheers
    RayW


    Tanix TX9 Pro 3/32GB S912

    Tanix TX7 2/32GB S905X

    Beelink MINI MXIII II 2/16GB S905X
    MXQ M12CX 1/8GB S905X
    MXQ M12 1/8GB S805
    Denon X500 AVR System

    LG 55SJ850T Super UHD TV

  • Shall I really try with the v8.2.4.2-Test2-wetekdvb build on this box?

    Yes. I did that on my ANTSIR (= Dolamee D6) box and even the VFD now works. Just make sure you use the right device tree afterwards (for me that meant using a tree that is originally meant for a 905W box ...).

    Cheers,


    chessplayer



    Formerly: Intel Atom, Dockstar/Pogoplug (headless PVR Server)

    Production: Wetek Play, RPi3, Cubietruck (headless PVR Server), Nvidia Shield client, XBOX ONE Tuner, Sundtek Media TV Sticks

    Experimental: Various AMLogic S905X (W) devices

  • Maybe is not the right topic but it is very active thanks to developer wrxtasy .

    In current libreelec 9 and OpenELEC 8.96 automatic switch to HDR 10bits is broken and wrxtasy is the only build that works pretty well. Man is there some workaround for nightly builds to get working hdr 10bit automatic? Is not possible use to custom kernel in libreelec 9?


    Thanks