[8.2.4.1] LibreELEC Kodi Krypton - S905 & S912 devices

  • Anyone knows how to check autostart.sh using SSH in this version?


    LibreELEC-S905.arm-8.2.4.2-Test2.wetekdvb.img.gz

    What did you mean by "check autostart.sh"?


    This is what I'll do:

    Code
    1. # Login to SSH
    2. cd /storage/.config
    3. nano autostart.sh

    Edit autostart.sh as below:

    Shell-Script
    1. #!/bin/bash
    2. (echo 1 > /sys/class/amhdmitx/amhdmitx0/output_rgb)&

    Save file by press: Ctrl-X -> Y -> Enter. Then make the file executable and reboot:

    Code
    1. chmod 755 ./autostart.sh
    2. reboot

    Enjoy /shrug

    X96 S905X 1G/8G WiFi 8189es 100M LAN - LE 8 @ 1.512GHz on SDCard.

    Edited 2 times, last by White ().

  • The same happend to me. The Test2 is the right one: LibreELEC-S905.arm-8.2.4.2-Test2.wetekdvb.img.gz

    Try it with its own dtb file. If it doesn't work change dtb file.


    p.s. I made a fresh install

    Thanks for the tip. I haven't had time to try this, but I will :-)

  • I ended up solving this. Discovered the issue was in fact audio related and not due to HVEC. I had incorrectly set audio decode to 5.1 rather than leaving it at its default of 2.0. In hindsight, I recall now seeing mention of leaving this setting at 2.0. I pass through virtually everything to the amp and so there was no reason for this to be changed. Brain fart!



  • Hi,


    I am using 8.2.4.2 and ever if a .sub file is within a movie folder, kodi freezes completely and take a soft reset. How can i avoid those crashes?!

    Based in GERMANY — working in cigar business — part time freelance webdesigner — PS4 Console Gamer and TV Show Junkie :cool:


    S912 with CE on NAND — S905x with CE on SD-Card (with EmulationStation&KODI shanti‘s build) - Odroid N2 with CE on emmc and EmuELEC on SD-Cad — 4K 65“ Sony — 4K Onkyo DD/DTSHD/ATMOS Receiver



  • I believe it's a bug in the 8.2.4.X version.


    It happens where you try to play a movie that is in a folder shared on the network by SMB (Samba).


    I've seen 3 possible solutions:

    1. (the easiest which is what I do) Use network sharing system NFS instead of SMB

    2. Something about storing the subtitle files in a special subtitle folder, separate from where the movie is located. You'll have to search the forums, I don't remember exactly how that works, but theres a libreelec setting about subtitle folders I think.

    3. Something about the "Version" of SMB. Apparently SMB has versions which is an advanced setting. I've also seen this somewhere in the folders but I'm not sure if it's an advanced setting of Libreelec, or where the movie is located (like a Windows setting, or a NAS setting)

  • wrxtasy: I still have video stuttering issue in your latest build for c2. I don't think you have time to solve this issue.

    Atleast can you suggest me a build of yours which doesn't have this problem ?

    This issue is seriously making me go crazy to the extent that why I invested in c2.

    I hope you understand my situation.

    Thanks in advance.

  • On a Minix U1 with IR remote if I press power button to shutdown the box it goes in suspendend mode. Does anyone know how to make the power button to shutdown it properly?

  • - Got LAN working btw, just that one time after boot I wouldn't find the adapter again, though a restart solved it.


    - Full 3D files would not be played in 3D, only HSBS/TAB (Like check quoted post - kodi samples - 3D MVC files 1 till 5). //EDIT: Ah, that's what you get comming from RPi, no HW support There are support 3D MVC ISO? | MINIX Forum - Official . So I guess I can use S912 for mostly everything and my RPi for 3D MVC or get an Intel Box Kodi Media Player Options with 3D MVC & HD Audio EDIT//


    - How to share using NFS? There is no etc/exports.


    - I'd like to go other round than omicron. In Android a short press on power button -> suspended, long press results in power menu. But here I would not have the option to suspend, only shutdown resp. menu with shutdown/restart/to internal ...

    Edited 2 times, last by rastobil ().

  • Now I see the problem with subtittles in folder, making LE restart. But I think it not the subs, but archived ones, I tried .rar and LE restart

    TX 3 Mini S905W, test1

  • I had a really strange problem the other night when I was watching a film on my X96 mini 2GB.

    I should note this is a different version of Libre to the one in the OP which I couldn't get to install, called 'LibreELEC-S905.arm-8.2.4.2-Test2-wetekdvb.img.gz' from here:

    https://drive.google.com/drive/folders/1p6wmq6o9ts08yow3dnmax6tytsp445pb


    About 20 minutes into the film, all of the speech suddenly cut out. It was the weirdest thing, I could hear all the ADR and sound effects and music perfectly, the character's lips moved but I couldn't hear them.

    The film in question was David Lynch's Lost Highway, so I assumed it was intentional at first, as it occurred moments after a shock and seemed to make sense in a Lynch-y way, until I reached a moment which I knew had audible dialogue and it still wasn't back.

    The film was encoded with 5.1 surround in HEVC, here's the mediainfo:


    Anyway long story short, it somehow fixed itself while I had it paused for a few minutes trying to work out what the problem was, maybe after I rolled it back 30 seconds the vocals returned, the previous 10 minutes played fine and I watched the rest of the film without a problem.

    Is this a known issue? Any ideas what could have happened and is it fixiable?


    Lost Highway btw if you haven't seen it is pretty special. I'd seen it years ago when I was young, but it made no sense at the time and I'd forgotten most of it since.

    Rewatching it was a massive treat. I think my technical issue added to the experience in a strange way.

    Really mysterious, head-f**k of a film. Loved it.

  • It's an infrequent and half-understood issue with the half-fixed audio subsystem in ye olde 3.14 kernel. It will not be fixed, because nobody with the competencies to perform major kernel development is prepared to work on that fugly codebase now. The 'fix' will come when we flush that turd kernel and move up to mainline, which is something being actively worked on.

  • I have been using wrxtasy builds since 8,2,4,1 but recently I've starting to follow balbes150 topic about new Kodi 18 builds.


    Are there any advantatge to jump balbes150 builds? I mean, HDR, 10bits, and all advantatges of wrxtasy builds are inlcuded?


    Thanks,

  • Hi wrxtasy ...using your fantastic builds on a wetek play 2 (s905) and a H96 Pro+ (s912) and both work great.

    Thinking about getting a S905x box...does your s905 build support this (with correct dtb.img!)?

  • Hi wrxtasy ...using your fantastic builds on a wetek play 2 (s905) and a H96 Pro+ (s912) and both work great.

    Thinking about getting a S905x box...does your s905 build support this (with correct dtb.img!)?

    Sorry, ignore post above...found it! Post #201....!!!

  • I have been using wrxtasy builds since 8,2,4,1 but recently I've starting to follow balbes150 topic about new Kodi 18 builds.


    Are there any advantatge to jump balbes150 builds? I mean, HDR, 10bits, and all advantatges of wrxtasy builds are inlcuded?


    Thanks,

    for me the advantage is to be able to read UHD iso files. I have a few problematic UHD discs that fail because of read errors when I try to create mkv files for them, but I can get unencrypted backups to files of them, that can be put into ISO files for playback. Hoping to be able to have access to those problematic discs with leia versions of libreElec since they use a version of libbluray that can read them. The wrxtasy builds are what I use for stable UHD/hrd/atmos/dts:x playback, but Oleg's images are showing promise. My limited testing (about to do much more) of them shows relatively stable mkv playback so far. If that holds & we get stable uhd ISO playback in my case it might justify migrating to them.

  • It's an infrequent and half-understood issue with the half-fixed audio subsystem in ye olde 3.14 kernel. It will not be fixed, because nobody with the competencies to perform major kernel development is prepared to work on that fugly codebase now. The 'fix' will come when we flush that turd kernel and move up to mainline, which is something being actively worked on.

    I know this is a difficult/impossible question to answer as a part-time developer myself, but do you have any ETA on when this new kernel will be released?