[] LibreELEC Kodi Krypton - S905 & S912 devices

  • I've started experiencing video playback issues with and on S912.

    I'll experience a couple of glitches.

    1. Audio sounds slight accelerated and stutters periodically.

    2. Above + at start screen remains blank and no audio plays. Otherwise video appears to be playing (timer counting up etc). Skipping forward fixes the blank screen issue.

    3. Regular audio glitches.

    In stopping and starting the video would rectify this. IN this no longer works. 1 and 2 seem to seem to only effect HVEC. 3 has also been seen in H264.

    All of this is new to 8.2.4* series. Was previously on 8.2.* without these issues.

    Logs recreating the issue @


    Have reset guisettings.xml as I was also experiencing periodic freezes but that has otherwise had no effect. Note: Box was upgraded from

    Anyone have any ideas? My thought is that it is related to my HDMI audio pass through (ive set HDMI audio out and channel number to 5.1 with everything toggled to pass through). Perhaps that is incorrect?



  • Hello wrxtasy

    first of all let me thank you for all your work, your builds are amazing!!!

    im a proud owner of a MECOOL M8S Pro+ TV running your LibreELEC-S905.arm- image.

    it puts my raspberry pi in a corner man, it is the best IPTV experience i had in a few years, its very very smooth!

    now i only have one problem. my NAS shares and Router Shares via SMB or via NFS are stuttering and buffering, i'm talking about 1080p REMUXES 20/30/35GB mvk files,kodi always gives me the bitrate too slow error (this doesn't happen on my raspberry pi) so its not a server or a connection problem (200Mbps/100Mbps). am i doing something wrong?

    edit: all my sutff is wired.

  • Hey, I did some Test with my box (hope I didn't overlook it) and I am wondering - is it that I did not move to internal Memory (https://forum.libreelec.tv/thread/9425-howto-boot-from-sd-card-use-internal-memory-for-data/?pageNo=5#post95212), does everyone get that or ....?

    Testfiles can be found at either:

    Samples - Official Kodi Wiki

    Evaluation of HEVC decoders (SW, Hybrid and HW) - Doom9's Forum


    4K | 4KSamples - Free Downloadable 4K Sample Content

    Xiph.org :: Derf's Test Media Collection


    3.Ducks-2160p @50fps-4Mbps.mkv


    OK, but small errors

    4K-Chimei-inn-60mbps (4ksamples).mp4 --- though some flimmering in very left side starting at 00:25

    Beauty_3840x2160_120fps_420_8bit_HEVC_MP4 --- Background flickering

    Sintel.2010.4k.mkv --- normally plays fine but when played after 10 Bit file - same half screen stuttering

    The World in HDR.mkv --- sometimes sames as Sintel - tough also on stop and restart ("always" from beginning "during tests")

    Buggy (10 bit videos):


    LG Demo DolbyVision Comparison.mkv



    So 10 Bit videos - if I shut down the system, give it some time, restart again the first file would play fine.

    In any other situation, it would cause ~ half of the horizontal screen to be ... idk seems like tearing. You can also see it on the timeframe - skipping back and forth.


    Btw. my LAN adapter would not show up in settings (It's an RTL8211F). Ah i guess that 1gb dtb is needed - now i need to know how to update that afterwards ...


    Sometimes when rewinding - after caching the picture won't come back (resp last decoded is shown).

    Edited 4 times, last by rastobil ().

  • Just picked up a Minix Neo U9-H and am wanting to install LibreElec on it (have ran LE on my RPi3 before). Wondering what the easiest way to install is, as I've read a ton of diff threads/ways and things are starting to meld together and I'm not sure which is the path forward (FYI, I've got 24 years of Linux experience, back all the way to the Slackware Days, so really am not a noob, just didn't' know if there was an image I can use in the SD Creator to speed things up or what).

  • Minix Neo U9-H

    Update, I attempted to use wrxtasy's Release LibreELEC - S912 release · wrxtasy/LibreELEC.tv · GitHub build. Downloaded the img.gz and wrote it to file with the LE USB/SD Creator, and when I boot off of it, I am getting the following error:

    **** Error in mount_flush: mount_common: Could not mount LABEL:LIBREELEC **

    I've read some things about using a modified dtm file, but not sure if that is correct and/or will solve my issue. Anyone ran into this?

  • Update, I think I solved the problem. I utilized the dtm.img from here: dtb.img, replacing the dtm.img on my micro sd card, with it, once the LE USB/SD Creator created the LE micro sd.

  • Hi,

    I''ve installed a different image fix lost audio v2 (search this thread) without any problems on a U9H, use the correct dtb.img for this release it is provided in the download link for that version. I used rufus 3.0 to write the image to SD card.

    You may also look at this thread [HOWTO] Boot from SD card, use internal memory for data

    This makes kodi run much faster because the internal data partition is used for data

  • Hi wrxtasy,

    I installed your build on my x96 with S905X. The system works very well, but only the remote control doesn't working.

    I have followed this link Infrared Remotes [LibreELEC.wiki] to setup, but I getting `/sys/class/rc/: No such file or directory` and no idea how to load the driver.

    Do you have any clue for me?

  • copy remote.conf file from andriod and paste root directory of sd card.

    Hi, are you mean the remote.conf from the original android it comes with?

    May I know where can I get the file? Because I tried adb into the android, but can't find the file yet.

  • I finally got the libreelec to work.

    thanks dronkeol to the correct file you gave me.

    someone guide me how to start libreelec without having to press the reset button?


  • I have a Mecool M8S Pro l and have been running kszaq [] LibreELEC 8.2 for S912 on my box. However now that he has retired.

    I would like to keep kodi 17.6 current until Kodi 18 drops and I was wondering can I just drop wrxtasy newer updates tar file onto the sd card to update or do I need to do a fresh format and install from scratch?

    Thanks for the help.

  • I have installed LibreELEC-S905.arm- on a Minix U1 connected to a 2009 Sony Tv needing ForceRGB setting and it worked.

    I set on the ForceRGB option in Amlogic menu and reboot but unfortunately the pink screen issue shows the same. Even on the original Android firmware there's a force rgb option that doesn't work as well.

    Before this Minix I had a S905W box that had force rgb on Android and it worked: the option was named "RGB 8 bit" and I saw it on other S905W boxes.

    Does S905X have the same output or is it different - I mean it could have an RGB 16 or 32 bit output as I saw mentioned in MX Player interface?

    How can I check if the Force RGB option on Libreelec changed something in the configuration files?

    p.s. Thank you wrxtasy for the release

    Edited 2 times, last by omicron ().

  • Attempted to install LibreELEC-S905.arm- by placing the file in the update folder on my S905 MiniMX iii, but received an error at boot saying that it was actually for a S912.

  • Attempted to install LibreELEC-S905.arm- by placing the file in the update folder on my S905 MiniMX iii, but received an error at boot saying that it was actually for a S912.

    The same happend to me. The Test2 is the right one: LibreELEC-S905.arm-

    Try it with its own dtb file. If it doesn't work change dtb file.

    p.s. I made a fresh install

  • Anyone knows how to check autostart.sh using SSH in this version?