[SOLVED] - LibreELEC on Minix NEO U9-H (could not mount LABEL=LIBREELEC_DISK)

  • WRXTASY EDIT:


    Marked as Solved see Post:


    [S912] LibreELEC on Minix NEO U9-H (could not mount LABEL=LIBREELEC_DISK)




    Hi,


    I have been using LE on Minix NEO U1 [S905] for a long time. Everything works great.

    Now I bought Minix NEO U9-H [S912] and I have a problem installing LE on SD card.


    I found a description of the problem at the Minix Forum. I have the same problem.


    dortmunder wrote:

    Quote


    Minix Forum


    I tried 3 different SD cards:

    32GB Samsung EVO plus

    32GB ADATA

    8GB Kingston


    Same error for all. :(


    Could you help me(us)?


    Thx ;)

    • Official Post

    Assuming "error in mount_flash: mount_common: could not mount LABEL-LIBREELEC" is a typo and LABEL=LIBREELEC is correct the issue is quite simple; you are trying to mount using disk (partition) labels and there is no partition with the label LIBREELEC. This is probably the boot partition, which is rather fundamental.

  • I will write what I have already tried:


    LE release:

    LibreELEC-S912.arm-8.2-8.1.10.img.gz

    LibreELEC-S912.arm-8.2-8.1.9.img.gz

    LibreELEC-S912.arm-8.2-8.1.7.img.gz

    LibreELEC-S912.arm-8.2-8.1.6.img.gz


    Device tree:

    gxm_q200_2g.dtb

    gxm_q200_2g_minix_neo_u9.dtb (wrxtasy) gxm_q200_2g_minix_neo_u9.dtb


    Minix Firmware:

    NEO U9-H FW007A (20171020)

    NEO U9-H FW006 (20170810)


    Result?

    The same error as I already wrote, or the LE logo will appear and then black screen will remain.


    I'm afraid this will not be a only Samsung EVO plus microSD problem, as it is written in the main thread [8.1.10] LibreELEC 8.2 for S912

    • Official Post

    You should be able to connect a USB keyboard and mount the boot partition to correct the boot command. The initramfs boot environment that you drop into when that error shows has "vi" as a text editor.

  • It looks like the problem will be associated with the internal card reader of Minix NEO U9-H.


    When I used a USB card reader, it worked as it should.


    Each microSD card or flash drive worked with LibreELEC-S912.arm-8.2-8.1.10.img.gz and gxm_q200_2g.dtb without any problem.


    When I tried to use gxm_q200_2g_minix_neo_u9.dtb from wrxtasy initialization process ended with black screen each time.


    Do you have an idea what could be done? In order for LE to work in the internal reader? Need to adjust device tree or something else?


    chewitt

    I got into the command line, but I did not find any information to verify or modify.


    Obviously, I'm not alone, who has the problem to run LE on Minix U9-H in an internal reader.


    I'll try anything you want, check what you want if it helps me and others to run LE on Minix U9-H.


    I would be happy if experts ( kszaq, wrxtasy, ... ) looked at this post and tried to help us.


    Thanks a lot.

  • Each microSD card or flash drive worked with LibreELEC-S912.arm-8.2-8.1.10.img.gz and gxm_q200_2g.dtb without any problem.

    Why don't you use it if it works? I cannot support device trees provided by other users, especially when they come without a source code. My device tree repo is open for PRs if anyone wants to contribute.

  • hi all


    Same problem for me

    unable to make it work with micro SD.

    I use lexar microSDHC 300x.

    Work fine on usb


    So I made more test.


    On micro SD

    with LibreELEC-S912.arm-8.2-8.2.0.1.img.gz and gxm_q200_2g.dtb I get this error message

    Error in mount_flash: mount_common: Could not LABEL=LIBREELEC


    with LibreELEC-S912.arm-8.2-8.2.0.1.img.gz and wrxtasy gxm_q200_2g_minix_neo_u9.dtb I get the LibreELEC logo and the img check with the 15s waiting time to reboot. After reboot LibreELEC logo and black screen.


    I try with other version of libreELEC but same result.


    On Usb Stick

    with LibreELEC-S912.arm-8.2-8.2.0.1.img.gz and gxm_q200_2g.dtb it works fine, it's just really slow due to my usb stick.


    Thanks in advance for any suggestion about this problem.

    Minix Neo U9-H

    Edited once, last by InNursery: more test ().

  • I have tried everything that InNursery has done too and I am having the exact same problems.


    Should I just install LibreElec to internal memory or will that have the same problems too?

  • Hi, I recently bought a minix U9 and ran into the exact same problem.


    I can confirm the results of InNursery. The only I way I got libreElec to boot is using my patriot USB stick. Neither the SanDisk Extreme 32GB nor the Transcend 8GB SDHC card worked.


    Is there a chance that the issue will be resolved ?

  • Please provide a device tree from Minix Android firmware, I will try to prepare some test device trees for you.

  • tell me how to get it

    You can extract from android firmware file or copy from the runnig android.

    RPI3 1GB, Z4 RK3368 1GB, MINI MX-G 2GB, Mini M8S II (coreelec.org 9.2.1), H96 Pro (coreelec.org 9.2.1), ODORID N2 (coreelec.org 9.2.1), VIM3 PRO (coreelec.org 9.2.1), Beelink GT King (coreelec.org 9.2.1), Denon AVR-X2600H, LG 60SJ810V
    pel.hu