feedback for test build LibreELEC-RK3328

  • It seems a network driver problem. I bought an usb3 gigabit adapter and now, the write speed is around 80Mb/s and the read speed 35Mb/s. Stable without broken file transfers. :)

  • The guys with the buffer problems, could you describe how to reproduce it? Trying to reproduce. 7h pvr playback an no buffering yet.

  • The guys with the buffer problems, could you describe how to reproduce it? Trying to reproduce. 7h pvr playback an no buffering yet.

    I think this patch will solve the Samba problem

    kodi/amlogic: reduce samba chunk size to 32k to improve playback · CoreELEC/[email protected] · GitHub or 1 line difference, same patch

    kodi: smb chunksize 1 -> 32k for smooth bluray iso playback by sky42src · Pull Request #2980 · LibreELEC/LibreELEC.tv · GitHub

  • The guys with the buffer problems, could you describe how to reproduce it? Trying to reproduce. 7h pvr playback an no buffering yet.

    in general buffering only happens sometimes at my mvr9 when watching tv streams from my tvheadend server, but i cant really say it is always on the same type of channel (interlaced 50hz material like sports/soccer and so on)....maybe it has something in common with the LAN problem ? transfer on LAN could be interrupted ... buffering appears ?


    Sorry,would like to help more...is there a scenario i should test ? give me a hint and i will do...


    p.s.

    interlaced sports channels 1080i are seemes to be stuttering for a few ms sometimes too. on other material this does not happen....or it is even not visible...

  • News about my discovering of ROC-RK3328-CC, and running LibreELEC on it

    1) I have to say sorry for missinformation here

    - on ROC-RK3328-CC I'am able to run all latest build's from Index of / or, http://cvh.libreelec.tv/test/rk3328/

    - after first tries I was confused with LED flashing/color combination's (there are differeneces: eMMC vs. SD card vs. different distribution - Android/Linux, and at first I'am wasn't allways connected to HDMI output to check whole boot process. With combination of first reboot of LibreELEC I got little bit confused...)

    2) Issues with my WiFi dongle are only on Android build's for my SbC

    - any Android are unable to use my WiFi dongle by default

    - this problem is not related to LibreELEC at all

    - it's about support of RTL8192EU WiFi on Android, on LibreELEC build's my Wi-Fi dongle just work fine

    3) my PVR add-on problem on Firefly LibreELEC build

    - I can confirm, that this problem was about obsolote Kodi build in Firefly LibreELEC img, in nightly builds, I'am able to install this addon without problem


    Things need to be improved for ROC-RK3328-CC for my daily use

    1) problem with playback h.265 videos

    - there is few mentions about issue, when the picture freeze after start of playing, or after switching video(or PVR channel). I can confirm this behaviour also on on ROC-RK3328-CC (tested on CvH's LibreELEC-RK3328.arm-9.0-devel-20180919223845-3e985ea-roc-cc.img.gz) // audio play normally after switch/start, but picture just freeze in some scene, or it's just black. Sometimes start playing or switching channel just go well...

    - PVR addon only give URL with stream to Kodi // then I suppose, that the main problem is in h.265 playback

    2) board freeze after going to list of TV channels on PVR addon (switch to black screen and no LED flashing - only hard reset is working in this case) // I'am able to switch to specific channel by Kore/Yatse (remote control app's)

    - I use one of official PVR addon for Kodi 18 // pvr.sledovanitv.cz (officaly supported PVR addon from Kodi 18 Alpha 3)

    - This can also be problem of addon itself, or problem with nightly build of Kodi (on other HW/kodi builds this addon just work well)

    3) problem with correct aspect ratio for vidoes

    - my PVR addon has options to use h.264 or h.265 // in h.264 are aspect ratios OK, after switch to h.265 ratios are not OK

    - in h.265 my 4:3 videos are stretch to 16:9 aspect ratio :/ but after switchint to h.264 aspect ratio is OK



    Can I help in any way, to solve these issues(or other issues) for ROC-RK3328-CC?

    1) What test scenarios and logs/outputs I'am able to provide to community to solve these problems?

    - I'am able to provide you logs, and other needed things to debug this - I'am only need to known what exactly

    2) I'am able to compile add-on or LibreELEC itself

    - So I hope, that I can help also with some non-standart test/debug for ROC-RK3328-CC



    Thank You in advance!!

  • Im planning to try again libreelec on my rock64 but im wondering, a loooooong time ago images included some sort of flash memory protection, cant remember if it was an addon, plugin, integrated, any, but i wonder if its still included on newer builds as i plan to install it on a microsd (basically the addon/plugin watever moved the log writing and other temporal writing tasks into memory if i recall correctly), i did some google searching but cant find if its still included in the latests alphas...

  • Im planning to try again libreelec on my rock64 but im wondering, a loooooong time ago images included some sort of flash memory protection, cant remember if it was an addon, plugin, integrated, any, but i wonder if its still included on newer builds as i plan to install it on a microsd (basically the addon/plugin watever moved the log writing and other temporal writing tasks into memory if i recall correctly), i did some google searching but cant find if its still included in the latests alphas...

    Utilize folder2ram - Raspberry Pi - OSMC Forums

    Im doing deeper googling and im seeing that its probably not needed anymore and thats why i dont hear about it since so long, im going to do my testing in a few days anyway but it would be nice to hear something about this from some of the gurus anyway, thanks all for reading... :D

  • CvH  

    Feedback for LibreELEC-RK3328.arm-8.90.006-rock64.


    Thank you for your ongoing work!

    I would like to provide feedback on the latest alpha.


    Observed behavior:

    A video is left paused, and the TV is left turned on.

    Screen eventually goes to black except for the time indicator in the top right hand corner.

    Moving the mouse causes the video image to reappear as expected, however upon attempting to resume the video or stop it all video output from the system stops. A power cycle is required to bring the system back online.


    Expected behavior.

    The TV should be turned off by CEC when left paused for an extended period.

    The video should be blank, and not show a paused time indicator to prevent screen burn if the TV is not turned off by CEC.

    Un-pausing the video should not result in a non-responsive system.


    I will try to provide pics or anything else you might like. Just let me know.

    -Written by a team of angry monkeys.

    Edited once, last by wizardknight ().

  • Hi,


    I test image LibreELEC-RK3399.arm-8.90.006-rockpro64.img, the main problems I have are :



    1) I am unable to play 4K video in 4K, it play in 1080P. I use the exact same hdmi cable that my Minix U9-H and with this one I am able to play 4K HDR without any problem.



    2) It's an alpha version so, I don't really care but a lot of 4K HDR (playing in 1080p on my systme) are not playable.



    3) Something you already know, Audio Passthrough is not working.


    I do not think it's significant to provide log in my case but, if that can help I can provide it.


    A+

    Libreelec : Odroid C1+ ; Odroid C2 ; Raspberry Pi 1, 2, 3 ; M8S-S812 ; A95X-S905X ; GT1-S912

    Divers : Xiaomi mi box ; Rock 64 ; RockPro64 ; Minix U9-H (x2); Orange pi pc ; Orange pi pc+ ; Orange pi one

  • I am unable to play 4K video in 4K, it play in 1080P.

    You know about whitelisting resolutions ??

    Is it possible you haven't whitelisted 4k ??

  • 1) I am unable to play 4K video in 4K, it play in 1080P. I use the exact same hdmi cable that my Minix U9-H and with this one I am able to play 4K HDR without any problem.

    I am aware of this issue on the RockPro64 and it is caused by Display Port support being enabled in the device tree for RockPro64 very late in the release cycle.

    Working on an update that should allow 2K resolutions on DP and 4K on HDMI along with adding DP support to the other RK3399 boards.


    A video is left paused, and the TV is left turned on.

    I have been able to reproduce this issue, I am not sure I will be able to fix resume in all cases and will focus on a fix that stops the video playback when the mpp library is reporting too many consecutive error frames.

  • Kwiboo , Thank you very much. It would be a pleasure t test the update.


    Nunu81 , On my side when I enable passthrough I hear white noise.

    Libreelec : Odroid C1+ ; Odroid C2 ; Raspberry Pi 1, 2, 3 ; M8S-S812 ; A95X-S905X ; GT1-S912

    Divers : Xiaomi mi box ; Rock 64 ; RockPro64 ; Minix U9-H (x2); Orange pi pc ; Orange pi pc+ ; Orange pi one

  • I started this thread thinking that i was having samba speed problems but now im starting to think that maybe there is some problem with the network driver on the rock64? i came to this conclusion after testing it with the proftpd addon, i get 30MB/s LE->W10 and about 45MB/s W10->LE, also i tried with SFTP and i get 30-30, its not bad and im going to keep using it as is but its not good either, the same hardware setup can give me 70-80MB/s with OMV, same cables, same router, same hdd...


    Can there be something related to the ethernet driver used by libreelec that limit the upload? its the same driver/options that the omv people use?


    Some stuff i tried:

    - stopping docker since it create a virtual lan interface, same results

    - forcing min/max to smb2 and min/max smb3 on libreelec, no changes

    - Completelly disabling smb1 on W10, no dice

    - Disabled LSO on W10, no luck

    - did most of these tests watching closelly htop and the worst offender was sftp with about 40-50% cpu use, still had room to work


    Again, its not a problem since it works and at a good enough speed for media (even up to 4k) but slower than it should be


    Any tip/help is GREATLY apreciated :D


    PS: i did an iperf in both directions, and now im totally lost about what happens here:

    One direction and the other, so i dont know what else to test, lan gives me 80/90, hdparm gives me 100+ but soft is slow...again any idea/tip is totally appreciated :D


    PS2: im trying crazy stuff and tried renice-ing smb and made allmost no difference

    Edited 3 times, last by TrashCanMan: Added iperf data ().