[8.90.6] LibreELEC 9.0 Alpha for S905/S912 devices

  • GDPR-2, I did clean installation of 8.90.4 , after this updated to new devel + new dtb. With crazycat scannng muxes does not work on tvh with hauppauge driver everything is ok

  • GDPR-2, I did clean installation of 8.90.4 , after this updated to new devel + new dtb. With crazycat scannng muxes does not work on tvh with hauppauge driver everything is ok

    so with Hauppauge everything works as expected?


    Did it work with crazycat before?


    It's very hard for both myself and afl1 to fully work this out as we don't have access to the hardware however I appreciate you taking the time to test the changes. New codesnake changes are causing a headache.

  • With Your older builds I was using only crazycat drivers and everyrhing was ok. In new devel wp2 driver/ wifi works but something is wrong with scanning muxes in tvh when we have enabled crazycat (hauppauge is ok)

    GDPR-2, is possible to map all buttons from wp2 remote in keymap editor app? On older builds I was using remote.conf file and thanks to this I could customize all buttons from my wp2 remote. Now for some buttons it is impossible

    Edited once, last by zbigzbig20 ().

  • kjack9

    I'm using passthrough. The word "non-passthrough" doesn't make sense for me.

    If I play an 5.1, 192kHz/24 bit flac file then my receiver shows Multi channel PCM, 192 kHz, 5.1.

    If I play a movie with an 5.1, 48kHz aac audio then my receiver shows Multi channel PCM, 48 kHz, 5.1.

    The sample rate is correct every time with every value.

    By 'non-passthrough' I mean audio streams that can't be bitstreamed to the receiver. So FLAC, AAC, MP3, etc.


    "If I play a movie with an 5.1, 48kHz aac audio then my receiver shows Multi channel PCM, 48 kHz, 5.1."


    This tells me that the issue is specific to me, and other people aren't experiencing it. I'm starting to suspect that I have a bad MINIX U9-H unit. I've ordered a replacement on Amazon to see if a hardware change makes the difference.

  • I just flashed the latest devel with the new DTB. My K1 Plus boots but internal dvb is not detected.


    Restarting the box seems to kill video output but the box does not reboot.


    Is there a chance to make the internal dvb work with the latest devel?

  • This tells me that the issue is specific to me, and other people aren't experiencing it. I'm starting to suspect that I have a bad MINIX U9-H unit. I've ordered a replacement on Amazon to see if a hardware change makes the difference.

    I've read something here that Minix boxes have different audio then the normal S9XX boxes so they need special dtb...

    RPI3 1GB, Z4 RK3368 1GB, MINI MX-G 2GB, Mini M8S II (coreelec.org 9.2.1), H96 Pro (coreelec.org 9.2.1), ODORID N2 (coreelec.org 9.2.1), VIM3 PRO (coreelec.org 9.2.1), Beelink GT King (coreelec.org 9.2.1), Denon AVR-X2600H, LG 60SJ810V
    pel.hu

  • I've read something here that Minix boxes have different audio then the normal S9XX boxes so they need special dtb...

    I'm using 'gxm_q200_2g_minix_neo_u9.dtb'. Is that what you're using?

  • [...]new devel version for you to try here.[...]

    Not that I expected something different, but the network-crash-on-large-file-writes-bug is in this version also. And I just realized I can't ignore the bug by just not writing large files: It occurs even when I do a longer recording from the DVB-T2 card attached to USB... Any chance that the problem will be addressed? While I understand that the patches I quoted are for mainline kernel and thus not directly applicable, they look rather "portable" to me, but of course I've close to no idea about kernel develeopment...

    Btw.: I tried kszaq 's latest Le Potato version I could find (LibreELEC-S905.arm-8.2-8.2.3.1-LePotato), and it still suffers from the problem.

  • I'm assuming that Retroplayer doesn't work yet, i've been trying to get it to work for a while. Retroarch and Emulationstation just restarts Kodi.

    Edited once, last by GDPR-4 ().

  • Hello guys, I have upgraded 8.90.4 to my evolveo h4 (s905x) from version 8.2.0.1. Befor on vers. 8.2.0.1 have i installed Remote Conf to configfiles, rebooted, and remote. Ha worked. Now, the remote after the upgrade does not work and has a dropped button. I tried again to insert the remote.conf file into config. Files, but without result. Please advice :(:(:(

  • The Coolest

    I have already done this and tried many versions of the config file, but after restart the buttons are still as badly configured as if the new config did not read, I have a config file that worked on the old version but here it is still wrong

  • Skaral

    Old versions used a completely different way of interfacing with the remote.

    You have to follow the exact steps in the first post, it works, across reboots. There are no 'conf' files.

  • Just tried the latest devel version on a new sd card. for playback its ok


    using the default-skin, the gui "reboot from internal" doesn't do anything when clicked, not sure if this is expected but when I click "reboot from internal" then "reboot" it boots to internal nand.

  • While I understand that the patches I quoted are for mainline kernel and thus not directly applicable, they look rather "portable" to me, but of course I've close to no idea about kernel develeopment...

    There is little value in advising the devs of the 'portability' of some code and immediately stating that you've no idea if what you're saying is valid. They are more than capable of deciding if mainstream patches can be adapted to these builds and, thankfully, do have (at the very least) some idea about kernel development :)

    Edited once, last by Poida ().

  • Gave the devel a test on my KI pro. Playing 4K CPU ~100% stuttering playback and almost none responsive to remote or ssh. TVHeadEnd reports no Adapters.:)


    ps. 8.90.4 works perfect;)

    2re Did you find a solution for the no adapters?

  • belaid38 , thank You. Now it works good. So just something wrong is with crazycat driver :)

    before experiment one question.

    i have to download 1st 8.90.4 image on sd card

    then dtb.img file for wp2

    then what to do with devil tar file?

    i should upgrade from le menu?

    where should i put tar file?

    and zbigbig20 can u upload ur remote config file here plz