[8.90.6] LibreELEC 9.0 Alpha for S905/S912 devices

  • @adamg


    I guess you have a point. Many prefer to just ask instead of take a few minutes to do a search. Some don't know any better.


    Yeah I've seen your posts about that (and the patch), I think it's great, it'll make life much easier to whoever wants to use those options.

  • Well future posts will be unlikely to get a response as my patience for it has bottomed out, I have so many ideas I would love to implement and not enough time, I need better hardware to speed things up and more hours in the day.

    I will be asking a mod to lock this thread soon so we can start a fresh as many helpful posts are hidden away because of the spam.

  • Don't forget xxx,12bit;)

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • GDPR-2 Just FYI, when I try to compile from source, on a clean dir using this command:


    PROJECT=Amlogic ARCH=arm DEVICE=S905 make image -j8


    I get this error:


    Not sure if its on my end or a bug.

  • It makes no difference if I put it in bold or even in font size 36, there are still people who will still disregard it or not bother to read whatever I put.

    I feel for you mate. Newbies that don't know what SSH is, trying an Alpha Build is plain stupid time wasting. I refrain from really answering what is in my head when new members can't be bothered searching keywords in Libreelec to find an answer.

    It's Just LAZY

    I've been called rude and other things before, after telling members to read a bit before asking for a HOLD MY HAND and teach me HOW.

  • Long time reader, first time poster here :) (issues i've had in the past where resolved by searching in the forum ;) ...).


    I've used LE for quite some time now and first of all i would like to thank the whole team and GDPR-2 specifically for building and supporting Leia for S912. Excellent work! Thank you! :thumbup:


    I'm using the u9 and a Samsung ue75mu8000. Everything movie/video related seems to be working great (FHD/UHD in mkv/bluray iso, HDR10, resolution/frame rate switching, color space, etc. etc.), except for one thing:

    Does the S912 still have issues with stuttering when subtitles are displayed and H/W decoding is enabled? S905X has the behaviour the first time a subtitle appears on the screen while watching a video, the subsequent subtitles do not cause it.


    I think i have this issue too on the Minix u9. It's very subtle (microstutter only visible in some scenes) and i think most people don't notice it. However, i do now and cannot unsee it ;)


    There are some topics i found regarding this:

    Dropped frames caused by subtitle rendering

    [BUG] Frame skips caused by forced subtitles


    As far as i can see there is no immediate solution in sight. Is someone even working on this?


    The issue can be resolved by disabling the subtitles. As far is i know there are no dropped frames according to the log (see the attached threads).

    Reproduction: In the 4K UHD/HDR version of Terminator 2 at 1h30m (chapter 9 of 12) the microstutter occurs. You can see it in the lines on the road and in the stop sign passing by.

  • The issue can be resolved by disabling the subtitles.

    It's resolved if you disable H/W decoding, but with UHD sources, that is a no-no I think. From what I've understood, this is more likely a problem with the S912 drivers themselves and there's not that much that the Kodi devs can do about it.


    On my S912 box, the video would jerk slightly every time a subtitle appeared on the screen so it was very noticable. I didn't test any BD sources, I did my tests with a Matroska file with srt subs embedded in it.

  • What this forum needs is a proper FAQ thread or Wiki page

    I agree 100%.


    The more I read the "Pick the right Kodi box" thread at the Kodi forums, the more confused I get :) The information is scattered all over the thread.. and some bad advice like recommending the S912 boxes while they still have issues with subtitles causing jerky video.


    Just some simple things like two cases of settings:


    1) I have a Sxxxx box and a 4K TV that supports HDR, what settings are recommended if I playback both HDR and SDR video?

    2) I have a Sxxxx box and a FullHD TV that does not support HDR, what settings are recommended if I playback both HDR and SDR video? Are there any special cases in which I should change the settings?


    Then the Netflix etc. things, how to set things up in a step-by-step manner.


    For example, I personally cannot answer those top two questions and I'm tech savvy :)

  • Well question 1. is simple. 444,10bit, Activate "Adjust display refresh rate" Set GUI resolution to 1080 or 2160 (depends on your TV profiles capabilities) AND THE MOST IMPORTANT THING OF ALL, CALIBRATE YOUR TV!!!

    ;)

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • I have new installed my libreelec on Egolggo S95X Pro and now my Original Remote and OneForAll 7980 with MCE Code running automatic! Thank you GDPR-2 !!!

    I use this file: gxl_p212_2g_kvim.dtb


    But my new Problem is, i have no audio sound now.
    I use Audio Passthrough with an Yamaha AVR 381.


    Is the dtb File wrong for me?