[8.90.6] LibreELEC 9.0 Alpha for S905/S912 devices

  • No you have completely misread what I said, problem is nothing to do with LibreELEC, it's a combination of a poor kernel and hardware, playing over NFS reduces a lot of CPU overhead which in-turn = better playback.

    I guess that's a perfect workaround then. Nas through NFS plays smoothly no buffering. Btw any plans to incorporate .iso uhd playback?

  • wapvi

    Here are the filesystem benchmarks executed on the "SAME" harddisk


    EXFAT: Timing buffered disk reads: 94 MB in 3.00 seconds = 31.30 MB/sec
    EXT4: Timing buffered disk reads: 94 MB in 3.01 seconds = 31.23 MB/sec
    NTFS: Timing buffered disk reads: 96 MB in 3.05 seconds = 31.49 MB/sec

    You must compare filesystem benchmarks executed on the same harddisk.

  • Both of these have been covered before, we really should make an FAQ for these kinds of questions.

    AFS/Samba don't work well on these boxes, transfer via NFS if you can and don't use wireless.

    LibreELEC is not the reason or cause for slow transfers, it's a combination of a poor kernel and slow hardware, when transferring over USB the kernel stack has to handle not just the usb stack but also the ext4fs which adds an overhead to the CPU which impacts performance in Kodi which is why you see the slow down and stutter, the file system format becomes irrelevant when transferring over NFS the overheads are then handled on the remote side.


    Thanks for your replies. I am transferring to the internal eMMC. I don't use USB at all. Should I still be experiencing this? Small files work perfectly. Big files don't. The transfer always stop after a certain period of time.

    I tried searching for Libreelec NFS server and kodi NFS server, but couldn't find anything except for a ubuntu NFS server guide... can you help me out? Every other guide is about NFS sharing from OS X. I just want to copy a file to the internal memory. Hope it is possible in some way without read/write error. Thanks!

  • Your testing is for raw disk read independent on file system.

  • Your testing is for raw disk read independent on file system.

    Aha, thanks
    btw afl1 , in htop I saw that mount.ntfs has high cpu usage(as I expected).
    Changed the file system to exfat(sometimes I need to use it in windows as well). CPU usage is fine now.
    But I saw lircd using a lot of CPU as well. What is that for? Can we disable it?


  • GDPR-2 I have only one repo and it's working.


    I have two microsd cards, one has @kszaq's LE 8.2 and other one has your LE 9.0.


    I test your builds by cloning LE 8.2 and installing updates.


    But last time I installed 8.90.1 on to your previous build.


    Cloned @kszaq's LE 8.2 and updated to 8.90.1 again. It's fine now.

  • Hi, im using last build but still have trouble with inputstream.rtmp , when i start i get a error no compatible version of rtmp. I tryed tu go to addons and go to update, works , but i reboot and i get same trouble. Is the correct way for update addons? thx!

  • I'm getting very choppy playback on my s905X Q-box.

    LibreElec has run from an SD card, and the files are being played back over wired LAN (source is on a NAS)


    The files are :

    Format profile : [email protected]

    Format settings : CABAC / 4 Ref Frames

    Bit rate mode : VBR

    Bit rate mode : Variable

    Bit rate : 9494159

    Bit rate : 9 494 Kbps

    Maximum bit rate : 15000000

    Maximum bit rate : 15.0 Mbps


    Format profile : [email protected]

    Format settings : CABAC / 4 Ref Frames

    Bit rate : 13062235

    Bit rate : 13.1 Mbps


    or


    Format profile : [email protected]

    Format settings : CABAC / 3 Ref Frames

    Bit rate mode : VBR

    Bit rate mode : Variable

    Bit rate : 4020000

    Bit rate : 4 020 Kbps

    Maximum bit rate : 6029952

    Maximum bit rate : 6 030 Kbps


    Should these all play without issue?

  • Hi, im using last build but still have trouble with inputstream.rtmp , when i start i get a error no compatible version of rtmp. I tryed tu go to addons and go to update, works , but i reboot and i get same trouble. Is the correct way for update addons? thx!

    This is a difficult issue to explain but we have resolved it for future.

    Because of the nature of these community releases and both myself and afl1 wanting to give you the latest version of Kodi and the related binary-addons...

    There have been issues with some addons, even though there was newer versions of them when we came to making new releases, the version numbers of the addons where not being increased by their respective developers.

    This was causing incompatibilities as Kodi will not download the updated addons if the version numbers have not increased.

    We solved this by increasing the very last number of the version string if there is any kind of update for the addons, HOWEVER this change has not come into effect yet because we have not bumped the binary addons since making this change.

    Issues like this should disappear in the future as we start updating the addons, you can clean your packages folder and force a reinstall of the addon via the addon system and then it should update and the issue should resolve itself.


  • I know it is a pain but starting from scratch is the best policy imo, upgrading between major Kodi releases will almost certainly produce issues.

    Releases should start becoming more stable since 8.90.1 as a lot of the code has moved upstream to the main LE repository, all future releases will be mostly based on the official LE repo and as closely aligned to it as possible.

  • Hey buddy, great work - especially for a newbie like me.


    I was using kzaq’s build on my S912 setup. I used PlexKodiConnect for as i use Plex.


    Worked great with this build. And overall has worked great with v18 on my other machines.


    Unfortunately, when trying to use it on your build i get an error:


    “Library Sync Thread Has Crashed. Please report and reboot” (last part is paraphrasing).


    Other than going back to ksaq’s discontinued build I’m not sure what to do. The PKC dev will likely tell me its an issue with the build and ask you.


    Any ideas? Can I provide you anything (a log?) to help?


    Thanks!

  • Sorry, old post - this is specific to v18. I’ve tried it on a number of platforms. Plex doesn’t work on Leia yet.


  • The add-on may not work in Kodi Leia yet, if you have a PC try Kodi nightly on that if it works then provide a log and I will be happy to look at it.