[8.90.6] LibreELEC 9.0 Alpha for S905/S912 devices

  • I can't find this setting in your build.
    My parents can't use Kodi, so starting Live TV on startup is a must for them :)

    Edit: I'm using version 1.0.5


    Also my Kii Pro (S905) doesn't power off. When I press power button, it stucks at a blank screen. I have to cut the power to restart it again.

    I know this is at very alpha stage, I'm just posting my feedbacks.

  • There was some changes to game packages in the last release, I will look into this.

    I am not talking about included libretro, this is a way to run optimised lakka retroarch alongside kodI basically


    kodi emulators, at least in the case of pcsx rearmed, are unusable...probably has something to do with why lakka s905 pcsx rearmed os over 1mb when kodi uses generic one that is around 500kb

    Edited once, last by grimyhr ().

  • I can't find this setting in your build.
    My parents can't use Kodi, so starting Live TV on startup is a must for them :)

    Edit: I'm using version 1.0.5


    Also my Kii Pro (S905) doesn't power off. When I press power button, it stucks at a blank screen. I have to cut the power to restart it again.

    I know this is at very alpha stage, I'm just posting my feedbacks.

    This option was moved to Settings->Interface->Startup.


  • just getting black screen when trying to play local 720p and 1080p videos in 1.0.6


    Specifically punisher in mkv, had to go back to 1.0.5, will test further tommorow and see if it works in Netflix... after I watch all 13 episodes first.

  • I am not talking about included libretro, this is a way to run optimised lakka retroarch alongside kodI basically


    kodi emulators, at least in the case of pcsx rearmed, are unusable...probably has something to do with why lakka s905 pcsx rearmed os over 1mb when kodi uses generic one that is around 500kb

    The lakka ones are the same as what's provided in the libreelec repo, they have the same neon optimizations... these where added a couple of weeks ago.


    I have just updated all the binary add-ons to the latest versions a few hours ago, so can you try the ones from the libreelec repo and let me know.

  • I have said for some time now that the build will automatically update

    Cheers GDPR-2 i only found my way to your build a day ago.

    This is a pretty fast and stable version on my K1 Pro (signature) using TV Headend DVB-T channels.

    Lightning fast through the channels switching and my movie library plays all great.

    Chapter skipping and big jumps forward really fast.

    Scrolling through my movie library is really fast considering the SD Card LE.

    Thanks to afl1 , kszaq and everyone else in making this possible. :thumbup:

  • I assume the widevine library is no longer included in this build for copyright reasons. But It also deletes the library if it is already installed?


    i upgraded from 1.0.3 to the latest version and I can no longer use NF.

    Running kszaq's LibreELEC 8.2.2.3 and adamg's LibreELEC 9.x 1.0.6 on Cooleme MB1 (S905X - 2GB/8GB)

  • Normally,

    widevine libraries should be in /storage/.kodi/cdm folder. At least - that's where the inputstream is looking for 'em by default.

    1.0.6 upgrade is not deleting this folder and its content,

    and I haven't noticed any of the previous update releases to touch it either.

    Just create cdm folder once and put the appropriate libwidevinecdm.so in it,

    and you should be safe.

  • I installed libwidevine again when I saw DRM failure errors in the log and it's now working.


    I just found strange that the automatic update from 1.0.3 to 1.0.6 would mess up the system.

    Running kszaq's LibreELEC 8.2.2.3 and adamg's LibreELEC 9.x 1.0.6 on Cooleme MB1 (S905X - 2GB/8GB)

  • chapter skipping has been fixed by afl1 it will be included on the next release


    I installed libwidevine again when I saw DRM failure errors in the log and it's now working.


    I just found strange that the automatic update from 1.0.3 to 1.0.6 would mess up the system.

    Yes I had to remove the precompiled binary to be compliant with the rules of posting community releases on this forum unfortunately, I replaced it with a service/script to automatically download it getlibwidevine.sh

    Sometimes there is a race condition where if the network is not up in time before the script starts then the resulting file size will be 0 so the script removes it in that case. If the file already exists and it is the correct size then it should not remove it. You can run the script manually by typing getlibwidevine.sh in ssh

    -edit

    Upon just reading this I have noticed that the script is not executable because of the wrong file permissions, wouldn't of noticed if you hadn't reported it :) will be fixed in next release

  • Just found the issue for people who was having issues with their boxes after turning their TV's off, will be fixed in next release.

  • New devel version uploaded

    • Chapter seeking patch by afl1
    • Latest version of Kodi source
    • Fixed libwidevine library downloader
    • Fixed specific issue for few a few people when they turn their TV off/on Kodi resolution is warped
  • New devel version uploaded

    • Chapter seeking patch by afl1
    • Latest version of Kodi source
    • Fixed libwidevine library downloader
    • Fixed specific issue for few a few people when they turn their TV off/on Kodi resolution is warped

    And IPTV simple client is working again ;)

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • Any hints how to fix the colorspace problem? My picture is too purple.

    I already tried this: Color problem with S905X


    10 bit gives completely broken colors and for 8 bit I see no difference.

    So what to try now?


    (Hardware is Docooler M9S pro S905, 1 GB ram)

  • Thanks adamg and kszaq for your hard work and prompt address of the issues encountered.

    I have been using the release for some time now in my Beelink Minimxiii and it is slowly replacing my old Ravi 3610 as media center since it can do 4k (I have recently switched from a 1080p tv).


    As a suggestion, for us brave enough, would it be possible to add a setting to upgrade to devel versions?

    Or to choose which version to install enabling upgrade/downgrade to different channels in a similar way that can be done for LE generic versions by manually adding and update repository path.

    I would rather select when and which version upgrade to.


    LibreELEC settings for update seem to be missing the option.



    Thank you.

    Beelink MiniMX III 2GB/16GB gigabit LAN
    LibreELEC running from SD card (will confirm version on post).

  • Gaudi Unfortunately I don't provide an update channel simply because I don't have a way to generate the file and I don't know Python well enough to modify any script on my own (for now).


    Speaking of updates, GDPR-2 where did you get update.php from? Or did you write it by yourself?

  • Gaudi Unfortunately I don't provide an update channel simply because I don't have a way to generate the file and I don't know Python well enough to modify any script on my own (for now).


    Speaking of updates, GDPR-2 where did you get update.php from? Or did you write it by yourself?

    I wrote it myself after working out what get requests LE-settings sends, I would be happy to send you a copy.