[8.2.3.1] LibreELEC 8.2 for S905/S905X

  • Do you have sync playback to display on in kodi player settings?

    I'm not sure but it's well possible. :-/

    I will check that setting tonight and toggle it. I let you know if it made a difference.

  • I just flashed 8.1.9 onto a brand new Mecool M8S Pro+. Everything works but wifi (I am aware of the wifi chip issue) and the rear USB port on the left side. I'm using the recommended DTB, but for some reason the port is dead. Is this a known issue? kszaq - coffee on the way.

    MXIII-G, M8 and Beeklink MXIII Plus LE 8.2.2 - Demetris, Mecool M8S Pro+/Abox A1, Abox A1 Max Coreelec 9.0.2. Thanks to all.

  • I just flashed 8.1.9 onto a brand new Mecool M8S Pro+. Everything works but wifi (I am aware of the wifi chip issue) and the rear USB port on the left side. I'm using the recommended DTB, but for some reason the port is dead. Is this a known issue? kszaq - coffee on the way.

    I had similar results using the dtb.img file provided by wrxtasy. I did a complete re-installation using the gxl_p212_2g.dtb from the links on the 1st page of this thread and both usb ports now work ok. I did continue to use the remote.conf file provided by wrtasy, I do not use wi-fi.

  • I had similar results using the dtb.img file provided by wrxtasy. I did a complete re-installation using the gxl_p212_2g.dtb from the links on the 1st page of this thread and both usb ports now work ok. I did continue to use the remote.conf file provided by wrtasy, I do not use wi-fi.

    Same here. The dtb.img file provided wrxtasy will not activate the rear USB port. But use gxl_p212_2g.dtb with the remote.conf file provided by wrxtasy and the rear USB port will work again. Also confirm that wifi is no good


    I think in one of the Kodi forum threads, wrxtasy says that he uses the Khadas Vim device tree, maybe for better wifi. I have decompiled the dtb provided by wrxtasy and the header mentions "vim"



  • Thanks a million for that Ray!! Worked like a charm.



    @Anybody who can understand serial boot logs:


    Here is my Kermit serial log of the Khadas boot failure/auto shutdown when booting LE from SD.


    Code
    1. https://pastebin.com/vQEd8REt


    I was FINALLY able to boot balbes150 Armbian image from SD after flashing his multiboot patch, but when I try to boot the LE image on SD (with proper DTB), the device immediately powers off as soon as it passes the Khadas boot logo. I am using the last known working build which would be 8.1.8


    Here's a Kermit log from the Armbian image I was able to get to boot successfully. I have no idea if there is any relevant info in it but felt I should include it in case there is something that indicates a hardware problem:


    Code
    1. https://pastebin.com/0ZaarB8J






    Cheers

  • Same here. The dtb.img file provided wrxtasy will not activate the rear USB port. But use gxl_p212_2g.dtb with the remote.conf file provided by wrxtasy and the rear USB port will work again. Also confirm that wifi is no good


    I think in one of the Kodi forum threads, wrxtasy says that he uses the Khadas Vim device tree, maybe for better wifi. I have decompiled the dtb provided by wrxtasy and the header mentions "vim"


    Thanks Pajoe and sirzur. Rear USB now works.

    MXIII-G, M8 and Beeklink MXIII Plus LE 8.2.2 - Demetris, Mecool M8S Pro+/Abox A1, Abox A1 Max Coreelec 9.0.2. Thanks to all.

  • I've just bought a new S905X box (SMBOX 2), and work fine with 8.1.9 when I boot from an SD card. However, I want to install to internal but when I run the 'Installtointernal' command I get:


    "Formatting SYSTEM partition...The file /dev/system does not exist and no size was specified".


    I've just deleted dtb.img, re-copied gxl_p212_1g_nand.dtb and renamed to dtb.img again just in case I'd done it wrong but I still get the same error.


    It fails immediately after asking you to type 'yes' to confirm you want to do it, and I have tried it multiple times ([HOWTO + FAQ] Install community builds on S905/S905X/S912 device).


    Indeed, there is no system folder under /dev


    Someone can help me?

  • I have the same issue with the S905X 1G-ram/8G.


    8.0 builds install to nand without issue, 8.2 builds cant find the system partition


    Tried the dtb from 8.0, gxl_p212_1g_nand.dtb , and various others



    Ofcourse right after posting I manage to get gxl_p212_1g.dtb to work.

  • Poida yes, i use shadertoy v1.1.5.1 from libreElec Add-ons repo, I do a fresh instal and it's still de same, my box is a TX5 no pro 2g/8g . I think I will just disabled the visualisation or stay on the old build.

  • My 2nd memobox t95n arrived today. This is 2GB/16GB version from a different seller and it has the same issue as my other one, it won't boot properly most of the times. Hangs at the libreelec logo and it's not accessible via network. I'll make debug logs.


    I've placed my 8GB version on a Samsung TV and I was wondering if CEC has the option to turn the s905x box ON when switching to the input. In Libreelec there are plenty of CEC option that turn on the TV and AVR when turning the s905x box on, but it would be cool if it worked the other way around. The Samsung remote works excellent via CEC, but either I need to leave the box on 24/7, or I'd still need a second remote to turn Libreelec on.

    If it ain't broken: break it, fix it, repeat