[8.2.3.1] LibreELEC 8.2 for S905/S905X

  • Hi,

    After anche update fronte 8.1.2 ti 8.1.4 with wrong dtb (my fault) my mxq pro 4k with analogico 905 won't boot. After a new boot via toothpick and SD with correct dtb I've tried to fix but now the box doesn't start neither with SD and toothpick method and displays always "no signal". Any idea? I don't want completato format the box.

    Regards

  • Which device tree are you using?

    Have you tried installing to nand?


    Thanks!

    I´m using gxl_p212_2g.dtb


    Mine is installed on nand since begin

    - Box Android Mini M8S II (Amlogic S905X, 2GB RAM, 8GB ROM)
    - Ugreen USB Ethernet Adapter Usb 3.0 2.0 [ASIX AX88179 Chipset]
    - LibreELEC 8.2 (Nougat Kernel) builds aimed at devices based on Amlogic S905/S905X SoC.

  • Hello,


    first of all, thanks for your work and time you put into this build to all contributors.


    I did an upgrade from latest 8.0.2 to 8.1.3 on my Beelink mini MX3 II which went well except for very poor WLAN performance (no problems with connecting or signal strength). It was impossible to stream anything from my NAS and even SSH was unstable or not even possible at times.

    The problems persisted in 8.1.4, interestingly after some usage (probably a few hours) it gets to normal performance and everything works as expected.


    Today I downgraded to 8.1.2 and have not experienced these issues since. I suspect the updated WLAN firmware in 8.1.3 to cause these problems in my setup.

    Maybe you could revert the update in the next build (I don't know if anything important is included in the new firmware). If there is anything I can do to help, let me know (I was not able to spot anything in the logs (kernel nor kodi)).


    Best regards

  • I installed on an Odroid C2 and could successfully install a custom splash screen (LE splash, not KODI), but how does one do it for a 905x android tv box? Any instructions for custom splash for the same? Cant see anything that I can change in the 'libreelec' partition.


    Also, the oem remote that came with the box seems to be working and powers on and off the box too. Is it safe to shut down the box this way without selecting 'Shutdown' in Kodi?

  • After a new boot via toothpick and SD with correct dtb I've tried to fix but now the box doesn't start neither with SD and toothpick method and displays always "no signal". Any idea? I don't want completato format the box.

    If even the first logo doesn't show I'm afraid you can only bring the box back to life using USB Burning Tool.

    Today I downgraded to 8.1.2 and have not experienced these issues since. I suspect the updated WLAN firmware in 8.1.3 to cause these problems in my setup.

    Maybe you could revert the update in the next build (I don't know if anything important is included in the new firmware). If there is anything I can do to help, let me know (I was not able to spot anything in the logs (kernel nor kodi)).

    Hm, the updated firmware is indeed slower but certainly not unusable. I will try to fix this and I'mm revert if unfixable.


    Edit: It looks that the updated firmware works much better with an updated kernel module. I will include it in 8.1.5. :)

    I installed on an Odroid C2 and could successfully install a custom splash screen (LE splash, not KODI), but how does one do it for a 905x android tv box? Any instructions for custom splash for the same? Cant see anything that I can change in the 'libreelec' partition.

    There is no "file" with logo on other boxes, there's a dedicated partition with logo in custom Amlogic format. Try to look it up at Freaktab forum.

    Also, the oem remote that came with the box seems to be working and powers on and off the box too. Is it safe to shut down the box this way without selecting 'Shutdown' in Kodi?

    Yes, pressing the button does the same thing.

  • looking forward to the 8.1.5 build :)

    Nexbox A95X 1GB Ram 8GB Rom Amlogic S905X
    JVC 55" 4k UHD 3D Smart TV
    JVC 40" 3D Blu-ray Sound bar

  • Hm, the updated firmware is indeed slower but certainly not unusable. I will try to fix this and I'mm revert if unfixable.

    Edit: It looks that the updated firmware works much better with an updated kernel module. I will include it in 8.1.5.

    Thanks, I am going to test 8.1.5 when its released and report back if the problem persists.


    The new firmware worked better with 2.4GHz (slower but still usable) , but with 5GHz the performance was much worse to the extend of unstable SSH.

  • hi, thanks for your awesome work. I have used this libreelec firmware on my x96 box and it works like a charm. My box is a x96 905x 2gb/16gb box. I have also 2 mini m8s ii boxes with 905x and 2gb/16gb. Can I use the micro sd card that is in my x96 box in the mini m8 boxes because it has the same specs (905x 2gb/16gb 100mbit) or will this not work?

  • Hi kszaq as always, awesome build - works fantastic on my Wetek Play. I've downloaded the remote.config as per your instructions on this thread.

    Just one question - how can I emulate the sms type letters behaviour on the remote keypad (e.g. pressing "2" gives ABC) as I find this invaluable when scrolling through my several hundred ripped movies.


    Many thanks

  • The new firmware worked better with 2.4GHz (slower but still usable) , but with 5GHz the performance was much worse to the extend of unstable SSH.

    My tests with 802.1ac 5GHz WiFi, device standing 15cm from the router, iperf3 over TCP to a wired NAS:

    • new firmware, old driver: ~50Mbps
    • new firmware, new driver: ~180Mbps download, ~110Mbps upload

    Can I use the micro sd card that is in my x96 box in the mini m8 boxes because it has the same specs (905x 2gb/16gb 100mbit) or will this not work?

    Yes, you can. Even if you have a bit different device you should only replace device tree and it should work. I am doing this all the time. :)

    Just one question - how can I emulate the sms type letters behaviour on the remote keypad (e.g. pressing "2" gives ABC) as I find this invaluable when scrolling through my several hundred ripped movies.

    I don't know, maybe better ask at general support or Kodi forum? The letters work with full-screen keyboard, not sure about movies list.

  • Err, the download link doesn't seem to be working.

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro (Coreelec), Fire TV 4K Stick (Bedroom)

    Synology DS414 Plex Pass

    :)

  • If even the first logo doesn't show I'm afraid you can only bring the box back to life using USB Burning Tool.

    Ho kszaq, tnx for your answer. I've tried USB Burning tool but it doesn't detect my box. Is It possible that the commands to fix wrong dtb (dd etc) may have brick the box or broke the band?

  • Only for 8.1.5 - upload in progress...

    Sorry, if I sound impatient. I didn't know if you realised.


    Thanks for all the time & support you give to this (and other) builds.

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro (Coreelec), Fire TV 4K Stick (Bedroom)

    Synology DS414 Plex Pass

    :)

  • Ho kszaq, tnx for your answer. I've tried USB Burning tool but it doesn't detect my box. Is It possible that the commands to fix wrong dtb (dd etc) may have brick the box or broke the band?

    If you ran only the first command, you might have (soft-)bricked the box. Try to look for "SD burning" tool and use it.

  • If you ran only the first command, you might have (soft-)bricked the box. Try to look for "SD burning" tool and use it.

    I've run both commands. However I'll try SD Burning, tnx