Screen Size is Wrong

  • Hi all,


    Not sure if this is a LibreElec, Kodi, TV or some other problem.


    As you can (hopefully) see from the picture, Kodi (using LibreElec 8.01h, but same result for other versions) doesn't format correctly on screen. All of the edges appear to be chopped off. This behavior occurs on a QBox (S905) as well as on an A95X (S905X) box.




    The TV is a Dynex DX-L32-10a in a bedroom. It has a stated resolution of 1366 x 768 and 720p format.


    Setting the Kodi input for 1080i gets this result (as does setting it for 720p).


    The set does not have an accessible overscan control (greyed out in the setup menu). The only setting is a wide/cinema/zoom which results in the same or worse - in normal it makes the picture take up the center of the screen and still be clipped as displayed in the image attached.


    I would blame this on the television but for the fact that my DirecTV receiver HR-24 500 (I think) - a high def DVR - displays correctly and is set to kick out a 1080i signal.


    Any thoughts on a fix? It chops off enough of the picture (in a video as well) as to be virtually unusable.



    Thanks.



    Andrew

  • It's just a simple video calibration needed.

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10

    • Official Post

    That's most likely overscan problem which need to be solved in the TV settings.


    Using Kodis video calibration will result in a lost of resolution and should be the last resort if the GUI doesn't fit the screen. The overscan settings for the TV might be somewhere in its zoom options. So please check that first, before you use the video calibration. If nothing works, then ofc the calibration is the way to go (or think about a better TV ;) )

  • i have an old samsung lcd that doesn't have the overscan options so no choice but to use video calibration.

  • In the perfect world, you want 1:1 pixel mapping. This means that each pixel outputted from the source is displayed on the screen without being remapped or altered in any way. What appears to be your problem is something called "overscan". This is a relic from ancient time, still present in a lot of tv's these days. it does, as the name suggests, overscan the image and chops of the edges. In the past (thirty years ago :) ) , this was done to lose crap which was transmitted along with frames, such as tv text among others, and distortion in the analog broadcast.


    What you want to do is search in the settings of your tv, for a setting which disables the overscan function. Recalibrating the screen in kodi is something you want to avoid. With this option, you'll still have the tv overscanning each frame, and then kodi displays it's image in a cropped fashion. You'll effectively lose resolution and add distortion.

    • Official Post


    i have an old samsung lcd that doesn't have the overscan options so no choice but to use video calibration.


    It might not be called "overscan" directly. Just check the zoom options from your TV and play with them.


    Could you please tell me which exact TV model it is?

  • Thanks for all the input.


    As I noted, the overscan function on the set is greyed out in the setup menu (and I don't have the service menu password/option).
    I used the zoom, and it seems to work fine - it is after all, a bedroom TV. I think it is set at -8% which seems to be a lot.


    The Dynex TV, however, was never a top of the line model.


    Andrew

  • It might not be called "overscan" directly. Just check the zoom options from your TV and play with them.


    Could you please tell me which exact TV model it is?


    This is true, some tv's have it as an option in the zoom modes "16:9 , 4:3 , true , wide etc", my panasonic has it as an option far away in a sub menu. There are also tv's that can only disable the overscan on specific inputs; older tv's with dvi input sometimes have extra settings to make. But i never encountered a tv which was unable to disable overscan. Normally there's always an option.
    [hr]
    I found this (crappy) video which shows how to enablen the service menu (at your own risk!):

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    There also seem to be software updates available for this tv (als at own risk!).

    Edited once, last by dipswitch ().