LibreELEC builds with nVidia 304.xx driver

  • Hi,


    did a fresh install of LibreELEC 8.0.1 on my ASUS M4N78-VM HTPC. Kodi starts and can be operated for between 30 and 90 seconds. Then the screen starts flickering (like X having wrong modelines) and the machine totally locks up (mouse cannot be moved, debug overlay freezes, no SSH login possible, no ping). Running tail -f on the Kodi log from a SSH shows no issue at the time of the crash. Kodi 17.1 under Windows 10 on the same machine runs well.


    Please find information below.


    Kind regards
    Boris


    Mainboard Information


    KODI log pastebin


    lspci output


    dmesg output follows in next post due to post size limit.


    Edit: Use pastebin.com for the next time ;). Usage: <command> | pastebinit


    [ 0.000000] Linux version 4.9.13 ([email protected]) (gcc version 6.2.0 (GCC) - Pastebin.com

    Edited once, last by DaVu ().


  • Hi,..


    The nvidia legacy driver was updated in libreELEC v8 and it no longer works with the geforce 7000, 8000, 9000 and 100 series gpus.
    You can either download an older version of LibreELEC or download a custom version of LibreELEC with the older nvidia legacy drivers integrated in.
    I have compiled 8.0.1 here with the older 304.135 nvidia drivers (I am a 8200 user too ;) ):
    Releases · sammy2142/LibreELEC.tv · GitHub

    Edited 2 times, last by sam3: update gpu list ().

  • Many thanks Sam3 i just downloaded 8.2.1 from you. just need to do manual update now as i have never done it before

  • strange after update i can not select spdif output
    as a matter of fact i can not change the sound output at all
    is there a way to change this besides an fresh install?



    1. #!/bin/sh
    2. sleep 4; \

    does the job

    Edited once, last by nowe ().