Milhouse Generic builds (OE)

  • Where can we see what are the milhouse builds? I keep reading about them, but can't see in download page or a comparison between Milhouse and regular OS.

    its linked in the second post of this thread by Milhouse.
    Index of /builds/master/
    as far as i can tell it's the latest cutting edge build based on kodi 17 kypton while the regular download is based on kodi 16.1rc2 jarvis.

  • I've now stopped building OpenELEC, and will only be releasing LibreELEC test builds in future.

    They're documented and supported over on the Kodi forum (as that's always where they've been posted in the past, and where the majority of users/developers are).

    Here's the links:

    RPi/RPi2 test thread
    Generic test thread

    There should be daily RPi, RPi2 and also Generic (x86) builds.

    Builds will be posted after 9pm UK time.

    Please post problems/issues relating to the test builds in the relevant Kodi forum test build threads.

    Edited once, last by milhouse ().

  • While waiting for devupdate to get updated; I patched it to make it work with Milhouse LibreElec builds, all others including openelec will not work: devupdate

    2 files changed are lib/ & lib/

    I just renamed (appended) existing two files in .kodi\addons\script.openelec.devupdate\resources\lib with (i.e.

    Then copied two modified files into same folder, rebooted LibreElec and everything seems to be working correctly in devupdate for updating LibreElec testbuilds (can step through existing available milhouse libreelec testbuilds), thanks ;)

    Will update to latest build tonight/tomorrow using temp modified/patched devupdate.

    RPi4, (LibreELEC 10.0 Nightlies) hdmi0 -> Philips 55PUS7304 4K TV, hdmi1 -> Onkyo TX-SR608 AV Receiver

  • I have to add, that I'm also using a SMB connection to another Pi1, where my videos are stored (on external HDD). So it seems like a network issue. I'll probably check with the OE builds.

    I get a cannot connect to remote server unless I select either none or local information only in content settings on a Chromebox.

  • Updating to the latest Milhouse build is just a matter of copying the .tar to the /update folder right?

    Will I keep my settings when updating?

    Also, whenever I want to go back to basis LE (Kodi 16.1), can I just use the download from downloads – LibreELEC ?

  • Yes, yes and yes.

    Although a backup is recommended.

    Also what I tend to do when testing is keep all my test version tar files in /storage, then I can ssh in and copy the version I want to test to .update and reboot to install it. If I want to revert, it is easy to copy the old version tar file to .update and reboot again.

    Of course now with LE it works with .img.gz files too.

  • Hi, I'm using Libreelec from today , I've been using Openelec. I have issue with one addons Transmission. It is working on official Libreelec but just for ver LibreELEC-Generic.x86_64-8.0-Milhouse-20160421040821-#0420-gfee76be which is dated for 21st April. Could you help me to solve this issue. Regards

  • Please can anyone tell me if the LibreELEC-Generic.x86_64-8.0 builds are compatible with a Celeron N3050 1.6GHz based Acer Revo M1601. Just want to check I will be using the correct version. Thanks

  • It worked for official and April 21 of your version , that is after April 21 Remove the addition of support ??

    Edited once, last by witek666 ().

  • I dont mean to hijack a thread at all but it seems like Milhouse might have an idea to solve this. (RPi3)I recently reflashed and switched from OE to LE then upgraded to MH Build #0508. I am running into an issue with my addons gui. When I open a video addon the screen is blank but I can still hear my navigation sounds when moving around. I can exit from the addon back to the main menu(all is fine again)and when i try to enter a different addon I get a glimpse of the home screen of the previous addon that i exited, then it goes blank again. Im not getting any errors so I didnt think posting a log would help.

    Found out switching from Estuary to any other skin somewhat helped with the issue. Mimic gets me into the addon, like youtube, I search for the video, results display, choose a video. When the video is done and it returns to the result menu it is blank and i have to go back and search again.

    Edited once, last by narfoner ().

  • FYI the best place to find support for the Milhouse test builds are the RPi/x86 Milhouse threads on the Kodi Forum. This is where the test builds are published and the majority of developers will hang out (some LE but mostly Kodi developers, which is important as most problems tend to be Kodi rather than LE problems).

  • I just tried upgrading to the #514 version from the official LibreElec 7.0. I cannot seem to get any sound in the new version. I tried searching but I do not see any answers. I am running a Zotac MA320 box with a Kabini A4-5000 CPU and the Radeon HD 8000 series graphics. Since it worked in v.7, I have to imagine it works in v.8 even if it is a test build.

    For now, I will downgrade to 7 until I can figure it out.

    Thanks in advance.

  • I have an Asus Chromebox Celeron, and for all of the builds after May 13 I gets loads of dropped frames. Is this a know issue?