S905 builds - general discussion


  • Hi,
    Hopefully someone can help me. I need a remote.conf file for the Mini MX box. I have tried extracting it from both Alex's OpenELEC and android original firmware (OTA update file) without success. I would appreciate it if someone has this file and sends it to me, or show me how to extract it myself. The problem is that every time we update to a new version of LibreELEC we have to manually update this file. I wish we had OTA updates or .tar files to avoid losing our set-ups every time we update.
    Thank you very much.


    I don't have the file, but I'm wondering why you need to keep replacing it? It should still work after an update. How are you updating? If you just stick the img.gz file in the update folder libreelec should do its magic on re-boot and keep all your data.

  • What Android? This is LibreELEC only build. There's no Android here...Or Am I missing something?


    I am using the wetek hub, android on nand and libre on sd.
    The same error was shown to me and I was told to fix it by setting the right resulotion in android.
    Worked for me.
    I bet here are many wetek hub users right now ^^
    I can't decide between this and wrxtasy version for the hub



    Oh yes, on .004 I can't shutdown libreelec/the device propally.
    The power indicator still remains blue (on) and the hub is not responding to any key commands.
    Don't know if this is this version or libreelec or maybe only the hub.

    Device1: Wetek Hub: LibreElec by kszaq 8.1.3
    Device2: FireTV Stick + SMPC 16.4.2
    Device3: MK808B+: LibreELEC 7.0.2.4 (kszaq)

    Edited once, last by Stimmenhotel ().


  • Hi,
    Hopefully someone can help me. I need a remote.conf file for the Mini MX box. I have tried extracting it from both Alex's OpenELEC and android original firmware (OTA update file) without success. I would appreciate it if someone has this file and sends it to me, or show me how to extract it myself. The problem is that every time we update to a new version of LibreELEC we have to manually update this file. I wish we had OTA updates or .tar files to avoid losing our set-ups every time we update.
    Thank you very much.


    Not sure why you need the remote.conf file for your Mini MX box, cuz Mini MX is the default box for kzsaq's build. Anyway, you can download file named 'Beelink_MiniMX_factorycode-0xff000001.7z' from this link: Index of /LibreELEC/FILES/ . There you'll find remote.conf for Mini MX.


    As for updating, I experienced the same issue. However, before update, I make Kodi backup, copy the backup file to a PC, copy it back to the Mini MX box after updating, and then restore the backup. I have not tried copying the img.gz file to the update folder like what I did for RPi2. I used the SD card version and keep Android in NAND all the time. I am afraid updating with img.gz file in update folder might over write the Android in the box.

    Edited once, last by wkchick ().


  • I have LE on NAND so no Android here. ;) Funny (well maybe not so funny...) but I've seen one 720p file that makes same effect. Shame because I thought that maybe I would give this box to my mother :(


    On my MXQ Pro Quick Play powering down behaves the same - LED remains blue. I didn't check if buttons other then power works after powering down. And it has to power down somehow because AVR loose it's signal.

  • Just booted this on my MXQ Pro Quick play (v004) and WOW. Had issues with Kodi locking it up and having to pull power. Mostly stable if I used SPMC and disabled all acceleration, but video suffered.
    Anyway, took a couple of goes with audio settings to get sound correct. But hooked to my Sony Home Theatre with passthrough, I have 5.1sound, so far no lock up and picture quality is excellent.
    I've also loaded my preferred Transparency skin. A few more favourite add-ons to install, but colour me impressed. Thanks to Kszaq, this box finally working as expected.

    Edited once, last by Tanzer26 ().

  • Follow-up on my audio problems with version 5 on a minim8s:
    I booted my old HTPC with OE 5.x
    No audio problems.
    The difference: Frame Rate.


    I watch mainly anime. And for some reason, kodi always detects 23.810 FPS at the very beginning of the file. Then is the difference between OE on my HTPC and LE on the minim8s:
    After 2 seconds (or more), OE refreshes the FR back to the correct 23.976, LE doesn't refresh and remains at 23.810, even with "Always" option selected for source frame rate sync.


    Since audio and video have to be in sync, it might be the problem.


    Also, I do not think it's possible to change source FR when playing a file (or any other debug function?)


    To further my point, some files do play at the intended 23.976 FPS and have no audio troubles...


    Thanks


  • Just booted this on my MXQ Pro Quick play (v004) and WOW. Had issues with Kodi locking it up and having to pull power. Mostly stable if I used SPMC and disabled all acceleration, but video suffered.
    Anyway, took a couple of goes with audio settings to get sound correct. But hooked to my Sony Home Theatre with passthrough, I have 5.1sound, so far no lock up and picture quality is excellent.
    I've also loaded my preferred Transparency skin. A few more favourite add-ons to install, but colour me impressed. Thanks to Kszaq, this box finally working as expected.


    Could you please tell me what your settings are? I have same device so it would great to have some reference.
    Can you play 1080p videos without any issues with picture? Did you set your GUI resolution to 1080p? Because I'm getting artifacts like this when playing 1080p content or trying to set GUI to this resolution.

    Edited once, last by Draghmar ().

  • I don't have the file, but I'm wondering why you need to keep replacing it? It should still work after an update. How are you updating? If you just stick the img.gz file in the update folder libreelec should do its magic on re-boot and keep all your data.


    Sorry, yes, I just noticed the remote works after the update, though I updated using the toothpick method, but it still worked. Next time I update LibreELEC I will follow your recommendations so I won't lose my data. Does this method work for both Nand and SD card installs? I have mine on Nand. Thank you very much.

    Edited once, last by Majorero ().

  • Have you manage to do something with this issue?
    I have the same thing on my MXQ Pro Quick Play with 7.0.2.005 build installed on NAND.
    I can't even use KODI in [email protected] Only [email protected] Switching to 1080p makes screen look like from your photo and I have to wait until system restores previous one.
    If I choose video that is in 1080p then it plays in background and there's nothing I can do - no button on remote is working and only thing that can be done is to unplug DC cable. 720p videos works fine.


    I suggested (in post 385, above) to try this (but didn't see any response back to see if it worked or not), perhaps it might work for you ? ...
    Try turning off "Adjust display refresh rate" under settings/video/playback.

  • just got the mini mxiii and having trouble with the toothpick method, anyone have any ideas? I'm not ready to flash on the NAND on this box and adb does not work since it isnt rooted.


    EDIT: Went to backup&update and used a random kodi addon zip then proceeded to update the box and bam LE booted from SD. The kodi addons zip where on the NAND after lauching kodi within Android. I think the reset button is broken on this box as well.


    Also the box has s905 revision C processor. Power, reboot, sleep all fully functional via remote on 004.

    Edited once, last by JonSnow ().


  • just got the mini mxiii and having trouble with the toothpick method, anyone have any ideas? I'm not ready to flash on the NAND on this box and adb does not work since it isnt rooted.


    EDIT: Went to backup&update and used a random kodi addon zip then proceeded to update the box and bam LE booted from SD. The kodi addons zip where on the NAND after lauching kodi within Android. I think the reset button is broken on this box as well.


    Also the box has s905 revision C processor.


    What are you trying to do with ADB? you don't need root to use ADB (if you're trying to use adb boot recovery command over wifi), you just need to enable developer options which should be done by hitting the build number 5 times.

  • What are you trying to do with ADB? you don't need root to use ADB (if you're trying to use adb boot recovery command over wifi), you just need to enable developer options which should be done by hitting the build number 5 times.


    Right that makes sense, cant believe i forgot to enable developer options.
    [hr]








    anyone else notice 004 only shows 2 cores? 005 shows all 4.
    Astra-SES_Demo_UHD_satellite_end-of-2015 played without artifacts

    Edited once, last by JonSnow ().

  • [hr]


    I think the reset button is broken on this box as well.


    More people should consider returning the boxes that have non-funtional reset switches.
    Without the reset switch, if the box fails to boot properly, you have a major headache.
    If more people returned them, instead of 'making do' perhaps less dodgy sellers would be passing these rejects off as original


    Anyone purchasing from ebay (or using Paypal) will have no problem getting a full refund (especially those that live in Australia)
    Both ebay and Paypal have purchase guarantee, meaning any goods received that are not as adverised or faulty, entitle you to full refund including return postage.


    I have just returned two Nexbox A95s because the reset switches did not work. Full refund and, as seller refused to provide a return postage label, was not required to post the boxes back.


    I am now looking at the Mini MX 2GB ram /16GB rom boxes.
    Is anyone using these builds on a Mini MX 2/16GB - or do they only work with the 1/8GB ?

    Edited once, last by Poida ().


  • Is anyone using these builds on a Mini MX 2/16GB - or do they only work with the 1/8GB ?


    Yes, I'm using the 7.0.2.005 image with a Beelink Mini MX III 2/16GB box via microSD card and for the most part it works very well. There are issues with HEVC stuttering (also present on Alex's OpenELEC build, but not on Android SPMC). Also, 5.1 PCM output doesn't work, but another thread suggests that this affects all LibreELEC builds.

    Beelink MiniMX III 2GB/16GB gigabit LAN


    LibreELEC 8.2.3.1 installed to internal RAM.


  • Anyone purchasing from ebay (or using Paypal) will have no problem getting a full refund (especially those that live in Australia)
    Both ebay and Paypal have purchase guarantee, meaning any goods received that are not as adverised or faulty, entitle you to full refund including return postage.


    Be carefull with that advice. If the seller has customer pays return postage in their returns policy and they claim the postage will be returned AFTER the goods are returned and inspected, stay away.
    This is a way of them making sure you dont return the goods. Why ? Because in China you have to pay DUTY when anything comes into China.
    No way they accept the goods are returns. They do not aknowledge returns as being not subject to DUTY.
    The seller will refuse to pay the duty and the goods will be returned to you.
    They will then advise you FAILED to return the goods and you will be well annoyed.
    Hope this adds to clarify the Chinese Smart Business Policy.
    I totally agree with you.
    [hr]


    Is anyone using these builds on a Mini MX 2/16GB - or do they only work with the 1/8GB ?


    They both work.
    Only problem i have had is the Ethernet is sometimes not recognised on Cold Boot only.
    Never happens if box has power supply alive.
    It happens in Android as well.
    Ethernet module error and Kszaq is aware of my issue.
    Cheers.

    Edited once, last by kostaman ().


  • Good point, the chinese sellers always claim they are unable to print the return postage labels, but promise to refund postage once the goods are received by them.
    I personally have never agreed to this and ALWAYS demand that they supply return postage label - as per ebay policy - they refuse and are therefore in default.
    At that point request to return case is marked as complete and purchase price refunded. Usually takes about a week
    [hr]



    Yes, I'm using the 7.0.2.005 image with a Beelink Mini MX III 2/16GB box via microSD card and for the most part it works very well.


    That's good news, does the led work correctly (and reboot / shutdown etc) ?

    Edited once, last by Poida ().


  • That's good news, does the led work correctly (and reboot / shutdown etc) ?


    MiniMx 2gb/16gb White Light when "ON"
    No light when turned "Off"
    MiniMX 1gb / 8gb Blue Light when "On"
    Red Light when "Off"


    Reboot , Shutdown Works.

    Edited once, last by kostaman ().