S905 builds - general discussion

  • Hello all,


    I have just registered, first I am not trying to troll or anything. I have been using XBMC for a long time, Kodi not so long, usually from Openelec, and more recently Libreelec.


    I just wanted to explain my little (short) experience for a day with an s905x:


    I have two home theaters at home, both with dedicated (silent) computers, 5.1 sound systems, and a Rpi3 on another single tv (yes, the kitchen).


    I have been looking for some time for a simple, yet powerfule (x265) solution to use as a kodi player, after reading the forums I decided to get an s905 device Beelink MiniMXIII from amazon. And here the problems began...


    I received the player next day, and installed the libreelec on an sdcard. It booted at first try (toothpick), but after loading nothing worked (no usb, no mouse, no controls, etc).


    After digging a bit, I discover that although I specifically asked for an MXIII they sent me an MXIII-II, yes, same specs but with the s905x processor.


    I remade the sdcard with the correct dtb.img and now I have a workable system. The usb's work, the ethernet too.


    Here are my impressions:
    wifi didn't work, ok, I can put an ethernet.
    remote didn't work, ok, not the most important, and I also read in the forums you need to copy the correct config.
    CEC remote (the one from tv, hdmi interface) didn't work either (the Rpi3 worked correctly with this tv)


    It's ok, I can get that.


    Now the serious stuff. No matter what I did, no matter what I setup, I could not make it work in 5.1. The central (voice) channel was always mute.
    I changed the libreelec version (7.2 and 7.9), change settings, tried with libreelec, tried with kodi from the android system... all of them failed in the same way. Stereo worked though, but that is not enough for me.
    As a personal note, it also looked like the image didn't have the same quality as my x86 player (thay may have been my impression though).


    So my question is, had any one got any similar experience? I understand that the device is under heavy development (thanks kszaq!), and that I have only read half the messages in the post but I am curious to know if anyone has had more luck than me with the optical output.


    I returned the device, I will keep an eye on the forum and for sure I will try again in the future, but the first impresssion was... very unsatisfactory.


    Regards


    PD: Sorry I am not providing logs, or more information about the tests I made.


  • Hello,


    How did you know that it is a MXIII-II?


    Maybe I have same device.


    Regards.


  • Direct answer: When I booted with android, went to settings, about, hardware: There was the model mxiii-2 and the processor specification s905x.
    There was no sign externally, or in the box.


    But there were several "hints" that should have given it away easily: it came with android 6, and it didn't work in the first boot when I used the dtb.img of the s905 (no wifi, lan, usb...), pretty logical when you think about it.


    I was not happy about it, I was looking for the s905 because I read here that the development was more advanced. On the other side in Amazon the mx-iii was 53€ while the mx-iii2 was 44€, so it also felt like I was scammed. The next day I cheked the mx-iii was "not available", so I guess they just send me that and didn't even know about it.


    Regards


  • Thanks,


    I don't have Android installed, could I check it in LE?


    Regards.


  • Thanks,


    I don't have Android installed, could I check it in LE?


    Regards.


    I don't know, I do not have the device anymore as I returned it after the "adventure". I am sure you can login into it from ssh and do something like lspci or lshw that should give you enough information.


    In any case, if the drivers are not the correct ones (the dtb.img) the device will not work, there is no mistake possible.


    Regards,
    Kino


  • There is one thing in my to-do list: compile ethernet driver as module while keeping MAC address from u-boot working and this might help your issue. You need to give me a few days, I'm a busy man recently (non-LE related).


    kszaq I just want to issue feedback from my issue way back #181  using the MiniMx 2gb / 16gb whereby my ethernet was not being recognised on a cold boot.
    It has not happened ever after upgrading to Development Build 18th October 2016. http://kszaq.libreelec.tv/s905/devel/201...453.img.gz
    I know it is a long time ago but i just realised as i move this box from room to room and it hooks up ethernet every time even when un plugged from power. :idea: :D

    Edited once, last by kostaman ().

  • Hi All


    Having a strange issue on my device in that when I reboot my device I seem to be getting a different IP address each time


    It's hard wired via a cable so I'm rather surprised by this. I am using the Libreelec 7 build


    Anyone ever come across this?


    Any help appreciated


    Thanks


    Mark


  • Fixed - used latest release


  • I tried twice and the stick got bricked with the second time ssh like I said.


    Hi,
    I installed openelec in my mk808b plus using the toothpick method.
    I got libreelec updating from openelec.


    Unfortunately, I had to come back to an older openelec build, because CEC did not work properly in my Samsung tv.

    Edited once, last by Sharuman ().


  • Hi,
    I installed openelec in my mk808b plus using the toothpick method.
    I got libreelec updating from openelec.


    Unfortunately, I had to come back to an older openelec build, because CEC did not work properly in my Samsung tv.


    Thanks for sharing.
    But my mk808b is amlogic s905 version and yours are s805, right?


    Toothpick method doesn't work with my device. (If insert toothpick in the hole, it will not boot until release it, and then it goes to normal boot as usual.) I can install LibreELEC to sd card with recovery app from stock android firmware, even can flash it to NAND with LibreELEC zip.


    But although flashing zip to NAND show successful result (as with ssh "installtointernal" from sd card), the device still not boot LibreELEC from NAND. It goes dark screen. However in this state, I can still use LibreELEC from sd card booting.


    The problem is that if I choose to reboot from NAND, or maybe doing ssh "installtointernal" repeatedly, the device will get bricked! I have to use amlogic burning tool to flash back to android and start all over again and again. :(


    I thinks I might have to settle with using LibreELEC only from sd card.

  • Is there any way of adding support for my TV tuner. It is a generic brand that is recognised as Geniatech T230 normally.

    Code
    [  [email protected]] usb 1-1: USB disconnect, device number 2
    [  [email protected]] usb 1-1: new high-speed USB device number 3 using dwc_otg
    [  [email protected]] usb 1-1: New USB device found, idVendor=0572, idProduct=c688
    [  [email protected]] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [  [email protected]] usb 1-1: Product: USB Stick
    [  [email protected]] usb 1-1: Manufacturer: Max
    [  [email protected]] usb 1-1: SerialNumber: 080116
    LibreELEC:~ #
  • I have odd behaviour on 008 version. Once my device reboots from Kodi to nand its all good. Reboots to Android, but if I shutdown or reboot from Android box gets stuck on Beelink logo. The only way to boot it back to Kodi is pulling the power cable 3 times as the first two are also hanging. Is that possible to fix?I'm on Beelink mini MXIII.


    Sent from my ONEPLUS A3003 using Tapatalk


  • CEC on Samsung TV's not working well with 009, have to check how it behaves with 008



    Sent from my iPhone using Tapatalk


    Hello, is there any shell command to test CEC?


    My TV is not working too, it is a Sony TV.


    I want to know if there id a command to power on/off the TV from LE.


    Regards.



  • Have no idea,we must wait for kszaq



    Sent from my iPhone using Tapatalk

  • I don't have solution for this either but if you find a guide created for other device, like RPi I think you should be able to use it - we also use libCEC for CEC communication (although hardware implementation is Amlogic-specific).