VPN Manager for OpenVPN

  • 4.1.8 is on GitHub


    Trespasser It has a pop up connection table as an alternative to filtering, with a key map function to help set it up (see

    Connection Switching if you want to do this manually). You can choose to display the entire list of connections, or just the validated ones.


    If you already have a cycle key mapped, then you can optionally map the pop up table as a long press, but this seem to only work well with keyboards and not TV remotes via CEC.


    I'll put it on the repo in a few days after I've tested it a little bit more.

  • I recently changed ISP provider, only to find out that my VPN provider is blocked.


    I know this because if I connect to my phone then it all works, and if on my pc i go to Nord VPN web page it’s blocked.


    I am using Kodi, VPN Manage for open VPN with Libreelec


    Can anybody help me? I feel like I’ve lost my right arm

  • Thanks, Zomboided. :).

    I'll give it a try when we get back home (small vacation to the beach before cold weather sets in).


    Thanks for your efforts, bud. :).

    Bob

  • Hi, hoping not to open up wounds, I am not to active here: I use nightly of Libreelec 9. Currently build 1004. No problems here. It worked on the stable 8.0.2 and 8.2 as well. The download is indeed huge for NordVPN. As mentioned I think: I always cancel the first connection after download and do it separate as validation of the first connection. For me as mentioned I think, it was essential to use the up/down scripts. Hope you get your issue solved.


    Regards


    As a side note: if you timeout on the download/update you might consider adding the one connection as user defined.

  • Hi Zomboided,

    Well, I'm back home. Last night I tried 4.1.8 and the long press on the 'D' remote key, after changing the gen.xml from cycle to table, brings up a list of my validated Nord connections. This solution will work fine. You can have up to 10 of them after all...:).


    Thanks for your hard work, buddy. :).


    BTW, NordVPN is a good vpn service but I'm shopping for another when my expiration date approaches. It takes too long to connect sometimes.


    Bob

  • Has anyone managed to access the webinterface behind the vpn? I noticed that there up and down script support but not sure what to do. I know there is also the option about iptables. i need my alexa to be able to access port 8080 but the vpn blocks it.


    iptables -t nat -I PREROUTING -p tcp -i eth0 --dport 8080 -j DNAT --to LIBREELEC_IP:8080


    iptables -I FORWARD -p tcp -d LIBREELEC_IP --dport 8080 -j ACCEPT


    Are the above commands right? Im using a wired ethernet connection. Any help would be great.

  • Use of the up and down scripts is documented in the wiki, along with an example you can enable. I don't have anything useful to say about what you'd put in them, but it's not unique to LE or Kodi, that's just "normal" iptables manipulation.

  • Hi, i am having troubles getting user defined setup. i am currently subscribed to Bolehvpn and have all of the keys and cert uploaded into the userdata folder "user defined" as described in the wiki. after loading that and trying to connect it failes "unexpected error happened" i have logged the issue and have pastebin link to the log any help is greatly appreciated.....thank you in advance


    Pastebin: pastebin.com/Q1uxJd5x

  • Start again and use the import wizard and many/all of these problems will go away. Supply all of the files needed at the same time and use the resulting log and the openvpn log to debug the issues.

  • the openvpn log says its an options error: unrecognized option or missing or extra parameters in /storage/.kod/addons/service.vpn.manager/userdefined/xcloakproxy-canada (udp). OVPN:18: scramble (2.4.0)


    i tried one other ovpn file and same error came up


    thanks in advance

  • It's telling you that you've supplied an ovpn file that contains a bad option. The import wizard isn't gonna fix that.


    Here's the manual page with the options Openvpn24ManPage – OpenVPN Community


    Work out what option it is by opening the ovpn file and determine why that line is bad.


    I don't know why your provider would supply options files that don't work, but maybe the issue is with an option not being available in the level of openvpn you're running. If you're using LE, then you're using 2.4.0

  • hi i keep getting TLS-Auth fail with ta.key. The ta.key file is in the UserDefined folder with the .ovpn file it looks like this:

    script-security 2


    #Connection Settings

    client

    dev tun

    proto udp

    nobind

    persist-key



    #Security Settings

    tls-auth ta.key 1

    auth sha512

    cipher AES-256-CBC

    tls-cipher TLS-DHE-RSA-WITH-AES-128-CBC-SHA256

    verify-x509-name bviserver name


    #US

    remote 104.250.136.243 880


    resolv-retry 30


    # Set log file verbosity.

    verb 3


    # Silence repeating messages

    mute 20


    #User Info



    ca /storage/.kodi/addons/service.vpn.manager/UserDefined/ca.crt

    cert /storage/.kodi/addons/service.vpn.manager/UserDefined/haru_14.crt

    key /storage/.kodi/addons/service.vpn.manager/UserDefined/haru_14.key


    ping 5

    ping-exit 30

    ping-timer-rem


    not quite sure what the problem is...thoughts?

  • i also looked into the options issue and in the ovpn file i just posted there was an option called scramble xorptrpos that was giving the issue

    i removed it from the file and that error quit coming up. i am not sure if the scramble is necessary when i went to the open vpn manual as per the link you provided it looks like v2.4 did not have that option....or at least i could not find it anywhere and i scrolled and scrolled and scrolled! haha


    thank you for all of the help! i am not that strong with stuff but i have done a lot of reading and am slowly catching on....i am almost there with getting a successful connection but just seem to keep running into an issue after fixing the previous:(

  • Good man for helping yourself so much. The issue is that the ta.key can't be found because it's not path qualified.


    If you'd supplied the .ta file on import like you did for the other files (.ca, .key and .cert) then the import code would have resolved this for you. The import code has no knowledge of the parameters (as there are too many and they change). It will just fix files that are referenced if you supply them.


    The import puts files in /storage/.kodi/userdata/addon-data/service.vpn.manager/UserDefined. When you select UserDefined in the GUI, it'll copy all the files for use from that directory into the paths you see referenced. You should repeat the import and input the .ta file to fix this.


    A quick google suggests the scramble option is something that was patched into some versions of openvpn that may have been made available by some VPN providers. I guess it didn't end up making it into 2.4.0. I didn't look closely enough. If your VPN provider is one of those that requires the patched ovpnvpn executable, then you might be out of luck if it can't operate without this. You're right to remove it meantime though.

  • I have a question i went and download the zip from github, then install it, but when i go to the program add ons the manager is never there.. is only in services.. why?

  • I have a question i went and download the zip from github, then install it, but when i go to the program add ons the manager is never there.. is only in services.. why?

    Install the repo

    You installed the Repo.

    Now install the add-on which is in the add-on.

    Is that what you did ?