VPN Manager for OpenVPN

  • Hi there zomboided.

    First I want to say thank you for the addon.

    I have pureVPN and I can sign in no problem and I can connect to the VPN, My problem is that after it disconnects for no reason.

    I have tried multiple servers but always with the same result, disconnection. I was hoping you could tell me what I'm doing wrong?

    Asus chromebox

    LibreELEC v8.0.2

    Kodi v17.3

    Celladdoor Build


    Thanks

  • I have pureVPN and I can sign in no problem and I can connect to the VPN, My problem is that after it disconnects for no reason.

    I have tried multiple servers but always with the same result, disconnection. I was hoping you could tell me what I'm doing wrong?

    Asus chromebox

    Start reading from below link and you might come to the conclusion that your VPN Provider may be your issue.

    #281

  • Start reading from below link and you might come to the conclusion that your VPN Provider may be your issue.

    #281

    Thanks. I'm not very technical at all so it really didn't make any sense to me at all. I really have no idea how to set up a user defined wizard.

    I guess PureVpn is a piece of crap and a rip off.

    Thanks

  • Was there a broken/missing update published recently? I had auto updates enabled for the vpn manager and a day or so ago an update to 4.0.8 came along but it fails to download it (as a result the addon disappears).

    Looking at github the last version is 4.0.7 and I reverted to reinstall it manually from zip to get it back again.

  • Yeah, 4.0.8 was bad. 4.0.9 has been pushed now.

    Might need to alert Updates to the OP with Changelog.

    I've just gone through the 4.0.8 wiping the addon and no 4.0.8 was visible in your Github.

    I got a bit of a scare.

    I disabled your Repo to stop Updates.

  • I found that an upgrade to 4.0.9 caused me to reconfigure the VPN connection, reset the VPN provider files and then reconfigure the connections. Please do this if you see any weirdness before reporting problems.

  • Hi zomboided

    I've recently started playing around with recent Kodi Master (Leia) builds for my Odroid C2 (with 32 bit libs, thus compatible to RPi2/3 Addons). There I get bootloops directly after installing your VPN Manager Add-on. Only way to get out of it, is to delete the ./kodi/addons/vpnmanager directory.


    I assume the root cause might be the switch from LibreSSL to OpenSSL in LibreELEC based Leia. Is there something you could do about it already? I'm aware that Leia is far away from final stage ;).

  • Hi,


    I too am having issues with VPN Manager in Leia. While with the latest Millhouse build I no longer get the bootloop, I am unable to change any of the settings within VPN manager itself. When I click settings i am presented with an empty dialog.


    Code
    1. 11:24:42.847 T:139784783644736 ERROR: Control 55 in window 10001 has been asked to focus, but it can't
    2. 11:24:42.916 T:139781235836672 ERROR: CAddon[service.vpn.manager]: failed to load addon settings from special://profile/addon_data/service.vpn.manager/settings.xml


    Removing the files in /addons_data and /addons folder doesnt have any effect. Ive tested on default Estuary and Estuary ModV2 skins

  • See here : Latest changes to kodi, possibly CSettingsManager cause kodi to crash · Issue #81 · Zomboided/service.vpn.manager · GitHub

    There were some changes in something called CSettingsManager which messed this up. There's nothing (currently) illegal in my xml settings, and I don't want to change them as they're all there for a good reason. The Kodi team need to fix this, which I believe they're doing.


    I'm not really interested in wasting time fixing problems in beta builds because a) I don't use them, and b) life is too short to be debugging other peoples code.

  • Thanks for the fast response zomboided.


    I assumed that would possibly be the case, so I guess I will just need to be patient while the Alpha builds progress some more.


    Thanks for the great addon btw

  • Hello,

    I have installed Zomboided VPN manager on my Raspberry pi 3 running LibreElec version 8.02 for Ipvanish ,the connection is established fine with any server,but the it appears that VPN time out after a day or even after half an hour sometimes, and no addons is working, until I disconnect and reconnect to another server or simply re-establish connection to the same server by re-booting my pi. When I attempt to display the VPN status, no dlg will pop up, but after a while a dlg will pop up and say "connected to unknown VPN using valid server profile, but with unknown external IP address and unknown provider". I have same VPN on my phone, but it never time out, after I installed the security certificate on it. So I am fairly certain that the problem is not from my router.

    I would appreciate if somebody can give me any insight to this problem. Thank you

  • IPVanish appear to have changed their connections recently, but the method of connection and certificates remain the same as when I added them. I'll update them somewhen soon, busy with other things right now. Meantime, try other connections, maybe you hit upon a bad one, otherwise follow the trouble shooting guide linked in the first post. I suspect you'll see the same problems if you use the command line with the ovpn files that IPVanish supply which would indicate an issue outside of the plugin.

  • Hi Zomboided,


    Thank you for the your response and your information. I been working with Ipvanish support team for a long time to solve this problem, but apparently they do not have sufficient information to solve it. Thank you again I will wait for the next update.

  • Thanks for the add-on for me works great

    I have a question if I can redirect some ports

    .... for example, email client / transmission, etc......

    is it possible .Probably iptables rules?

  • It supports up and down scripts. See the documentation on the wiki. You'll need to work out what the set of changes you need to make to the iptables rules are.

    Edited 2 times, last by zomboided ().

  • Thanks for the info...for now I can not verify it

    But now I have another mistake

    After a few days of working properly I get this error

    On another computer and the same settings

    Server / client works well ...?

    Files

    • openvpn-log

      (955 Byte, downloaded 123 times, last: )

    Edited once, last by kraken ().

  • Looking at VPN's and in particular Express VPN, IP Vanish and PIA in that order. Are there any known issues with any of these running in VPN Manager?