VPN Manager for OpenVPN

  • zomboided Been trying to install OpenVPN onto a 10.0.0 LE Pi 4GB. It completes the repo successfully, but there is only a Video add-on for "Kids TV". No Services option at all.
    Just did this successfully a couple weeks ago, and am following the same procedure. THAT system (that was working) is now not connecting to my VPN. FWIW, my VPN connects just fine via PC, but the Pi version seems to be having serious issues.

  • See previous page/the posts directly before yours, you need 6.9.3, which you'll need to get from github

    Negative--'dependency not resolved' error. Tried installing outright, tried removing previous version and installing 6.9.3, same error.

    So should I roll back LibreElec and try 6.9.3? Or will I have to rebuild completely and hope 6.9.3 works on a raw unit?

    EDIT: You have to start from a raw build.

  • Good morning,

    having problems here as well. Trying to install the VPN Addon. I get the error message that xbmc.python in version 2.7.0 dependencies can not be resolved. Also tried to use 6.9.3 without success. any suggestions?


    ###SOLVED### all went well, I had to download the zip file manually (wget...) to my pi and it works now :)

    Edited 2 times, last by deadkenny ().

  • I’ve pushed v7.0.0 to the repo now for those using Matrix. I left the older 6.4.3 version on there too for those using older versions of Kodi but I honestly haven’t tested if it can still be installed.

    If you’re not on Matrix you'll see a message that 7.0.0 doesn’t meet the pre reqs and it’ll not upgrade. This is working as designed. 7.0.0 needs Python 3 which only Matrix has

  • Hi there I am trying to connect to ExpressVPN via this addon I put my user name and password in? I am using the email and password i set is this right or am I meant to use the openvpn username and password that I can get for express VPN?

    once I select my server it loads and i get the message "Express VPN requires key and certificate files unique to you in order to authenticate. These are typically called client.key and client.crt or user.key and user.crt or can be embedded within .ovpn files." so I press OK. Then I get "ExpressVPN uses the same key and certificate for all connections. Make either the .key and .crt, or the .ovpn file available on an accessible drive or USB key." How do I get these files that I require? and am I using the right username and password please?

  • You need to get an ovpn file from Express VPN, it will have things in you need and those things will be extracted. I'm not a subscriber so I can't describe where or how Express offer this download.

  • So what IS the 'moving forward' solution here? I don't mind having to work/rework things from time to time, but it seems like ExpressVPN and LibrElec like incompatibility more than compatibility.
    Should I switch VPNs? Switch to regular Raspbian?

  • So in case anyone is trying to figure this out, you have to:
    Rebuild from new
    Download 6.9.3 from GitHub--do NOT use the Zomboid repo

    Download your client keys and login from ExpressVPN

    All will work then.

    Gotta give it: those Zomboid guys are cryptic, but they do answer your question. :D

  • Hi there,

    I am trying to configure OpenVPN with Zenmate but can not manage to make it work.

    Zenmate is compatible with OpenVPN.

    From its web interface, I can manage the necessary files: ca.crt, client.crt, client.key, openvpn.ovpn

    Running the wizard, I select all these 4 files, import log says it is ok.

    Then going on forward, it doesn't seem able to connect and here is the log file:

    I tried many times and still end up with the same error log file.

    Can anyone help me understand what I am doing wrong and how to correct it ?

  • Thansk to your reply and looking at the log file,

    I created a pass.txt file with 2 lines (usename and password)

    and modified these lines in the .ovpn file to reflect path:

    ca ca.crt to ca #PATH/ca.crt

    cert client.crt to cert #PATH/client.crt

    key client.key to cert #PATH/client.crt

    And apparentlty it is now working.

    Edited 2 times, last by guilders ().

  • Hello, i have a specific networking problem and i’d much appreciate some help.

    I have Asus router ( with openvpn server running on it (TUN,, so i can have access to my home network from the outside. On my Vero 4k ( i have Surfshark VPN, managed through Zomboided addon. If i’m on my home network, i can normally access Vero4k (NAS, Transmission etc). But when i’m connected to my home network via VPN, i cannot see Vero4k or access NAS etc. I can do that only, if i disconnect Vero 4k from the Surfshark VPN. Any hints? Thank you.

  • ... But when i’m connected to my home network via VPN, i cannot see Vero4k or access NAS etc. I can do that only, if i disconnect Vero 4k from the Surfshark VPN. Any hints? Thank you.

    First check that your OpenVPN server settings allow access to your home network.

    Second, stop using device names and use IP addresses to find devices.

  • Hi, thank you for your answer. On my Asus/Merlin Vpn, i can access all other devices on my LAN, except Vero4k, when it has Surshark Vpn enabled. Client VPN is set to both, lan+internet. I'm using IPs all the time. I think i have a routing problem, but i duuno how to solve it...

  • With Surshark VPN enabled SSH into the device and type 'ifconfig' then you will see all the IP addresses of your device; your router knows the ethernet and wifi range. Those are the addresses to use remotely.

    Added: I forgot to say that if you connect to your Asus server from a home network with the same range of IP addresses as you have on the Asus home network, there may be conflicts and not work. In this case change the address range of your home network (for example, from to

    Edited once, last by elonesna ().

  • I'm connecting to my home vpn through android open vpn app. My router home ip is and my vpn subnet is When Vero4k (rpi) is on surfshark vpn, i can't see destination tun0, gateway and genmask I can see samba shares at home on, also when i'm on asus vpn and surshark is disabled on Vero 4k. As soon as i enable it, i can't reach it.