CEC problem - RPi 2 - v7.95.3

  • After upgrading my RPi2 to v7.95.3 the CEC is not working. With the previous version v7.95.2 everything was ok.
    When i reboot the RPi2 the coursor buttons starts to work but "play-stop-pause" buttons are not working. After switching the TV back to DVB-C, DVB-T, other HDMI source and than again to RPi source or turning off then on the TV the CEC stops to work. Definitely a bug as v7.95.2 was excellent with CEC.


    My TV - Panasonic TX-P46G20ES

  • Agreed CEC is broken in this build. There seem to be a number of users reporting this in separate posts. I guess everyone should be uploading their debug logs in order for this one to be fixed.

  • No effect, CEC does not work on this version as it should, or as it did work on v7.95.2. (RPi3 & Panasonic TV)

    X92_S912_q201 3/32G - 1GB Ethernet Box_Android 7.1.2, X96Mini_S905W 2/16G 0.1GB Ethernet Box_Android 7.1.2,

    Mocool KM8 2/16 0.1GB Ethernet Box_Android 8.0



  • prwnd Can you try disconnecting TV from mains for a minute and retrying?
    Also see this post: How do I make additional buttons on my Panasonic remote work?


    Panasonic sending PVR button presses is a choice the TV makes (you can affect it with the magic button code)
    and it may have just got disabled.


    Please see my TV remote. I have a dedicated button (see picture) on the low right corner to control the "play, stop, pause" etc. buttons. With v7.95.2 and even with former Openelec everything went fine. I could even disable media buttons with that switch button. But with v7.95.3 i have problem with CEC itself. Non of the buttons are working.


    Update: interesting anomaly. If i start to control OS with Yatse, after some minutes the remote starts to work. But is i change source (HDMI, TV, DVB-C) and go back again no response. And the game begins, i start to control with Yatse (Android) and after some minutes remote turns alive.
    I made only one setup change, namely set the CEC preferences to default, but i think it has nothing to do with it.

  • I'm experiencing the same issues with a rpi3, Panasonic TV and lg soundbar. Cec is disconnected when the TV has been turned off, a reboot fixes it. However, same as prwnd, the lower half of my remote is not working.
    I've never had these issues until 7.95.3

  • There have been some libcec changes and some firmware changes between Jarvis and Krypton.
    If you are having trouble with CEC on Pi, you can try reverting the firmware back. Download the following two file:
    start.elf?raw=true
    fixup.dat?raw=true


    and replace the ones on the sdcard (take a copy of the old files in case you want to switch back after testing).
    These files should be visible when the sdcard is inserted into a PC with an sdcard reader (assuming a direct LibreELEC install, rather than a NOOBS install).


    Power off the TV from mains for a minute. Check you are seeing a problem. Revert the firmware. Power off the TV from mains for a minute. Report if any difference in behaviour.

  • popcornmix ,


    I just tested this and it has resolved the CEC issues on my RPi3. Just to confirm this was all working on 7.95.2 so it seems a change in firmware between that and .3 broke it. Out of interest how does this get fixed when it was introduced by a 3rd party?


    Many thanks for your help on this

    Edited once, last by stream ().

  • It fixed all the issues for me as well! And I would also like to reiterate that the issues started at 7.95.3 and I have been running 7.95.1 and .2 as well.
    Thanks for your help!


  • I'm having the same issue on WEtek Play, is there a fix for wetek play?
    For details see: thread-4845.html

  • I'm having the same issue on WEtek Play, is there a fix for wetek play?
    For details see: thread-4845.html


    Same here with Wetek Core. I have been using Android so far, but since the PlayStore KODI Krypton update screwed up the hw acceleration, I switched to Libreelec on SD. Now CEC is not working properly. It sort-of starts and works for a few seconds, but then it stops working. Yesterday it worked for a few hours before stopping. Sometimes it starts when I reboot Libreelec, sometimes not. Both TV (Philips Easylink) and KODI (settings-peripherals) options are turned on.


    Is there anythong that can be done? I hate juggling more remotes than necessary.

  • According LE blog post discussion, yes - for some of installations, particulary people with Panasonic TV. I would save those files, just to have backup in case of affected installation.

    Odroid C2 + ??? - proof of concept, trying to find out best ELEC version supporting: GPIO IR, Mysql(for Kodi library), DVB-T2 drivers, TVHeadend. Not sucessfull yet.

    6x RPi2 + Various TV's + LE 7.0.3, 2x Win7 Kodi 16.1 + MySQL from vPeter's LAMP plugin as Library DB + .zip patch + EAC3 patch

    Edited once, last by JimmySmith ().


  • Perfect Solution, thanx a lot :)


    It's a shame that this BUG is still present in 8.0 after many reports on 7.95.3 :@

  • Late response, but yes, the issues are persisting with the 8.0 release (at least for me). Sometimes CEC magically starts working immediately after using Kore to remote control Kodi, sometimes it takes a reboot, I haven't been able to spot a pattern there yet.

  • CEC problem
    I have a Raspberry Pi3 connected to a LG 42LM6200 TV thru HDMI.
    On the last version of Libreelec with Kodi 16 the CEC function correctly
    With latest version (8.0.0) CEC is very strange.
    1. While watching broardcast TV the CEC will switch to the Pi by its self
    2. While switched to the Pi but with no activity the screen saver tries to
    operate but come straight back to life again as thought there is constant activity
    happening somewhere maybe from the CEC


    I have tried the fix above even using the two files from version 7.0.3
    but no fix


    Any help would be appreciated


    Cheers
    Wayne in New Zealand

    Edited once, last by VFR-NZ ().