[9.0.0] LibreELEC builds for MX2/G18

  • Ok I got ext3 on a USB. I flash my box with 8.0. I put the USB on the USB slot. Then turn the on. It would show matricom then LE but after that it would go black and just stay black. I use easeUS partition and labeled it libreelec_disk.

    Edit lucky I just left it on it took a couple of minutes then krypton loaded up. Now I gotta figure the ssh. Thanks for your work koprajs!

    Edit got to run the command through ssh thanks for your help koprajs. I only have one problem. I can't get my keyboard to work. It uses a dongle that plugs into USB it worked before but it don't now.

  • I am running 8.1, just wondering if anyone else is having problems with enabling RTMP input? I don't see the VideoPlayer InputStream, in My Addons.

  • Hi to all !

    Nice work from developer KOPRajs ! :cool: Thanks !

    I was previously used LibreElec 7.95.3 on my MX2 with Kodi 17.0 and there was no any problem at all.
    Then I tried to update with .tar file from .update map and the update process begon good but it didn't saved my settings and update it but it started as a fresh install.
    No problem about that, I thought, and after a reboot it was LibreElec 8.0.1 installed and I had Kodi 17.1 but I couldn't change the skin interface, actually I didn't get possibility to download any other skin except the "Estuary" and when I try to download and when I click on the "Get more Skins" it just "flash" for a while and disappear even I was already conected on the network via the wire and also via wireless too. So, I thought it could be some coruppted files and so let's do it all again but then and now I will do it from the scratch...
    I did it all the way it should be done and I changed to internal NAND and rebooted but again I couldn't change the skin.
    I downgrade and reinstalled the LibreElec 7.95.3 with .zip but also in this version, at that point I couldn't change skin anymore.
    I wiped everything in the recovery, reformat the SD card and I flashed again new, fresh install LibreElec 8.0.1 from recovery with .zip file and changed to internal memory but still the problem remains.
    I got at one point after first reboot the message that some system files are corupted and if I wait 120 seconds it will be repaired. I did it and the system repaired this files and rebooted normally.
    What I else have noticed is that I also couldn't change "Regional settings" at the Interface settings.
    I could only use "English" language and there was no any other languages to choose from except "English" language even I was already conected with the network and online on Internet.
    Also "Weather services" didn't work with a same problem, there was no any provider for weather services on the list.
    Is there any other way to get more other languages and "Confluance" skin interface and to add weather provider manually ?!
    Thanks in advance ! - (Already found an answer).

    P.S. What I have also noticed but I don't know if that have any connection with my problem is that when I format SD card with "MiniTool Partition Wizard Professional Edition" in Windows 10 x64 to .ext3 and when I put it back in the laptop reader after flashing it and repairing the file system it states it's an .ext2 file sysytem and not an .ext3. file system anymore.

    After a long set up through "Estuary" skin I have managed to find all "missing" parts and to set up Kodi 17.1 on the way I like it with all addons from last version.
    What I have learned is that all have to be done manually thru Addon packages and there is and Skin addons, and languages addon and weather addon and have to be installed from "All Addons" section.
    I hope it will help to others too to learn that this clean install of LibreElec 8.0.1 needs to be set up in every small detail.
    Succes !

  • Hi KOPRajs, nice work on maintaining alive and updated our oldie boxes!

    I was wondering if it could be possible to add a selectable option on where to install, at least on new installs from recovery, so people could take its best option without having to input additional commands trough ssh.

    Apart from this, could it be possible to have an automatic way of restoring a profile backup (with all the preferences, installed addons, etc.) on first launch of a fresh install?

  • Hi! I wonder if someone can help. I had a working Libreelec 7 install on a MX2 and I followed the instructions used tune2fs command to change partition name. Then put 8.01 tar file in update directory and restarted the box. It started the update and gave some kind of can't stat mtd4 and then proceeded with the rest of install but when it reboots it says my installation is now broken and gives me gibberish all over the screen. Any ideas what I did wrong and how to recover?




    I ended up doing a full install from recovery and still could not get it to work. Kept getting the same tty message as everyone else. Took me a few tries before I realised that I was formatting the sd card with minitool partition wizard as ext3 Primary and it needs to be ext3 Logical! Duh! My Bad! Just wanted to point that out for others in same situation.



    Edited once, last by iamwally ().

  • I am running 8.1, just wondering if anyone else is having problems with enabling RTMP input? I don't see the VideoPlayer InputStream, in My Addons.

    Still having problems with finding this setting here are the directions I am trying to follow.. Anyone have an idea why this option isn't here?

    kodi 17.1 to enable: Addons -> My Addons -> VideoPlayer InputStream -> RTMP input

  • Edited once, last by Luddite ().

  • Hi,

    I have a HD12 V2.22 motherboard. I was running Codesnakes LE7 version, but I tried to update using the tar file.
    Problem is that I got the message during the UPDATING IN PROGRESS:


    stat: can't stat '/flash/dev/mtd4':No such file or directory

    Now I want to flash the box using the toothpick method, but I can't get into the recovery. It's now hanging at the LibreELEC splash. Can you help me fix the box? I want to enjoy your great work :)

  • I have the latest LibreELEC running on my Matricom but running on NAND. What steps do i need to take to have an SD card take the brunt?. Is it just a matter of renaming an SD card or would i need to do anything further?

  • Edit:

    Deleted. I didn't know an addon is blacklisted. Not sure why...

    Edited once, last by Sag ().

  • I guess the bigger question for me would be how do I know if I need a new installation or an update? I have OpenElec 6.0.3 on an MX 2. Also, how does one create a Libreelec_Disk label on the storage? I'm totally confused about how to do something like that. I'm no coder that's for sure but I can read directions to a point.

  • For a version that old I would recommend a fresh new installation. The difficulty comes in the fact that after it installs it will look for an EXT3 formatted disk labeled LIBREELEC_DISK like mentioned above. I ended up using a Linux virtual machine to format an SD card with that label and copied the files from the ZIP file and then ran the command he listed via SSH. You could also just run it from the SD card directly.

  • The part I might have some questions about is how do I go about relabeling the SD card to LibreElec as I am not sure where that is and or if the existing internal memory needs to now run from an external SD card? I just need to see what the whole proceedure would be starting with doing a new installation from recovery. If I had the box in my possesion now, I'd experiment with it and see what would happen. I have a Mac and can connect the GBox directly to it from a tetherred ethernet cable. I can all the files in it. But if the internal storage nand memory(wahtever that is?) is still working, how do I got abouts changing its label, let alone format an SD card to ext3? If there were just a couple of links to some of these instructions? I'm not sure I can find the original instructions to get even Openelec installed on it. Would I need to use the toothpick method to do a new installation going from Openelec to LibreElec?

  • I got version 8.0.1 working using the usb method as I couldn't get access via SSH - kept getting an error saying that I was 'refused'. I think this might be because I had previously accessed openelec via SSH and it has the same IP address are libreelec.

    The build seems good but I can't seem to get my old addons to work like they used to (e.g. Exodus). Anybody else having this problem?

  • Yes, you will need to do a new installation via the toothpick method. My method was I used a Linux VM to format my SD card as EXT3 with a label of LIBREELEC_DISK. I then copied the files from the new install ZIP file to it and used the toothpick method to install. I left the SD card in to boot, it boots up LibreELEC and Kodi as expected, but this is the SD card version and not the internal memory version. Enable SSH and connect to it, then run the tune2fs command specified in the first post. Power down the MX2, remove the SD card, then power on again and it should boot up normally.

    I tried looking for a reliable tool to format an SD card to EXT3 via Windows 7+ but could not find one so a Linux VM (with Ubuntu) was easier.

    So to summarize:

    1. Use a tool (or Linux VM) to format an SD Card using EXT3 and label it LIBREELEC_DISK
    2. Copy files from new install ZIP to SD Card
    3. Install using toothpick method
    4. Leave SD Card in and let Kodi start
    5. Enable SSH, connect from a computer, run tune2fs command
    6. Shut down MX2, remove SD card, power on again