7.0.3.011 build for S905/S905X


  • I created a fresh SD card and flashed 011 to internal, tried stock 011 kernel, test1 and test2 but was unable to get my Beelink MiniMXIII to reboot 10 times in a row. The only way it booted 10 times in a row was when I removed the SD Card and unplugged my remote.


    So with my test it seems like the boot issue is caused by the usb ports or SD card, @Kaszq could you build a kernel that disables booting from USB? I really think it maybe the USB ports coz as soon as i unplug my remote it boots. Yes I've tried different remotes and the results are the same, the stock remote stopped working but I haven't tested it since 008 since I don't use it anyways.


    @ kostaman maybe you can try unplugging everything from the box except hdmi/lan and reboot using the stock remote or via ssh?


    MiniM8sPro S905 2gb/8gb
    LE Internal Flash
    7.0.3.011 stock version. gxbb_p200_2G_100M_RealtekWiFi.dtb
    18-Dec-2016 16:54 38576



    I think JonSnow may have nailed it. I have slightly different results but definitely the USB Boot in the kernel is having a negative effect in my booting.
    I fired up my box and it booted no problem with no USB or USB Air mouse receiver attached.
    I re booted and powered off the box at least 20 times without a freeze.
    I then inserted a USB Stick in the side USB port of my box (next to the sd card slot) not the back one.
    I rebooted the box and got 5 freezes in a row.
    I then removed the USB Stick and cold powered back on with success.
    Rebooted 4 times no issue.
    I then inserted the USB Stick in the BACK PORT. and rebooted with no issue.
    Did this 4 times with no issue.
    I re inserted the USB Stick back into the side Port and it booted up successfully. That threw me.
    I rebooted another 4 times and it successfully booted until the 5th time it froze.
    I cold booted and it successfully booted.
    Powered off and it rebooted.


    My observation whilst the USB Stick is inserted is that when it does boot,
    The boot animation is shown for a good 8 to 10 seconds.
    Without the USB Stick inserted the boot animation only stays for 3 seconds.


    I would like to disable USB BootUp option with this build and see what happens.
    [hr]


    update: sorry bud but this doesnt work, box rebooted 4 times before hanging, only hdmi and power plugged in 7.0.3.011 installed to nand on my mini mx s905 1gb/8gb realtek wifi box.


    Can you please try the non realtek device tree. I am not 100% sure about your box but i never used that realtek device tree on my MiniMx 1gb/8gbgxbb_p200_1G_1Gbit.dtb
    [hr]
    Edit Update : USB Inserted reboot and got this after LE Splash Screen. Kernel Panic.


    Cold boot and successfully booted after this.

  • @kszak Quite a few posts back i mentioned about my picture being over blown when changing resolution (too big) well i found the issue lied within the Video Acceleration when amcodec is Enabled. Now that I have disabled this the change in resolutions are working perfect. However, i will experience micro stuttering when this is done. Is there any other workaround to get rid of the micro stuttering?


    Kind Regards


    Edit: On 4K content it is a lot more then a simple micro stutter. Not watchable.

    Edited once, last by maceyp ().


  • My observation whilst the USB Stick is inserted is that when it does boot,
    The boot animation is shown for a good 8 to 10 seconds.
    Without the USB Stick inserted the boot animation only stays for 3 seconds.


    I would like to disable USB BootUp option with this build and see what happens.


    USB booting is not handled by kernel, it is handled by u-boot and only after SD card with LE is not detected. That said you may be right that is has some influence on how kernel driver works. Can you please do the following: execute fw_setenv upgrade_step 1 over SSH and reboot - this will make all u-boot variables go back to default values and thus disable SD and USB booting.

  • Hello guys,


    I've just bought myself 2x Nexbox A95X (s905x) and reflashed them with this version of LibreELEC.
    I got 3 issues with the box, hope you guys can help out:

    • HDMI-CEC/ARC: When I shutdown my box and turn off my TV. Come back in a couple of hours and just want to watch TV on my settopbox, then somehow my HDMI-ARC stops working through my receiver. I can still change volume, but it just doesn't give me sound. Until I power on and off the Nexbox, then it works again. Before I had an Asrock with OpenELEC and a HDMI-CEC adapter, which didn't have these problems.
    • When playing a video the screen goes black (no signal) for 2 seconds and comes back. Then it plays the video, with the brightness much higher then in Kodi. When stopping it goes black again for 2 seconds before returning.
    • Scrolling through Kodi is a little bit sluggish. Seems to have a little delay/lag. That while this box should perform better than the Asrock ION I had.


    Any ideas how to solve these issues?

    Edited once, last by Xitro01 ().

  • USB booting is not handled by kernel, it is handled by u-boot and only after SD card with LE is not detected. That said you may be right that is has some influence on how kernel driver works. Can you please do the following: execute fw_setenv upgrade_step 1 over SSH and reboot - this will make all u-boot variables go back to default values and thus disable SD and USB booting.


    Issued command and rebooted. The command worked because i inserted my SD Card with bootable LE on it and it was ignored after this command was issued. It worked prior to the command.


    Well i just spent 45 minutes trying the reboot / on off procedure and the results for me are unchanged
    Except for faster boot up when it does boot up.
    By that i mean the Boot Animation is barely on screen for even 1 second.
    The random Freezing on Boot Animation is present with or without USB Stick installed.
    Less frequent with no USB Installed but that is inconclusive as the freezes are random.
    I had 6 Freezes with USB Installed out of 25 Bootups.
    About 4 Freezes out of roughly the same Bootups without USB Installed
    This is now becoming the Mother of all Bugs.

  • Hi.


    I have a Nexbox A95X s905x 2gb/16gb and 7.0.3.011 installed to nand. I have no problems at all it boots fine every time and picture is good and so is sound.


    So thanks again for your work kszaq.


  • Hi.


    I have a Nexbox A95X s905x 2gb/16gb and 7.0.3.011 installed to nand. I have no problems at all it boots fine every time and picture is good and so is sound.


    So thanks again for your work kszaq.


    Do you also experience, when you launch a video, that your screen goes blank for 1-2 seconds? And after that, that the brightness is much higher?

  • What about the audio sync problems? Isn't anyone else having them? I'm still having them in almost every video I have tested. This is on a Beelink MXiii-ii 2gb 16gb, with the release from 18th dec, and newest device tree installed on internal memory.


    Or is it because im using passthrough?


    btw: Everything else, is working absolutely perfectly! Huge props to kszaq!!

    Edited once, last by beatwolf ().

  • I have the same box, and I'm still having sync issues. Audio is almost always ahead about 100-250ms. What are your settings in kodi?


    Hi beatwolf. I use optical out audio with dolby digital. No sync issues. I have also flashed the rom on a MiniM8S II 1GB with no sync issues. The MiniM8S very rarely when i press the power button it freezes and i need to closed the box from the plug.


    But the MXIII is running perfectly. I have replaced the stock device tree with the one from ksazq (1Gb for MiniM8S and 2Gb for MXIII device trees).
    My only issue overall is on 4K videos with HDR (BT2020) sometimes the colours are disoriented. But not on all files so im not sure what the issue may be.

    Edited once, last by kakoskm ().

  • beatwolf: have the same audio sync problems since .009, also in the Krypton versions. But only when using passthrough and using AC3,DTS ...but not with mp3 - otherwise it works perfectly.


  • Can't help with first issue, but second one could be refresh rate switching together with HDR (read OP).
    3rd one: 64 or 32 bit?

    * s905x, 2/8GB, Coreelec 9.2.1
    * RPi3, LE 9.2.0, GPIO IR
    * Server, kodi-headless, MySQL, VDR, NFS-Server (& much more)


  • Can you try again but with no usb or SD Card, it shouldn't make a difference since the SD and USB boot options have been disabled, but hey worth a shot.

  • Can't help with first issue, but second one could be refresh rate switching together with HDR (read OP).
    3rd one: 64 or 32 bit?


    Thanks, I will check that out. I have installed the aarch64 version so 64-bit.


  • 7.0.3.011 (2016-12-18)
    Known issues:

    • WiFi driver may need to be reloaded after a reboot by manually toggling WiFi in LE Settings.


    Is there a possibilty to get fixed with a workaround? Maybe a script which disables and enables WiFi after startup?
    On my Mini MXIII II I have to do this manually after each boot.


  • beatwolf: have the same audio sync problems since .009, also in the Krypton versions. But only when using passthrough and using AC3,DTS ...but not with mp3 - otherwise it works perfectly.


    OK, haven't really noticed which files and audio formats it happens with. Guess we will have to wait and see if it gets fixed. It's not a huuuge problem, as it can be corrected, but it does get a bit tedious to do every time.