7.0.3.011 build for S905/S905X

  • Audio sync problem S905x.


    When using DVBlink TV client with AC3 or mp2 audio there is no audio sync problem


    Playing video h264 and AC3 there is a small audio sync problem about 80-100ms.


    Playing video h264 and DTS there is a bigger audio sync problem about 200ms.


    Playing video h264 and Master DTS HD I see no audio sync problem.


    Playing video h264 and AAC there is no audio sync problem, but this is not playing as pass though as the others are.

  • AAC audio has to be decoded by the box and sent to the avr as multichannel PCM audio. Same with flac audio.

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test

    Edited once, last by mmpp ().

  • USB booting is not handled by kernel, it is handled by u-boot and only after SD card with LE is not detected. That said you may be right that is has some influence on how kernel driver works. Can you please do the following: execute fw_setenv upgrade_step 1 over SSH and reboot - this will make all u-boot variables go back to default values and thus disable SD and USB booting.


    Well i only tried this on 007 version im running now and WOOOOOOW, boot time went from 15 to 4 seconds.
    This is for Minix U1.
    Will try 011 during holidays :)

  • MX PLUS Amlogic S905 4K TV BOX Android 5.1 1G/8G 802.11b/g/n Gigabit LAN


    using gxbb_p200_1G_1Gbit_RealtekWiFi.dtb renamed to dtb.img and i have boot logo on last version 7.0.3.011 build for S905/S905X 32bit with 7.0.3.009 it was ok ... should i revert back to 009? It is gift for my parrents and i thing with boot loop they kill me soon after christmass :D

    MX Player 1GB 8GB 2.4G WiFi Gbit Lan | nVidia Shield TV stock + SPMC

  • No sound with USB boot of 7.3.011 2016-12-18


    Model: NEXBOX-A95X 2G+8G
    Version: 6.01
    Build: NEXBOX-A95X-RTL8723BS-6.0.1-201611181620
    Connected via HDMI


    Initial boot showed as ALSA:AML-M8AUDIO PCM (no sound)
    Switched to ALSA:AML-M8AUDIO HDMI (still no sound)


    Log: WfXD


    Any help would be appreciated, would be great to get this going - 170 MB memory use vs. 600+ in Android.


  • I have the same box (only difference is 16 vs 8 GB storage), sound over HDMI works fine for me. What device tree did you choose?


    gxl_p212_2g.dtb is the right one for you!

    Nexbox A95X | S905X 2GB/16GB

    Edited once, last by chielmi ().

  • I have the same box (only difference is 16 vs 8 GB storage), sound over HDMI works fine for me. What device tree did you choose?


    gxl_p212_2g.dtb is the right one for you!


    Thanks for that info, I will try that tree ...


    I used the default tree from the image, as it was a fresh install and the install instructions noted:


    " S905X: Device trees for these boxes start with gxl. You can leave a tree that is already present on SD card (fresh install only) or choose one according to your RAM amount. "

  • Here's third kernel to test for users who have booting issues. How to use:

    • Install 7.0.3.011.
    • Make the box boot.
    • Choose kernel URL:


    • Login over SSH and exectute:

      • SD card:

        Code
        mount -o rw,remount /flash
        cd /flash
        rm kernel.img
        wget link_to_kernel_image
        sync


      • Internal:

        Code
        cd /tmp
        wget link_to_kernel_image
        dd if=kernel.img of=/dev/boot



    • Reboot, report.
    • For SD card you can alternatively put the card to your computer and download kernel.img directly there, replacing 7.0.3.011 kernel.

  • First restart after update hang.
    Cold boot.
    First restart OK...
    Second restart hang.
    Cold boot.
    Hang at boot...twice in a row


    Tried regular 64bit 011 and it hangs again...


    Minix U1

    Edited once, last by 9800pro ().

  • still same :( tried with 32-bit version, is possible give you some log or something what can help solve issue?

    MX Player 1GB 8GB 2.4G WiFi Gbit Lan | nVidia Shield TV stock + SPMC

    Edited once, last by locki ().

  • it is easy .... just test it with new kernel which s provided by @ksazq, but it doesnt help

    MX Player 1GB 8GB 2.4G WiFi Gbit Lan | nVidia Shield TV stock + SPMC

  • Nexbox A95X (2Gb/16Gb) -> Yamaha Receiver
    (Audio via HDMI passthrough)


    Hello


    As mentioned by a few people here I also have got a issue with audio/video sync, about 200ms for 23/24p and 85ms for 30p. After searching around on the forum a few members have recommended creating and adding a few lines in advancedsettings.xml to tell Kodi to use 200ms for 23-25 and 85ms for global. Created the file and added the lines as instructed on the Kodi Wiki. After rebooting the box these settings not come into effect.
    Checking the Kodi logs I can see that Kodi does read the file (as it shows all the commends from advancedsettings.xml in the log) but does not act on it..


    .."
    00:00:18 T:4118745664 NOTICE: Loaded settings file from special://profile/advancedsettings.xml
    00:00:18 T:4118745664 NOTICE: Contents of special://profile/advancedsettings.xml are...
    <advancedsettings>
    <video>
    <latency>
    <delay>85</delay>
    <refresh>
    <min>23</min>
    <max>24</max>
    <delay>200</delay>
    </refresh>
    </latency>
    </video>
    </advancedsettings>
    "...


    I have even tried using a single line setting (just a random one to test). Again logs show it loads up but does not act in it. So does this version read and act on the advancedsettings.xml saved in /userdata?


    Thanks :)

  • I had first installed a clean v. 010 and had no problems booting, unlike some of the other users. I updated to 011 and now have issues at boot most of the times. Usually it works after I disconnect the power and reconnect it, but today, 5 disconnects later - I can still not go past the GoogleTV logo my box shows when first booted.


    Box: Mini M8S S905 2GB RAM


    I can provide any information that is necessary.

  • Hi to all


    do i still need a dtb. file like "gxbb_p200_2g_1gbit" or "dtb2_16.img" for my QBox 2/16 with Superceleron Rom to install it with TWRP to Internal.Without i had only Blackscreen , and why renaming to .img if the File self is still .dtb.
    I used latest "aarch64" Build of Version LE/011.
    The LE.zip files are all zipped twice , so i must unzip it once and put the renamed "dtb.img.dtb" file into the still zipped "-update" Folder . Is this correct . After that i can use it for install ??? ,or must "-update"be unzipped and rezipped with "dtd.img.dtb" File for installation ???


    Until now i tried it with and without .dtb with LE 011 & 09 but only Blackscreen , no Boot from USB or SD.
    32 bit too.LE 011 Version was from the 19th.


    have a nice Day



    gefattern

  • The MiniMx 1gb/8gb S905 Non Branded Beelink
    2016-12-23:
    2016-12-23
    Internal Install


    I have just discovered that depending on your box you will get different results with freezing. This is because of different u-boot and how it handles booting.


    I discovered this because today i UPDATED my Krypton Version 32bit to the 23rd December and rebooted the box 20 consecutive times without fail.


    I then inserted a USB Stick into side port and the box froze.
    I cold booted it and it successfully booted.
    I then rebooted and it froze again.


    I then executed [fw_setenv upgrade_step 1] over SSH and rebooted - to make all u-boot variables go back to default values and thus disable SD and USB booting.


    I repeated the reboots with the USB Stick inserted and got repeated random freezes.
    After the last Freeze with USB inserted.
    I took out the USB Stick and it froze.
    I cold Booted and successfully Booted Up.


    I have now performed over 30 reboots without the USB inserted and not 1 Freeze.


    This is not the same behaviour with my MiniM8sPro S905 2gb/8gb  #186


    This also explains why JonSnow gets different results with the MiniMxiii #179
    EDIT: I inserted the USB Stick and ReBooted which froze the box.
    Since i did that the second time the MiniMx 1gb/8gb box is displaying the same results as my MiniM8sPro


    This bug is Definitely related to USB causing Booting issues.
    After the 19th November Dev Build, all versions have a U-Boot conflict relating to Bootup depending on your box.


    I hope this narrows it down and we close in on this little parasite bug.

    Edited once, last by kostaman ().