RetroELEC Kodi+Wayland+Emulationstation+RetroArch (x86/XU4/RPi)

  • noxx

    No, it's not.

    In other news, I've uploaded a new nvidia 304.xx build (20170130) for those with older nvidia cards.

    Going on a two week holiday, so no new builds for a while.

    Edited once, last by escalade ().

  • Don't know if that helps,
    I have tried once again to update to escalade build.
    I can see the following lines:

    "INFO: task swapper/0:1 blocked for more than 120 seconds. not tainted 4.10.0-rc5 #1"

    Hope it will helps to someone.

  • yesterday i try to install your bild on my laptop - pavilion dv6
    after installation xorg failed to start.. what can i do to fix it?

  • great news, thank you for this!

  • Installed libreelec Le on my Intel Nuc i5

    - keep getting random blank screens now and then (have to restart)
    - I am using aeon mq 7 skin is there any way to connect Chromium in that (like script used in default skin) ??
    - Spotify keeps saying installing but never installs

    Any suggestions .....

    Just a question to Intel NUC users with Retroarch : what do you guys think performs best in terms of input lag and general performance : KMS/DRM or Vulkan ? Thanks !

    I am using Featherence Emu addon ....pre-configured with 9 consoles and games best addon ever

    Intel nuc i5
    Liberelec LE

    Edited once, last by vegeto_10 ().

  • escalade: I seem to be unable to compile uae4arm.

    For anyone interested while escalade is on vacation, I rebased all of his changes on the most recent LibreELEC Beta 7.95.2 and compiled for RPi2. I just couldn't wait for his return to get Kodi 17 final and recent LE changes. The only thing that is missing is uae4arm since it will not compile for me.

    I am only providing the RPi2 version as that is what I compiled (sorry Intel users). Please take caution as I am still in the learning phases on building/compiling.

    For those interested, here you go:
    Meet Google Drive – One place for all your files

  • I wanted to thank Escalade and the rest of the community here. Incredible project that makes newbies like me look great. I owe you all a beer or suitable adult beverage.

    I managed to add most of my collection and it looks great and plays pretty good on a Lenovo Flex 2 with a 'Celeron' cpu (barely could run Windows). I do have some newbie questions about touchscreen support, metadata, themes, and scummvm. Someone patient, would you kindly PM me?



    I have about a months worth of Linux experience, most of that from unRAID. Forgive me, I am a newbie!

  • Can anyone suggest some tweaks to snes core? I seem to be running into choppy sound and slow gameplay while playing some snes games most definitely in super mario world.

    Running Chromebox M004U with Escalade's latest build.


  • I noticed the same black screen error with latest update
    I think it is a skin problem with rc 4 krypton

    I used advanced launcher to open chromium in that mq7 skin

  • been using Liberelec for last few days now...

    Intel Nuc i5
    Liberelec LE
    Aeon mq7 mod skin
    Wifi connected with Netgear D6300 router
    Full Access on my Synology NAS (static IP for KODI)


    - random blank screens

    This one is weird, Initially i thought my WiFi driver might have issue with liberelec, but all addon like youtube , downloads and other streaming addons are working fine.... but internet is not pulling metadata/pictures/details for shows/movie. I have to play movie and then stop and all meta data will appear.

    - Slow SMB talk with NAS same issue (no metadata for movies/shows on my Synology NAS until i play something, no customize background pictures (photos from NAS) at main menu...
    (there is no lagging or buffering playing movies from my NAS but does not show metadata).
    - I cant play movies straight away from NAS (if i go into video folder kodi hungsup) have to wait 2-3 mintues until its appears on main screen (will play fine after that no issue).

    I have fresh reinstalled liberelec 3 times LE and beta 7.95.2 version same issue persist.

    Got NUC i3 with Kodiubuntu similar setup everything works fine.

  • Did you tried a reinstall with standard skin (Estuary MOD skin)
    And look if the random crashes still appears

    EDIT: maybe it is the memory leak.
    If that is the case we need to wait till escalade update the build to the latest libreelec

    Edited once, last by Waspoeder ().

  • Thanks so much for this! I'm running it on my new Zotac and it's crazy good. One huge question, I'm not the best at Linux, so hopefully, you can dumb it down to my level :)

    I'm trying to skin it with Aeon Nox. I'm used to it, and always used it. I can't for the life of me figure out how to get the emulators button onto Aeon Nox. I also can't find the code file for Estuary where it shows the link to emulators, I was hoping to copy and paste that into Aeon Nox. Either of those answers would be most helpful.

    Thanks again so much for this!

  • Thank you for the work you have done on this. I am really enjoying ES inside Kodi. I just have 2 questions.

    1. I added my roms. Except I don't see a folder for TurboGrafx-16/pcengine. I created a folder and copied the roms over. How can I get it to show up in ES? Retroarch plays it fine from it's own menu.

    2. I like to use the Vibe Krypton build from the ECHO developer. Installing that build loses the Emulators option. How can I add it into the Xonfluence skin for Vibe? Is there possibly an addon I can install to create a home menu option?

    My system is a Zbox nano AD12. Dual core AMD CPU.

    Thank you in advance. Much appreciated. Great job over all.

  • You must edit the es_system.conf
    add this :
    <fullname>TurboGrafx 16 (PC Engine)</fullname>
    <extension>.pce .cue .zip .PCE .CUE .ZIP</extension>
    <command>/usr/bin/retroarch.start -L /tmp/cores/ %ROM%</command>

    You need to download the core first with retroarch