S802/S812-Libreelec images for 7/8/9

  • I have an M8 s802 and I can't seem to get any of 8x2 images working, every time it installs and reboots i get the usual startup splash screens and then nothing. I can install codesnake 603 and then the 8.0Rc4 and also the old "LibreELEC-S802.arm-8.0.1a-M8" version which seems to have been removed, they both install and load ok but the 8x2 images install, display splash screens and then goes black and doesn't display Kodi. I have tried updating using tar from 603 and from 8.0rc4 etc but same result.


    Can anyone please help? I've tried different combinations and searched back through thread, please help! anyone else with m8 have same issue? if not what combination did you use or am i missing something?

    Index of /image/LE8/arm/8.0.2


    Try either the Gbox or m8 build. Install "update.zip" via Recovery and you can later update to Demetris build with .tar file to update folder.

  • i wont be helping anyone that didnt read the thread and asks for solutions like those of remote not working.

    I did read the thread, every page, but I don't understand everything with the supposed solutions. I tried adding the remote config file posted here, but it did nothing. I still have the same problem. Remote works when device is turned on, but box won't start when I press the power button. Had to roll back to the previous version cause I couldn't fix it.


    Have you found a solution for this? Im having the same issue.

    No I have not found a solution.

  • Many thanks jack9 but I seem to have the exact same problem with those builds too. They install, then reboot, m8 splash, libreELEC splash then nothing. I can install the m8 6.0.0 build from that site but then as soon as I try a later one LIbreELEC, be it v7.x or 8.x I get the blank screen again, back to openelec and all is fine. The strange thing is I can update Demetris 8.0RC4 without any issue and also Demetris LibreELEC-S802.arm-8.0.1a-M8 (which has now been removed?). So I'm not sure what is different with those builds.


    Any ideas? Demetris can you shed any light or have anything I can check / test?


    Many thanks in advance

  • Many thanks jack9 but I seem to have the exact same problem with those builds too. They install, then reboot, m8 splash, libreELEC splash then nothing. I can install the m8 6.0.0 build from that site but then as soon as I try a later one LIbreELEC, be it v7.x or 8.x I get the blank screen again, back to openelec and all is fine. The strange thing is I can update Demetris 8.0RC4 without any issue and also Demetris LibreELEC-S802.arm-8.0.1a-M8 (which has now been removed?). So I'm not sure what is different with those builds.


    Any ideas? Demetris can you shed any light or have anything I can check / test?


    Many thanks in advance

    Your situation is identical to mine, we probably have the exact same M8.


    I posted after every subsequent Demetris build just to say that it wasn't working in the hope that I would get some assistance but none has been forthcoming. I hope you have better luck so we can both benefit.

  • Been away for a while- any success on the BCM4335 models? I've got the Minix X8-H Plus, still without Wi-FI. I went through the whole thread but didn't see any report on that (unless I missed something), am I right?

  • OK.... I have a G-Box Q (S802) and Q2 (S812)... I've tried to read through as much of this thread as I could too. These devices were working very well until a few months ago. Matricom updated their Android OS and Kodi moved on to V17.x and then everything went to crap. Suddenly, I was getting hangs, audio playing while the video froze, and the wife is bitching because the world isn't "easy"...


    No problem. I don't need full Android anyway... So I tried to move to OpenELEC/LibreELEC. I loaded the S8x2_8.0.2b_M8 build by Demetris today and I also tried the "G- BOX" build I found in this thread too. Loading was no problem but my issues continue. I got one lockup but I also found that Kodi 17.3 under one of the 8.0.2 builds didn't process an SMB directory with RAR split video correctly. THoughts here?


    Before I go skeet shooting with one or both of these boxes, can I get some input on builds that might be stable and working well for others and where to find them? Am I just using a poor Matricom product and it's time to move to different hardware?


    Many thanks in advance.

    Edited once, last by kartman ().

  • OK.... I have a G-Box Q (S802) and Q2 (S812)... Am I just using a poor Matricom product and it's time to move to different hardware?


    Many thanks in advance.

    Well it is time to move to different hardware. Matricom seems to be dead. Having said that there are builds that work quite well on these boxes. Use the s8x2 arm M8 build from Demetris for the Q. For the Q2 you need to use the Balbes build from this thread. The Q2 uses the BCM wifi chip which is not in Demetris's build but I am hopeful he will have it for the LE 8.2 release.

  • Well it is time to move to different hardware. Matricom seems to be dead. Having said that there are builds that work quite well on these boxes. Use the s8x2 arm M8 build from Demetris for the Q. For the Q2 you need to use the Balbes build from this thread. The Q2 uses the BCM wifi chip which is not in Demetris's build but I am hopeful he will have it for the LE 8.2 release.

    Thanks for the guidance... I'm going to try to improve the thermal performance on my Q to see if that stops the weird freezes and lockups. I'll install the v8.0.2 s8x2.ARM.M8 build, as recommended. One question... I think I tried this build already and I found that the RAR/Split files on my shared media drive were not being interpreted correctly by Kodi... instead of appearing in the browser as one big media file, it was showing on small RAR and wouldn't play correctly. This surprised me a bit as Kodi has been processing RARs correctly forever.


    What version of LE were you recommending? Latest or something older in the v7.x.x vintage?


    Cheers.

  • Hi.


    I have m8s+ with broken SDcard slot. I tried to burn libreelec from usb port (tried both with toothpick method) and have no result.


    Is possible to flash libreelec with some other methods, e.g. USB burning tool or android update?


    p.s. My other box, beelink mini mx, working with kzasq's libreelec and I burned it with toothpick+usb drive. Unfortunately same method doesn't work with m8s+


    upd. Solution found. I updated to libreelec 7.0.2 via Android Update (from here MEGA) and placed tgz to update to lastest 8.0.2 from Demetris.

    Edited once, last by phanex: solution found. ().

  • OK. On further exploration it seems that the new version of Kodi can take upwards of 10 minutes to upgrade an external sql database. I must not have waited, thinking it was hung, and the next time it booted it came up but would not read the updated database. The fix for this is to delete the xbmcvideo99 database and reboot and leave it long enough to update



    The second real problem however is if the external monitor is not powered on when the box is then the kernel will die on a fatal error unable to create display. Once the monitor is up and repower all is well. This was not an issue with OE.




    Custom Software Development India - Nintriva

  • I used toothpick method but the box boots into Recovery Mode.

    That is what i don't understand with Demetris builds.

    I have used kszaq builds on old s805 chip boxes as well and they have a script to activate boot from SD Card during first install.

    Demetris builds do not seem to have a script to activate SD Card booting when doing a first time install to run LE from SD Card.

    That is what is not clear in everything I've read here to get LibreElec running from SD Card.

    kostaman, did you ever get an answer to your question?

    I've just finished reading 58 pages. I have cut and pasted numerous posts on how to install and run this build on an SD card so that I can try to make sense of it and I have to say its very confusing.

    My box is an MXIII-G 2/8. It ran great on Wilro's build (Freaktab) and unfortunately I wiped that SD card for Balbes's build and cannot seem to get it working again.

    balbes150's script does not work for me and I am not confident with this one.

    MXIII-G, M8 and Beeklink MXIII Plus LE 8.2.2 - Demetris, Mecool M8S Pro+/Abox A1, Abox A1 Max Coreelec 9.0.2. Thanks to all.