S802/S812-Libreelec images for 7/8/9

  • Demetris - firstly thanks so much for this - it's really awesome

    Help needed all

    I'd bricked my device, and managed to get this build working, so that was good. Just one things now....

    My question.....how do I put this onto Nand? I have looked about the forums, they mention doing this with WETEK. However, my device is a:

    M8s S812 - n200c board I think.....Is there a way to run this libreelec straight from nand, without using the sdcard?
    Reason for this, is that my sdcard is old, and I'd prefer using the nand anyway and getting rid of the old android 4.4.2.....

    I'm assuming we'd have to use dd or something similar.

    Anyway can someone point me in the right direction? thanks in advance :)

    ps - I'm aware of flashing a zip file from recovery - done it on my phones etc. Could I make a zip from these img files, that would flash from recovery onto the nand?

    Edited once, last by Neural_oD ().

  • I've flashed it into NAND no problem, using the toothpick method.

    To install OpenElec on your X8-H, X8 Plus, X8-H Plus, follow this procedure:

    1. Download Minitool Partition Wizard from here: Best Free Partition Manager for Windows | MiniTool Partition Free (thanks @Roylegr!)
    2. Format your SD Card with Minitool Partition Wizard in FAT32 format
    3. Rightclick the USB partition in Minitool Partition Wizard, and under Modify, selected Change Partition Type ID
    4. Select 0x81 Minix/Linux and click OK
    5. Then click Apply on the top left (don't forget this, as Minitool Partition Wizard doesn't apply immediately)
    6. Now download the OpenElec Surkovalex build from here: https://mega.nz/#F!W0Qk2JIQ!P1iyw7dFFHvubkIUZ-i1lA!LlBEFApT (take the .ZIP one)
    7. Unzip the three files in this ZIP file to your formatted SD card.
    8. Turn off your Minix X8-H completely and insert the SD card in the side slot.
    9. Then with a paperclip press the little reset button on the back of your device and keep it pressed while turning on the device. When you see the Minix logo appear, release the paperclip from the reset button and wait.

    This gives you OpenElec 5.0, which is only a start (even though this build works the best of all builds I ever tested).

    Then, start it up, connect it to your network, in the settings activate Samba.

    Once Samba is activated, from your PC you can just browse to the box from your Explorer, and place any .tar file in the Update folder.

    Reboot the box and it updates to that build.

    I just have a SD card with this Surkovalex build, so if I mess everything up, I can always revert back using this method and then install a .tar of my choice.

  • Could you please tell me how CEC is working here (specifically interested in Tronsmart S89-H)?

    Does it hibernate box when you power off TV?

    Can I wake up box via CEC (power on TV and change input to HDMI input with "sleeping" box)?

    Does CEC survive input changing (like to TV source and back to HDMI input with box).

    Can CEC be enabled via TV settings? For instance my receiver sometimes "steal" CEC control. Will I be able to return it back to box via TV menu?

  • Arcee thanks so much. I'm going to go try this method, will let you know if there are any problems

    -- as a note - I'll try the partitioning first in gparted, as I use Linux as my distro, but the rest of the process should be the same...

    ** as a note, the link wasn't working, but managed to go higher up, and found this link to be working.....note I'm on the M8s.....

    Index of /image/LE8/arm/8.0.2


    Edited once, last by Neural_oD ().

  • Hi Demetris , I tried your last image LibreELEC-S8X2.arm-8.0.2-MXIII-PLUS.img but again my wifi didnt work.

    Once again my specs :

    MXIII-G 2G Amlogic S812 with AP6330 Chip . Inside the box specs : Netxeon MXIII-C v1.1

    This is my working official firmware : Yandex.Disk (MXIII-C_202L1) .

    Maybe on the next update tried to incude a fix for it.

    Συγχαρητήρια για την εργασία σου , Πάνος .

  • Arcee
    just to let you know - it's not working, but not sure if that's cause the files I have aren't compatible or what?

    I downloaded a couple of files, the one I thought would work had these files in the zip:








    However this was for M8Splus - so it never came up with a logo, the only thing that happened was that it kept cycling to the current logo that's on the box at the moment.

    *** feeling this should be the right "type" of file with the recovery.img files etc, but I feel that I should try to find one for the M8S....

    The other zip I had had these in:




    this too didn't work....

    As a side note - I'm comfortable that I'm doing the toothpick method right, as I'm able to flash a android based rom on this..... however in that zip the folder contents are these....





    Any suggestions would be great.....

    As mentioned I can run libreelec from the sdcard, but I'd really like to flash it straight onto the nand

  • you need 3 files on your SD card, the actual .zip from Demetris, factory update script and a recovery.img.

    I found it easier to flash an old openelec that I knew flashed (even if WiFi didn't work 😉) then put Demetris update zip onto a USB flash drive and used kodi file manager to transfer it to storage/.update.

    Tbh I have never flashed any of Demetris files only ever used the update tars.

    Probably doesn't help you much lol

    All the best


    EDITED: you could try taking the factory update script and recovery.img from your android ROM put these 2 on The root of your SD card along with the correct zip from Demetris

    Edited 2 times, last by chunk1982 ().

  • ** as a note, the link wasn't working, but managed to go higher up, and found this link to be working.....note I'm on the M8s.....

    Index of /image/LE8/arm/8.0.2



    The right files are on Mega, click on this link and you'll be redirected there.

    In Mega, go to the 5.0.8 folder and get the file called OpenELEC-Amlogic.X8.arm-

    Inside you find the following files:

    - OpenELEC-Amlogic.X8.arm-

    - recovery.img

    - factory_update_param.aml

    These are the three files that must be in the root of your SD card, prepared following the procedure I mentioned.

  • Hey, community... very sorry for being a newbie. I own Matricom Q and Q2 devices and I want to move to the latest LibreELEC v8.0.2 build from the stock Matricom. I've flashed some older OpenELEC builds before so I know the basic procedure. Can I just get a bit of help to identify the correct images for my devices? I really don't want to mistakenly brick one.

    For the g-box Q: I need <correct_image>.zip, recovery.img, and factory_update_param.aml

    For the q-box Q2: I need <correct_image>.zip, recovery.img, and factory_update_param.aml

    Does this sound right?

  • Hello to all,

    Just found that I can install this on my minix neo X8-H, I was having some problems with one of the addons (Exodous and pelisalacarta) in the XBMC mini.


    I have some questions:

    • Did you been able to install it on NEO X8-H?
    • If yes, Was the installation on the TV Box and not in the SD?
    • Was all working? wifi??.
    • Sorry for this one but I'm a new with libreelec. How do we downgrade after testing one of the builds.


    Edited once, last by djurcich ().

  • @Demetris

    Thanks a lot for the great job you are doing....

    I have a question I have read all 49 pages.... but I think I cant find out witch one of the file I have to install (MXIII,S82 or X8-H plus) for a Neo X8-H.

    Please advise.

    Thanks again for the great job you are doing

  • I've had the X8-H (not the plus) before and I used the X8 builds from Surkovalex.

    Again, click on this link and you'll be redirected to Mega, and go to the 5.0.8 folder.

    OpenELEC-Amlogic.X8.arm- works on the X8 and X8-H.

    OpenELEC-Amlogic.X8P.arm- works on the X8 Plus.

    OpenELEC-Amlogic.X8HP.arm- works on the X8-H Plus.

    Again, these builds are the best ones I've ever tested, but it is still OpenElec version 5.0.

    Since, Surkovalex made some 6.0.x builds but they are less good.

    Then I sold my X8-H and now I've only got the X8-H Plus.

    None of the LibreElec builds I've ever tried have working Wi-Fi on the X8-H Plus.

    balbes150 just made a test build for the Minix:


    Since I haven't got the X8-H anymore, I cannot test it on that one. On the X8-H Plus, everything works except 4K, Bluetooth and Wi-Fi.

    If I would still have the X8-H then I'd try the LAN100 version balbes150 compiled, find it here: Yandex.Disk

    Latest version that works is in the 20170602 folder. The LAN1000 works on the Minix X8-H Plus, the LAN_100 should be worth a try on the X8-H.

  • It took a while, but now I have the update to kodi 17.3 on my Tronsmart MXIII. Thanks to Demetris and my colleague Tom. Nocompat and Demetris update, LibreELEC-S8X2.arm-8.0.2-, in the update folder and the remote.file of Beelink in the config files folder. Everything works. Top!

  • Finaly I found the correct LibreELEC from you thank you very much, I have ENY M8S (AP6330, 2GB/8GB, 10/100 Ethernet, n200 S812)

    I try lots of LibreELEC but I couldn't success, but your LibreELEC-S8X2.arm-8.0.2-MXIII-1G.img.gz is works perfect except power on/suspend.

    But wifi and bluetooth works perfect, tvheadend 4.2 too. But it's too hard to install at ENY M8S,

    1. Prepare SDCARD

    2. LibreELEC-S8X2.default.arm-7.0-devel-update download and unzip 2 files copy SDCARD

    3. Use toothpaste install developer version of Jarvis

    4. Download LibreELEC-S8X2.arm-8.0.2-MXIII-1G.tar or LibreELEC-S8X2.arm-8.0.2-MXIII-1G.img.gz copy to LibreELEC's update folder

    5. Reboot and LibreELEC 8.0.2 at ENY M8S

    Thank you very much Demetris!

    I hope power on and suspend will be patched :)

  • Hi Demetris,

    Thanks for the build, I have been testing on my MX3-G (8g/16g) device .

    DO you know if this supports 4K?

    I am seeing strange behavior when I switch to 4K res (3840 x 2160), the picture goes up to the top left.

    The same behavior happens when I leave the kodi interface @ 1080p resolution, and I play a 4K file. The picture goes small to the top left.

    I have tried with the Xonfluence skin and the stock Estuary skin - same issue.

    I have attached photos of the issue. Have you seen this before?

    As a note - when I run Kodi Krypton in the original Android ROM, on the same device, the 840 x 2160 resolution is not available to choose on the kodi interface. But when I play 4K movies, they play perfectly.

    Thanks for any advice!!



  • I will release a new version for all devices soon and no MX3-G doesnt support full 4k as hdmi port is only v1.4 and for that you need v2.0 as S905/12 has but these soc (S802/12) is way more powerful than any S905.

  • Thanks for your reply Demetris,

    Just to confirm - HDMI 1.4 is capable of running 4K @ 24 and 30 Hz.

    My MX3-G device plays 4K fine when using the stock Android firmware. So it is capable for sure, it just seems to have an issue with LIbreElec for some reason.

    I look forward to your new build to see if it solves the issue.

    Cheers, and thanks again for you time!