Gamestarter: Retrogaming add-ons (RPi/Generic)

  • Hello there! Great work! I finally manage to make almost everything work on my RPi4 (8Go) with last LibreElec. Still have to go into RetroArch to launch N64 game.

    For RetroArch I had to replace Ozone by XMB in the config file.

    The only minor problem I have is I cannot have RetroArch to list my N64 roms when scanning the directory... If I launch them they work, but it seems it do not recognise them automatically, I tried different version of the same rom, into or not into a zip, it do not recognise them as Nintendo 64 rom (or any kind). Any advice on that?


    Edit: In RetroArch I pressed on Update Info file and Update Database and now it's working...

    But now it's reverse, game are seen, put in the good categorie. But RetroArch just let me choose between 2 core (parallel and Mupen64-next) and when I want to launch game say "Cannot find core file"...

    I checked in ":~/.kodi/userdata/addon_data/game.retroarch/cores", all cores are here (and RetroArch seems to see them but cannot launche them...). I don't understand...

    Edited 2 times, last by dantahoua ().

  • I've just done a new install of Gamestarter on my RPi4 LibreELEC 9.2.3 install and get the same error when trying to start EmulationStation.

    EmulationStation is installed from GameStarter repository and is v8.201.1

    emulationstation_debug.log shows:

    ConfigPath /storage/.config/emulationstation
    lvl0: Error creating SDL window!
    Could not create GLES window surface
    lvl0: Renderer failed to initialize!
    lvl0: Window failed to initialize!

    emulationstation.log shows:

    EmulationStation [ADDON] :: Sat Jul 25 17:24:51 AEST 2020
    EmulationStation [ADDON] :: Firts Run!
    EmulationStation [ADDON] :: RPi
    EmulationStation [ADDON] :: Kodi is ready.
    EmulationStation [ADDON] :: RPi4.arm-9.2.3 - Sat Jul 25 17:24:55 AEST 2020
    EmulationStation [ADDON] :: Stop kodi...
    EmulationStation [ADDON] :: Launch EmulationStation (See process output in emulationstation_debug.log)
    EmulationStation [ADDON] :: Set LC_ALL=C
    EmulationStation [ADDON] :: Restart kodi...

    I can get RetroArch working and playing cores OK. LibreELEC works OK.

    Any pointers from anyone?

  • Any pointers from anyone?

    I m sure few posts back on this thread bite_your_idols was trying to get ES to work with RPi 4 with no success...on the other hand AEL and RA works fine and you can set them up with all the bells and whistles i.e artwork etc..

    edit it's post #1069

  • I m sure few posts back on this thread bite_your_idols was trying to get ES to work with RPi 4 with no success...on the other hand AEL and RA works fine and you can set them up with all the bells and whistles i.e artwork etc..

    edit it's post #1069

    Ah thanks. I wasn't quite sure if RPi4 was fully supported. I got RA working with the manual config change. I'd just switched over from the RetroELEC build which has ES, RA working on RPi4, so I'm sure it's possible. I'll just wait it out.


  • newbie first time poster here...

    Been looking around for a way to use RA on RPi4 running LE 9.2.5... basically wanna play N64 games on my RPi..

    Apologize if this has been discussed before but I can't seem to get it to work.. maybe someone can point me to the right direction

    Everytime I opened RA (9.186.20) it just gave me a blank screen. If I downgraded to 9.186.19 it would take me to the RA main screen and then rebooted back to kodi..

    I read somewhere that I have to change the menu driver to "xmb" from "ozone" to get it to work in RPi4.. tried that.. still no joy..

    I did a fresh install of RA 9.186.20 (most current version?) from Gamestarter Repo and ran it to capture the logs. I'm attaching the logs here..

    Any help is appreciated

  • heya, thanks for this repo.

    I'm new to retrogaming on LibreElec, so I'm a bit confused about the various options.

    I've installed MAME 2003 Plus with the builtin libreelec libretro support and I've a bunch of ROMs I can play.

    The only annoying thing for me is that I need to browse through them as .zip files.

    I'd like to have a GUI ROM browser that shows game names, metadata, screeshots, etc.

    What is the best way to achieve that?

    Do I need this repo? Or is there a simpler add-on in the standard add-on market?

    Thanks in advance,


  • Advanced Emulator Launcher and Retroarch from this Repo does what you want....

  • Hello

    I just added the Gamestarter Repo and I know want to install the RetroArch add-on, but unfortunately I don't see it on the repository. I attached a screenshot, I see the other add-ons on the repo, but not the RetroArch one. Am I doing something wrong?

    I'm on a Raspberry PI (I think Pi 3), running LibreElec (I think version 8.25). Should I update to LibreElec 9 maybe?

    Thanks for your help.

  • Any way to get this to work on non pi/x86 devices? I tried to launch this on my rock64 (RK3328) but it just goes to black screen and boots back to kodi. retroarch_debug errors out looking for /storage/.kodi/addons/game.retroarch/game.retroarch-RK3, which doesn't exist. I assume this device isn't supported, or I'm doing something wrong. Anything I can do to fix this/hack it together? Can't find any good solutions to get kodi and retroarch running simultaneously on this device.